Is there a way to repair a corrupted AUP3 file?

No time crunch here.

:blush: Well, that is a good thing. Due to a faulty assumption of my own, I had a problem with the upload. I am going to try this again, later. :blush:

No. I have not forgotten about you. :smiley: The second upload attempt failed due to a dropped network connection. :frowning: :astonished: :open_mouth: :angry: :cry:

So there is another one on the way. But it will take many many hours again - and that is assuming everything goes well. :wink:

Well, I can’t say I’ve ever had this much difficulty uploading a file: I got up in the middle of the night to check the completion of the transfer and found the upload was aborted due to another network failure. Anyway, at that time, I re-started they upload, yet another way. At this time, it is still running, but not even close to being done.

If this fails, I am going to try breaking the file apart into sections. :imp: :smiley:

OK, the tenth time is a charm! :smiley: I have PM’d you the link. :smiley:

Hello,
I have the same problem! When I try to open my file, it says, “Audacity failed to read from a file in C:.” with the following problem details posted below.
Can you please let me know how I can fix this? It looks like the previous user was able to successfully recover the file. I would be happy to send the file over if it is possible to look at it. Thank you.
{
“timestamp”: 1644362192,
“event_id”: “fe771912883f984888689e463167c9ea”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.22000”
}
},
“exception”: {
“values”: [
{
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”
}
}
}
]
}
}

Yes. There are instructions posted here: Corrupt or Otherwise Broken Audacity Project Recovery

THANK YOU!! It worked and I thought I had lost it forever!

Thanks for the report - we have been getting extremely favorable reviews on the success of this new repair facility. :smiley:

I’ve got this same issue cant pm anyone yet.
I tried using the repair tool but no luck.
Please can I zip this up for someone to try and fix?

Go ahead and zip it up, upload it to a public file sharing service and post a link. I’ll take a look at it.

[Edited] I see you have posted it elsewhere - I’ll update there: Corrupt or Otherwise Broken Audacity Project Recovery - #25 by Derick9184

Hey. I am having a similar issue. I tried using the recovery tool with no luck. I was wondering if anyone could help me. Thank you for any help you can give me.

https://drive.google.com/file/d/1N-YZyTebdaM0_uf4uZSO7k-4F463yqXe/view?usp=sharing

If the recovery tools fails for you, it is highly unlikely it will work for anyone else. However, I’ll try to give you a second opinion. Your file is large.
I’ll take a look at it tomorrow or Tuesday.

So I have uploaded a .recovered.aup3.zip file. I PM’d you the link. :smiley:

Thank you so much! You are an angel.

Happy to Help. :smiley:

Hi!
I have a similar problem. Worked a while on a project and suddenly my PC crashed. Even though I saved the file from time to time, the file can not be opened anymore. Error: Unable to work with the blockfiles.
Is there any chance for recovery?

Thanks in advance and all the best,
Nick

Yes. See the first post here: Corrupt or Otherwise Broken Audacity Project Recovery

Thanks for your reply!
I already tried the tool you mentioned.
Step 1 does not work - file doe not open with same error.
Step 2 terminates after some seconds giving this error: Executing query #2 (PRAGMA writable_schema = on;)…Unexpected lost_and_found structure

So, if you care to zip up your .aup3 project file and upload it to a public file sharing service, then PM me a link; I’ll have a look-see. However, it is most likely that I’ll only be able to confirm your issue.

I am a content creator that creates a podcast of approximately over 2 hours. I have poured my time and love into my work, and I put it everything on a hard drive.

Lately, these past couple of weeks, I have been noticing an issue with my hard drive. The Hard drive works perfectly well outside of Audacity 3.1.3, however, it seems like multiple 2 hour long Audacity projects don’t load at all. So I copy the file to my local computer hard drive. Windows creates the error Can’t read from source file or disk. However, if I load Audacity it says that it “Audacity failed to read from a file in ”.

Audacity always struggles to load in gigantic files, and that’s understandable: loading in GBs of data understandably take time, but when it seem to be failing for every large file, I am really concerned. Smaller files seem to work so far in my tests.

I notice another forum on loading on using your audacity repair tool, but the steps to do that involve copying those files from my hard drive into a downloads folder and renaming it. However, since every transport from the hard drive to the computer always fails, I can’t use that work around. Or, at least, everything I’ve tried for that has failed.

I really hope years worth of work hasn’t been lost, and if there’s anything I can do to recover all of those countless hours, I would be much obliged.

I recognize this is likely way out of your league, but if you have any suggestions or ideas, I would appreciate it!

I don’t think my hard drive itself is corrupted because I can read in some files just fine, but for some reason, there are a lot of seemingly corrupted files. Is there a way to fix this that you are aware of?