Is there a way to repair a corrupted AUP3 file?

Dear all.

Is there any way to repair a corrupted AUP3 file? Audacity cannot open it (Audacity 3.0.2 and Windows 10).
I don’t know waht happened, I hope it is not FUBARed since it is the work of several days and there is no backup.

If it is corrupted, then most likely no.
Why do you think it is corrupted?

Is that because you are short of disk space, or just that you didn’t expect that you would need one?
(Audacity now has an option to export a backup copy of the project)

Thanks for your answer steve.
I guess it is corrupted since Audacity is unable to open it.
A popup shows: Audacity failed to open a file in .

Where is ? Audacity can have troubles with network or cloud drives.


That is not the case, it is a local drive, I am afraid.
I tried to open the file after being copied in other local drives with no avail. Time to give up, I guess.

So have you closed it and reopened it over those several days - or just left it open all the time ?


First one.
I worked during several days on the file that got corrupted, closing/opening it every time I needed.

Hmmm so every other time it Saved and then re-opened OK - sadly I don’t think this will be recoverable.

For future reference, certainly each day as well as closing the project I would use File > Save Project > Backup Project to make a fresh safety copy each day (each with a slightly different name).

In fact I might make a couple of backup projects throughout each day at key stages.

And as a cautious individual I would check that the backup projects will open before moving on (just open it and than close it).



is the project small enough to send with WeTransfer, DropBox or similar?

If so I will send you my email address on a Forum PM if needed.

Update: our lead developer suggested - as the devs would very mucj like to examine this project:

Send Large Files - Free Secure File Transfer - TransferNow

Free 7 day trial allows 5GB transfers.

Question: was this project only ever worked on in 3.0.2 -or did it start off in 3.0.0 ?


Hi Peter.

It is about 9 GB, but I can provide you a link to download it, no problem.

The project started in Audacity 3.0.0 and I think it got corrupted at some point before the update to 3.0.2

Hi David,

thanks for offering to share the problem project.

I have sent you a PM on this Forum with my Audacity email address to effect the transfer.

Do you have somewhere to host this - or do you need us to provided some hosting for the transfer.



I’m really sorry about your losing the project and the time lost. Dmitry has had a good hard look at the .aup3 file (thank you for sharing) and I’ve been following along with what he has been doing. Using sqlite3 utilities he can get back about 70% of the small ‘blocks’ that make up the project, and we see the overall structure, but 30% of the blocks are gone for good. That makes continuing on with attempting to recover the audio pointless. The recovered project is going to be peppered with bad (silent) blocks and not usable.

Dmitry is looking deeper to see if there are ways to go and recover blocks from ‘free space’ but that is more from curiosity as to what’s possible. We’re both pretty sure such blocks will be inevitably damaged. It’s going to be best just to do as you are doing and rebuild from the original audio. Again, sorry.

What went wrong? There was a serious bug in 3.0.0 related to when the file system says it can’t write to a file. We were doing the default (on windows, trying three times) in 3.0.0. In 3.0.2 we do that and we also allow 5 seconds for the file system to catch up. That should fix that problem. We also fixed a problem at start up that I had thought just affected start up. It looks though that I was misreading the problem at the time, and that a bad start up could then lead on to problems later on, rather than just stopping Audacity from starting. We couldn’t tell from the damage to your aup3 file exactly what happened, only that the file had got corrupted and that blocks had been lost. Anyway, both those 3.0.0 problems are fixed in 3.0.2, though of course that does not bring back the lost blocks.

Paul is meanwhile looking at some of our current code again that handles macro commands when used from nyquist plug ins. Macro commands are handled differently there to how they are handled when used as macros, and he’s concerned that may be a problem.

In view of what Paul’s doing, it would be a help to know whether you used anything from the ‘Tools’ menu when doing the Primigenia.aup3 project. I’m expecting not, but if you did that makes Paul’s investigation more relevant.


Hi James.

Thank you for the detailed feedback I appreciatte that.

No need to apologise. My overall experience with Audacity has been and is so great to complain or need apologies for a single bugged file.

Thank you for the hard work with the software and for your selfless efforts trying to recover my file.

Answering your question, nope, I didn’t use any of the tools with the file.

Best regards.


Can I ask if you have a closer idea of what the cause of the issue was in this case? I find myself in a very similar situation: Upgraded to 3.0.2 (from 2.x) last weekend. Converted a bunch of files. Edited several hours on and off. Exported and closed one of those files - all just fine. Today I wanted to go back to it, and the file is corrupted, with the same error message. All the other files I converted and worked on are fine - but the main one is gone.
It’s not the end of the world, I have copies and I could go back and edit this again - I am just somewhat scared that this corruption will happen again in the future. So any light you could shed on what might cause this, so I can prevent a repeat occurence, would be very welcome … I did use a Macro for the Nyquist de-clicker on the file (but that would have been back in the 2.x version), and use macros a lot while editing (for cut/copy/paste/delete/amplify/label), just in case that makes a difference.

Many thanks!

Hi Lit,

I’d like to double check that you are on Windows. This report worries me because it is in 3.0.2 and suggests something other than the two known (and fixed) issues. The kinds of thing I am worrying about include powering down a computer after closing Audacity, but before Audacity has fully closed (and the progress dialog has finished). But it’s a long shot that that’s what you did and what did it.

The corruption happened on the 3.0.2 version, so Macro/Nyquist on 2.x is not going to be the cause. Are you using a standard hard drive or an SSD? It’s not that either type is implicated, but just gathering information that might be relevant.



I definitely didn’t shut down the computer; the file closed fine, there were no issues at all.

I’m working on Windows and my main drive is an SSD.



Thanks for sharing the project off-list.

It looks like something landed ‘splat’ in your project file, knocking out the start of a page that says where audio blocks are. That fits with what you report of the drop outs being random rather than the most recent edit(s) or from use of a specific effect. We think we can further improve the recovery process, but even a 90% recovery with random drop outs is a broken project, so improving recovery can only be one strand in our approach.

You asked if we know what could be causing it. No we don’t. Sqlite is widely used and extremely reliable, so we are pretty sure it’s something we are doing wrong. In my opinion we’re not going to find a quick fix and release a 3.0.3 with a good fix in in four weeks or so. We need instead to work on a range of things - testing tools that work on large files repeatedly - forensic tools so that we can examine broken project files more closely - built-in recovery within Audacity - more robustness to errors in our code.

The ‘more robustness’ to errors is probably what will eventually fix it. One possibility is that in rare circumstances Sqlite might use more memory than we have told it it is allowed to - and that when Sqlite runs out we just plough on, rather than stopping and keeping the project safe. We may have things wrong when multiple projects are open at the same time - we’ve had many problems with multiple projects open at the same time in the past. I would like us to reduce the size of the extra two files (the .wal and .shm files) that appear temporarily, as that will mean Audacity will have fewer large bursts of work to do. Paul would like to upgrade the Sqlite library to a more recent version, and I think that’s a good thing to do too.

My/our hope is that corrupted aup3 files with 3.0.2 are rare enough that this approach will work.


Hi @james,

I am having the same issue on my Aup3 file. I was working on a podcast that I originally recording off on Audacity. I did a few edits on it. Primarily just editing the noise reduction because there was some echo in the audio. I the. Saved it on my desktop and tried to reopen it and it says that the file cannot open. It looks like the file is corrupted. This was an interview a recorded for my podcast and unfortunately I cannot re-record it!! I know you were able to work with the previous corrupted file and recover some of it. Any chance you could please help worth mine? :pray:t4::pray:t4:

I know I’m on the windows portion of the forum, but I couldn’t find one for Mac that someone had reported.

Thank you!

Hi @james crook,

I have a similar issue. Corrupted AUP3 file.
It’s 7.5GB but I don’t mind to share if you guys want to try and find root cause.I managed to RAR it to 5.2GB
(I’m not asking for recovery at all. Just would like to contribute to awesome product. Happy to learn in this chat about backup :slight_smile: )

As far as I remember I never left audacity open while shutting down. Most recent action was:

  • Opened the application
  • Created a quick import from small MP3, cut some audio and exported.
  • All the above without saving.
  • Then I doubleclicked my massive AUP3 file and it crashed when audacity tried to open it with offer to save .zip file. (available if you need)

The large AUP3 has had multiple saves since 1 May. Unfortunately, I cannot remember if I used it before or after audacity 3.02.
It seems I upgraded to 3.02 on the same 1 May.
I dont use any other macros that doesn’t come in the box: noisy reduction, eq, amplify, compress. For compress I saved a preset which is something I’ve never done before).
Apart from that I cant think of anything different happening this time. I have 50GB free on the same SSD (win10) where I have the AUP3 file and audacity.

a) was this project originally created with 3.0.0
b) do you have access to any file sharing service which would enable yo to share this damaged project file so we can look at and possibley attempt to repair it for you.

You can communicate with me via PM on the Forum - and that way I can get you my Audacity email address.