Audacity 3.4 is out now!

Watch the release video!

We are excited to announce Audacity 3.4, which adds the following features:

  • Beats and measures grid: You can now easily align your audio clips to the musical tempo and rhythm of your project. The grid shows you the subdivisions of each measure depending on your zoom level, and you can snap your clips to the nearest beat.
  • Time stretching: You can now change the duration of your audio clips without affecting their pitch non-destructively. Audacity 3.4 uses a new time stretching algorithm specifically made for music, which outperforms many of the commercially available options.
  • New exporter: You now have all options for exporting in a single window, including advanced options for 5.1 exporting. The exporter now features the native file browser, giving you access to all your bookmarked folders.

A more detailed overview of these changes can be found in our changelog. You can download Audacity on


I was a bit disappointed with this installation. I installed 3.4 over the previous version and two things happened that I don’t recall occurring on previous installations, also done over previous versions. First, if I use the menu option “File → Import → Audio…” to open multiple files from the same folder, Audacity throws up a popup stating all files must be in the same folder (?). Second, when I import/open a single file, a .flac in this case, and attempt to export it as an .mp3 file, the preferences I had set in the previous version appear to have been wiped out. I’ve never had to revert back to a previous version, but I’ll be doing that in this case. Too bade, really; Audacity is a great tool.

P.S. Running Win10 64-bit

The exporter is completely new, that it doesn’t remember your settings from the old exporter is expected. Once you re-set it, it should remember it going forward though.

As for the import, I cannot reproduce that.

Just downloaded prior to doing a task to export mp3s of various mixes of vocal learning tracks, sincerely wish I hadn’t… It doesn’t appear to be possible to copy and paste from one track to another any more, ie to insert/correct something… am I missing something, or has that simple edit option been removed? Please bring it back ASAP if so, and please advise how I can revert a version as this functionality is essential to me :frowning:

OOps… think it might be a mono/stereo thing. I’ll stop panicking.

I replaced 3.4 with 3.3.3 and the import problem recurred. This made me think it was something with the files themselves, and sure enough I can import multiple files from all the other folders I tried. The problem files are in a folder I created just before updating to 3.4, and the download site was one I had not used previously. I also noticed a third issue when I imported a single file from the suspect folder, and that was the filename appeared in Audacity in the old 8 character format with a wildcard. Files from other folders appear with full filenames when I import those. It’s looking very much like Audacity is just fine, so I’ll delete the suspect folder, try again, and report back.


Edit: All’s well that ends well. No more import issues, and the filenames now appear normal. Two thumbs up, Audacity!

Edit #2: Spoke too soon. Audacity once again thinks the files are in different folders and refuses to import them, and importing a single file results in the 8-char filename thing I described above. Not sure what to do now.

Just downloaded the new version and found a strange bug - cracking sound while recording the mic. monotrack

  • Open monotrack
  • Open stereotrack
  • mute stereotrack (under normal curmustancies I have there short sounds to split mic recordings)
  • while recording mic sound with muted stereotrack I hear constant cracking sound in my hedset
  • the recoded voice is ok
  • if I unmute streotrack - cracking disappear and i have normal silence in headset.
  • if streotrack deleted - normal as well.
  • tested with existing Projects as well as completely new one.
  • also tried to remove Audacity and reinstall - same problem

I’ve been recording voice, using such configuration of tracks for years, with previous versions - never had that issue.

PC Dell XPS15
Win11 64
Audacity 3.4.0 English
Headset Logitech Pro X wired version (USB connection) with Logitech G HUB version 2023.9

1 Like

3.4 Amazing! Thank you all, for your hard work :slight_smile: Best wishes, Joseph.

I can’t record anything after updating to Audacity 3.4 on my Mac running OS 13.6.1.

I just installed Audacity 3.4 on my Mac running OS 13.6.1. (I haven’t upgraded to MacOS 14 yet since Audacity hasn’t been fully tested on it.) Now, I can’t record anything.

When I click the Recording Meter to start monitoring, the popup menu now says “Enable Silent Monitoring” instead of “Start Monitoring” (which I believe is what it used to say). When I click to Enable Silent Monitoring, the monitoring bar goes all the way up to red/clipped/0dB and just stays there. When I try recording, the track just shows a solid red bar of audio maxed out vertically on the dB scale. If I press Play, nothing I said was recorded, and instead it plays back a very loud, staccato noise, like a machine gun or loud machinery.

I’ve rescanned the audio devices, and I have the correct audio source selected (a Yamaha AG03MK2 audio interface). Even if I change the audio source to my MacBook Pro built-in mic, the same problem occurs.

I’ve tried restarting Audacity and my Mac, but the problem remains. I have no problem recording using other software. For now, I’ve reinstalled Audacity 3.3.3, so I can continue recording an audiobook.

Any advice or assistance would be appreciated.

~ Rob

I had the same problem. I installed 3.4.0 and found NO way to export to an MP3. Fortunately I always save a new version to a new folder; Audacity 3.3.3 was still there and is kindly exporting my MP3. This is NOT acceptable.

To export to MP3, go to File → Export Audio… and change the format to MP3 files


I have my problem solved with 3.3.3 now, but I’ll play with that when I’m not on a deadline…

that’s a good idea in general :slight_smile:

Will have to agree with hedera. The new exporting is requiring a lot more work and the most of the results after exporting is gone versus the previous version. This is a giant step backwards for me. Wish i had kept previous version.

1 Like

I am having the exact same problem as Rob when I tried to record on my PC with windows 11.

On this new version I have attempted to export my tracks based on labels at 24-bit/96khz and have selected this, but it’s automatically reduced this to 24-bit/44.1khz despite having the project set differently. This seems to be a bug in the system, please address it as soon as you’re able.

My project is in the sample rate of 96000 khz and it’s been selected on the export menu.

1 Like

@jasonmaska This will be fixed in 3.4.1
@Rob This seems to be because you’re recording in 24 bit. It will also be fixed in 3.4.1. In the meantime, you can record in 32 bit, 16 bit or use 3.3.3.
@Badger We’re looking in to that issue but so far I haven’t been able to reproduce it myself yet.

1 Like

For metadata, “Set default” no longer works. If I have clicked on “Set default” for a file, all fields are empty again for the next file. That’s why I went back to 3.3.3 for the time being.

1 Like

After installing 3.4 I can’t remove paste lines after editing clips into my track. What am I missing?

1 Like