LABEL SOUNDS no longer works

In 3.4.0, 3.4.1 and 3.4.2, LABEL SOUNDS no longer works with the parameters I have always used.
It just does not find any breaks in tracks.
I have tried experimenting changing the parameters but … nothing.
Any help with this would be much appreciated.
It just looks like a recently introduced bug to me but if so I am surprised it hasn’t been fixed in the .1 or .2 releases

Hello canyelles,

I’ve noticed that too.

I have already noted the bug in this post. The malfunction was also confirmed to me by jademan. But the developers rarely seem to read the forum.

Maybe my workaround will help you: Switch off the Sync-Loc and let the “Label Sounds” function create its own label tracks.

Best regards

Thanks double07

Unfortunately sync-loc did not work for me. I am not doing anything complicated, digitising old records mainly.

Will stick to 3.3.3 for the moment

Testing on W10 with 3.4.2

Label sounds works fine for me:


Yes, I can get it to work as well under certain circumstances, I now see.

However I seem to be doing something that stops it working - I routinely cut silence at the beginning and manually make a label at the beginning. After that label sounds doesn’t appear to work. It used to on earlier versions

I am on macOS Sonoma but I’m sure that’s not relevant.

Hello Peter,

can you try this with an existing label track, as described here?

Thank you very much!


Hi Christian,

works for me:

BUT only if I select just the audio track. IF I select the audio and label tracks THEN it fails to work.

This looks like a minor bug to me - I’ll need to test to see if it’s a regression (i.e. worked in an earlier Audacity version) - and if it’s not logged already I’ll log it on Muse’s bug log on GitHub.

I’m not sure what expected/desired behavior is - but is should work and either create a new label track or add the labels to the existing label track - I can see benefits of either way.



well it certainly works in 2.4.2 where, if you select both the audio track and the label track the Label Sounds adds to the existing label track:

So this is indeed a regression - I need to do some more work to find which release introduce the bug before logging it.


It’s a regression on 3.3.3, introduced in the recent 3.4.0

I’ll get on and log this later.

Good catch Christian, many thanks for the report :sunglasses:


Hello Peter,

Thank you for taking a look at this!

Best Regards

1 Like

Logged as:
Label Sounds fails if the selection also includes a label track #5648


This topic was automatically closed after 30 days. New replies are no longer allowed.