How to put Audacity in your dock and use microphone in 10.15 Catalina

Hey everyone,

I’ve found a way to launch Audacity from the dock, with proper microphone permissions and all. It will still run the Terminal in the background and is a bit hacky, but it should work.

Step 1: Go to Launchpad > Other and open Script Editor. Create a new document, and paste the following:

do shell script "open /Applications/"

Click “Save”, and save as an Application. Call it Launch, and save it in your Applications folder.

Step 2: Go to Applications >, right click it and choose “Show Package Contents”. Go to Contents > Resources and find Audacity.icns.

Open a new Finder window and go to Applications > Launch Right click and choose Get Info. Drag Audacity.icns onto the default app icon, and close the window. Drag Launch into your dock.

Hope this helps!

I just had created an Automator app as a launcher and was going to offer it. Yours sounds better.

Thanks for the tip picpak. I’ve not tried it myself as I’ve not yet updated to Catalina, but it sounds like it could be a good workaround.
I’ve “pinned” this topic so that it stays at the top of the macOS forum board for now, so that others can find it easily and say if your workaround works for them.

Some of my files open fine with this, but some just don’t open. Is there another workaround I’m unaware of?

I expect that is due to an unrelated issue. Please start a new topic so that this forum thread remains on the original subject of launching Audacity on Catalina.

Audacity 2.3.2 on Mac OS Catalina 10.15

I just updated my oS and installed Audacity last night. I have a blue yeti mic and checked inside the audio app on my mac that it produces sound/is connected properly. Audacity acknowledges it under the mic dropdown. I spent all day troubleshooting. Sure enough, under security>microphone there is no permission box to check. I nearly gave up and found this thread! There is hope. However, I tried this workaround and still get the thin blue line, indicating no sound is being picked up. I am new to my mac and audacity so the lingo and platform is very unfamiliar so please reply clearly and simply for a middle-aged non-techy mom who’s trying to help their kid with a school project. Here’s what I did:

I got as far as the script code, entered it, saved it as instructed. Then opened a new finder window, went to applications > launch I right clicked to get info.

This next part was where I was unsure: “drag audacity.icns onto the default app icon” (I took this to mean the audacity headphones app inside the applications folder. I then closed the window as instructed.

when I opened audacity, I got an error–some files couldn’t be opened (like a dumb-dumb I clicked away and the error disappeared. Not sure how to find out what it said.) I tried recording again and still get the blue line.

I would like to be able to record sound. Any and all help is appreciated.

Oh thank you so much! I have been trying for days to get this to work. And your fix did the trick in seconds. Much appreciated

I prefer the Automator version, just for simplicity. In case anybody else does, here are the steps:

  1. Open Automator
  2. Choose Application as document type
    Screenshot 2019-11-01 at 10.01.10 AM.png
  3. Drag Run Shell Script to grey space on right
    Screenshot 2019-11-01 at 10.06.38 AM.png
  4. Type
open /Applications/

into Run Shell Script textfield
Screenshot 2019-11-01 at 10.11.39 AM.png
5. Drag Run Apple Script to grey space on right, below the Shell Script Code
6. Type

on run {input, parameters}
tell application "System Events"
set visible of application process "Terminal" to false
end try
end tell
return input
end run

into Run Apple Script textfield
Screenshot 2019-11-01 at 10.17.31 AM.png
7. Save and use just like an application

The Shell script starts audacity via Terminal app. The Apple script just minimizes the Terminal app.

I simply installed it on Catalinea 10.15.1 and it immediately opened (without any problem) … I think that this problem of opening it on Catalina has been officially resolved (to correct the website) :wink:

This morning I upgraded to 10.15.1 for QA testing.

I can confirm:

a) Audacity can still be launched and run from the Applications folder
but this way recording from mic or USB device remains blocked

b) Using our published workaround, launching from the Terminal app also
launches and runs properly with recording working properly.


Hi, Im new to this forum, I updated to Catalina as I was unaware that Audacity would not work with it only to find out I couldn’t record. I am running the latest Audacity and everything is fully upto date on my Imac. I have tried to use the “workaround” - open /Applications/ but it doesn’t seem to work for me. Is there something Im doing wrong?

In what way does it “not work”? What happens?

I get the following when I try inputting open /Applications/ in the terminal even though my Audacity 2.3.2 is in the applications folder.

-bash: open: command not found

Any clue what I’m doing wrong?

I’m also getting the following when I try to open a saved Audacity file.

Could not open file: /Users/dperkins/Documents/podcasts/Houston Kraft.aup

Wondering if that’s related…assuming it is since that’s new after the Catalina update.

I made small APP for permission start on a microphone.

I have removed the attachment due to the negative results returned by virustotal:

While the detected malware results may be false positives, as the administrator of this forum I cannot take the chance of putting our visitors at risk.


Need help ASAP, not tech savy what’s so ever but I have used the recommended scripts to put into Terminal and did all the workarounds on the forum. All it does for me is open up Audacity with no pop up window with permission to access microphone. I have MacOS 10.15 updated, and I have the newest version of Audacity. In my system preferences, Audacity already has permission to use microphone also. Everything is up to date. I can upload audio files I just can’t record with my microphone. I really need help.

Same here! Really need some good advice, done everything I found and Audacity still not recording

For me, the pop-up appeared when I clicked the record button for the first time. After that, I still need to launch Audacity from a Terminal window, but there’s no more prompting for access to the microphone (the Terminal acquired access to the microphone the first time), and Audacity can record.

There are of course other reasons why Audacity might not be able to record. The “Terminal” workaround only solves the microphone permissions problem, not “all possible recording problems”.

Hmmm. Tried everything hirnhorn recommended, exactly as listed, as well as the other work arounds, but no luck. I am at a loss. Any other suggestions?