Catalina + 2.4.2 + No Line In Detection

Hi there. Longtime Audacity user, first time needing to post in the forum. I’m running MacOS 10.15.7 and Audacity 2.4.2.

I’ve got the common current issue of not being able to record, but only from a line input from a tape deck. This is the case on my MacBook Pro 2018 and MacBook Pro 2014 (identical Catalinas), MacBook Air 2011 (Mavericks), and an HP laptop of unknown vintage running Windows 10. Each has the latest version of Audacity, and the MacBooks have access to the mic checked in the Security system preference. I’ve checked that the tape deck is outputting sound and that the Y cable is good (records fine into a mini digital recorder). The MacBook Pros, at least, are able to record some sound in Audacity; the source is “Built-In Microphone”, and it does indeed pick up spoken sound or knocks on the computer shell. It’s as if the audio port is only recognized as a headphone jack now.

I’ve tried running via the Terminal (and iTerm 2, if that matters), but no difference. (cf

I’ve tried downloading 2.4.2 anew and installing over the existing 2.4.2, but no difference (cf

One of the MacBook Pros had BlackHole installed, but it’s been rooted out, as far as I can tell.

Is there a piece of the puzzle I’m missing? Like, a plugin or something that is necessary?

In System Preferences > Sound > Input do any of those Macs show a Line Input available?
– Bill


Not at all. I get Internal Microphone for the older MBP and the Air, and MacBook Microphone for the newer MBP. The implication here is probably that I won’t be able to get line in on a device that doesn’t recognize itself as having a Line Input, which makes sense.

Sometimes I forget the basics, but this helped me to search a little differently and now I’ve found good information out there on what’s going on with the MacBook Pro audio port.