Envelope Tool randomly creating envelopes throughout audio

I am using audacity edit audio on a MacOS Monterey (Version 12.6). I have the latest version of audacity installed (installed using chrome).
I am having two reoccurring issues which are causing huge delays in my work:

  1. when I make an edit (cut / envelope / paste - any type of edit) to a track, the envelope tool will occasionally randomly place multiple envelopes throughout the audio.
    If I don’t notice this happen (when zoomed in and working on small segments of wave), I have to then either undo the work I have done (to remove the additional envelopes), or I have togo through the entire audio and remove the individual unwanted envelopes.
    Both are time consuming.

  2. I have to close down audacity completely and “quit” from the dock every time I want to open a new file to work on.
    Again, this is time consuming and it also means if I am unable to work on multiple files simultaneously.

Any suggestions as to how I can remove these bugs are welcome!


See screen grab!!
It just happened again - I cut and pasted a tiny piece of wave and pasted it elsewhere on the same track and then all these random envelopes appeared!

Now I either have to undo my cut and paste (and save and close the project - to reopen it again to work on)
OR, I have to go through each individual envelope and remove them individually :frowning:
Screen Shot 2022-11-20 at 4.53.52 pm.jpg

Apparently there is a quick solution, see … https://forum.audacityteam.org/t/how-to-solve-envelope-tool-problem-solved/62655/2

Thank you


I HAVE JUST DELETED 3.2.1 (after trying to re-download it and coming across the same issue)

What do you mean by “using chrome”?

The multiple-envelope-points bug was fixed in Audacity 3.0.4, so installing a version older than 3.2.1 probably won’t help.

Do you have this problem with a brand-new project containing no envelope points?

In any case, older versions of Audacity are available here.

– Bill

Thanks Bill. I mean I downloaded audacity on the Chrome browser.

The problem occurs on multiple projects that I am working on. This could mean that some of those projects have zero envelope points but where I have made other edits such as cut and paste or splitting tracks. Some projects have a couple of envelope points that I have manually added (no more than 3 or 4 total).

what appears to be happening is that after making an edit, such as cutting and pasting a section of a sound wave (whether on a single track or multiple tracks), numerous random envelope points appear dotted throughout the entire length of the audio.

I am yet to find a workable solution

OK, so that’s the web version of Audacity? That is based on an older version of the Audacity code, if I remember correctly.

I’d recommend downloading, installing and running the latest stand-alone version of Audacity from here.

– Bill

Hi Bill,
Apologies, I meant i used chrome to download the latest installed version (not the web version).

Would it be worth me trying the web version instead?

Hi Bill,

I have tried versions 3.2.0 and 3.1.1 and I am still having the same problem, where when I edit the audio, it is adding envelopes randomly, sometimes hundreds or thousands are added. I have tried the solution suggested by Trebor and that does work to remove the envelopes but obviously that also removes ones that I have intentionally put there.

All of the audacity projects that are having this problem were all edited initially on older versions of audacity, so they may have been started or edited using 3.0.4

Is it possible that there is something in the project files themselves that could be causing this problem? I have tried re-saving one of the projects with 3.2.1 but I still have the problem when I go to make an edit (any edit, whether it be cut, paste, split audio etc) that envelopes randomly appear on the track/s that I am editing.

Or could there be some files left on my mac after I delete audacity from the applications and install a different version? I notice that after reinstalling it, it knows what my recent files were (“open recent”), so there must be some files left somewhere on my hard drive.

I have tried creating a new project file with two separate tracks of raw audio and I noticed that if I insert envelopes on the track, when I make edits elsewhere on the track (cut / paste / split / join etc), the envelopes on that track disappear. Only the envelopes on the track that I edit disappear, they remain on the other tracks.

Just as an extra piece of information, I have tried both x86_64 and arm64 versions of 3.2.1 with the same results.

Thanks for your help,


It is quite possible that there is something wrong with those old projects that is causing the multiple-envelope bug to keep appearing, although (as far as I know) the bug was in Audacity, and should not occur when using versions of Audacity later than 3.0.4.

I’m not recommending that you use the web version of Audacity - quite the opposite.

I cannot reproduce the problem with a new project with “raw” audio using Audacity 3.2.1 on a Macbook Air running macOS 13.0.1. For example:

Before deleting audio from Track1 (using the Multi-tool so I can watch the envelope points while editing the audio)
Screenshot 2022-11-21 at 6.02.00 PM.png
After deleting some audio in Track1
Screenshot 2022-11-21 at 6.02.30 PM.png

Yes, so I am also unable to reproduce this issue on 3.2.1 with Windows when I use Generate to create two new tracks in a new project.

If you care to, please provide detailed instructions on how to reproduce the issue and/or upload your project then post or PM me a link. I’ll take a look at it; however, possibly not until after Turkey Day = Thanksgiving here in the states.

Hi both,

There are no specifics as to when this happens - it just occurs randomly (it could be 3 edits in or 10 edits in). This is what makes it particularly frustrating as when I am zoomed into a particular section of the wave and making many meticulous edits, I zoom out and find multiple envelopes on the track. It means undoing all of my work.

Unfortunately I am unable to share the audio I am working on.

Do you have any other suggestions?
I have used the Nyquist prompt and whilst it works to initially resolve the issue at the time, more envelopes reoccur later. This is not a solution for me because I need to add a few envelopes and end up losing them with the Nyquist prompt

Hi Just adding an update - the envelope points that I have created disappear when I cut and paste a small bit of audio. I am cutting and pasting from two tracks simultaneously and the envelope points on both tracks didappear.

Yes. So zip up your .aup3 file then upload your .zip file to a public file sharing service. Post instructions on how to reproduce the error, and PM me the link to your shared file.

From PM:

So I took a quick look at your project today, and I saw the issue but was not able to reproduce it immediately. I noticed that some of your clips are expandable “smart clips”, which may or not be related to the issue at hand.
I’ll take a deeper look into this tomorrow, but in the meantime can you try doing a mix-and-render on each of the three tracks? First backup the project. Then just select a track, then do Tracks > Mix > Mix and Render. Do this one track at a time - it should keep your project intact, yet remove all of the smart clips, and it will should render out all of your envelope points.

Hi Jademan,

Thank you - have done the mix and render. So much easier to work on the audio again.

I also noticed when I was editing just now that when I made an edit on one of the tracks the envelope points that I had put in (not the random ones) remained at the same time point and not moved with the audio track (so they end up being in the wrong place on the audio).

Could this be something to do with them being expandable “smart clips” (not sure how I have done this)?


So I spent a little time on this today and reported a (clear and mostly repeatable) problem to the developers relating to copying selections containing envelope points, possibly the cause of your difficulties. Later…

Hi Jademan

Thanks for taking the time to look into this.

For now, what would you recommend as a work-around so that I can continue with my editing?

Do you think it would eliminate the problem if I do the mix and render on each track before continuing?

Absolutely! And it seem to work for you yesterday. :wink: