You ruined this software [CLOSED]

I have never done this before, but I have to. I have to tell it to your face. You have destroyed Audacity. It used to be the best lightweight editor ever, but now is unusable garbage. Nothing works. Only get errors upon errors about sample rates… -9997, even though the sample rates match that other applications have no problems with. This only happens if I try to add another layer when recoding. Even after finding a hacky workaround I have new problems pop up, such as the volume being extremely low no matter what I do. It just doesn’t stop.

Heck even this forum doesn’t work. I tried to register with a Hotmail account, but the emails never came (not in spam either) so I had to use Gmail instead. I mean, come on, really?

You wanted a review, so here it is. I want you to feel bad about this, because you should.

I am not a troll either. I mean it. I am sad to see this happen and hope you are ashamed. :confused:

Oooh, you censor. Well never mind then. You are obviously not going to approve this. Well, whatever.

It is a forum. You have to wait for a forum elf to log in. No new user posts immediately.

You missed the “Save Project?” nag message.


Unfortunately that’s a problem with Hotmail - they frequently block emails that are sent from forum software.

This error is about your computer sound system. When playing back and recording at the same time, the sample rates must match for the recording device (Windows sound settings), the playback device (Windows sound settings), and Audacity (“Project Rate” in lower left corner of the main Audacity window).

Do those “other application” record and play back at the same time?

Which version of Audacity?
In the most recent version the playback volume in Audacity should normally be set full up (max volume), then it is entirely down to the computer sound system to control the levels.

I understand your frustration, but it seems that most of the problems that you have mentioned are about configuring the Windows sound system correctly. We can probably help you with that if you are still having difficulty.

There’s no reason why “we” should feel bad - this is an Audacity community help forum. “We” are Audacity users, just like you, that spend some of our free time trying to help other members of the Audacity community.

I was pleased to find some dirt on Audacity because it just crashed with no apparent reason, ruining 2 hours of my work.

I love its simple workflow. I hate when it crashes. I’m torn between “just hit delete and move to Audition” and “Audacity is better than Audition in many respects”.

What do I tell you?

Please continue the good work. I’m now going to walk for another 2 hours to let the steam off.

Perhaps you could tell us:

  • Which version of Audacity you are using
  • Which version of Windows
  • Precisely what you were doing when Audacity crashed (for example, if you were applying an effect)
  • A bit about the project (number of tracks, length of tracks, overall project size)
  • What precisely happened when you restarted Audacity (Audacity is usually able to recover the project after a crash / incorrect shutdown)

(Needless to say, it is highly recommended to make regular backups when doing any important work on a computer)

Audacity 3.2 (most up to date)
Windows 10 Pro 19044.1706

This is what happened.
1/ I recorded WAVs with Roland R-05 (96khz, 24bit). Files were split by ~2GB, it had 22 GB in total. The source signal was from a tape deck. I’m digitizing old lectures. One tape side = one lecture.
2/ I donť have enough space on my internal ssd, so I placed it all on an external ssd (Sandisk Extreme, 1TB, exfat).
3/ In order not to run out of space, I set audacity’s working directory location on the external ssd as well. Of course, I did it beforehand and restarted the program properly.
4/ I imported the files into Audacity (drag & drop). I marked individual tracks (perhaps 10 tracks in ~12 hours) with labels.
5/ When I wanted to apply some basic corrections (amplify, denoise), Audacity started to give me errors “Can’t read from file S:/…” with “S:” being the letter of the external ssd.
6/ After several attempts to apply some effects, Audacity crashed. I started it again and tried to export the labels as WAVs but Audacity kept giving me that error message and some other, too.
7/ I must emphasize that there doesn’t seem to be any problem with the SSD nor with the original files. I imported it successfully to Audition.
8/ I restarted Audacity several times. Each time I was able to playback the audio within audacity but unable to export it as WAV or FLAC. At one moment I deleted one clip, imported the source file again and voila, it worked. This is why I suspect that the error occurred only once within Audacity’s project file.

I’m now giving it another try. Of course, I still have those source files. Audacity still seems to have the best workflow for this project. But the crash… ouch…it still hurts. I hope it doesn’t happen again.

Sorry! It was Audacity 3.1.3!

Note that this error is a symptom of a corrupted file - which in most cases can be repaired. See:

In the later versions of Audacity including 3.1.3 there is a useful command called File > Save Project > Backup Project…

This enables you to save a backup (or backups) of your project at useful intermediate stages as you work on a project.


As jademan wrote, see:

How is that connected to the computer?

Working on Audacity projects on external drives is not recommended. Sometimes it will work OK, but other times you can get database corruption, which is quite likely what has happened to your project. It’s fine to move a project to an external drive, even a network drive, once Audacity has been closed, but highly recommended to move it back to a local drive before opening again.

It was connected through USB. Ok, I’ll free some space up and tell you if something changed.

If I might be so bold, what exactly about the changes you made to the program caused this to be an issue? I was using the service before the software was sold and there were no problems. Now once every two or three times I do this I end up having to do seven workarounds in order to deal with this problem, especially since it still happens on the computer itself sometimes. It’s unpredictable and erratic and new.

Who? Me? It has nothing to do with me. I just look after this community forum and help people where I can.

As Steve indicates, this is a community forum - the developers rarely view this forum. You are more likely to find them on or on Audacity dev discord.

I would like to react on this topic too. This is just My opinion and if you’d like to ban me, I’ll accept It as It is normal thing.
Some days Audacity was great. But some features, like I have mentioned in one topics are very badly included to Audacity. For example, one VST3 effects feature.

Of course, connecting with was great idea. But It is normal, if same people owns Audacity, and also, Musescore. So, It is of course normal. But really, some features are not managed very well.

For example, to type numbers in time field I must switch keyboard layout to English, because of number row. In Slovak keyboard layout, We can use shift and up arrow keys to type numbers.

That’s My opinion about It. But, I don’t want to move to another software. I still like Audacity.

Don’t worry, we don’t ban people from the forum for discussing Audacity, or for constructive criticism.

We do ban people for spamming, trolling, being abusive, excessive vulgarity, or other behaviour that is obviously unsuitable for a family friendly help forum.

The forum is intended to be a safe corner of cyberspace where members of the Audacity community can help each other to use Audacity effectively. All of the regular crew are experienced Audacity users. Ideas / suggestions for improving Audacity are welcome, as are bug reports, questions about how to use specific features, and so on.

Audacity “should” work with a Slovak keyboard, provided that the system is configured correctly for a Slovak keyboard.
I don’t have a Slovak keyboard to test with, but I can imagine that their may be bugs that cause problems with Slovak keyboards because Audacity uses the Shift key as a “modifier” for many keyboard shortcuts.

Is it possible to work around this problem by using “Shift Lock” to type numbers instead of “Shift”?

No. There is only possibility to use those keys without shift and It behave, as keyboard with numbers. Due to this, I must use English keyboard, because It is sometimes confusing.

Hi All, complements of the season to everyone…

It has been a very long time since I last needed to use Audacity, and what I remembered and what I experienced is not the same, the software has taken a development path a long way to not being functional…

1: I would have thought that it would have been somewhat of a standard now across the NLE industry, that I key-In point, O-Out point, B-blade=split the track at this point, delete, delete any highlighted clips…

2: The 4 cursor keys would have some function, <-move 1 sample left, > move 1 sample right, and not at 1 sample per second which makes the app non functional… The Cursor up and down, adjust the volume up and down, would have assumed this as a standard as that is how it works on other apps…

Audacity used to be a fast, reliable, competent app, now it is not sure, you see as a tv news video editor, I am looking for a lightweight easy to use video editing app, and Lumafusion on Android/IOS is that, but it is not, it has a major flaw, that is there is no way to zoom in on wave forms, you are stuck due to AVFOUNDATION to a zoom level of 1 frame width, there is no way to resolve an audio waverform closer than 1/60th of a video frame, for tv news editing, this is impossible to edit with this level…

I have a brand new M1 Macbook Air, 8GB RAM, so what I was hoping, with using Audacity, is that I “cut” the interviews and voice overs in Audacity, create a bunch of split clips, and import the split clips as a series of single clips, Project 1_1.wav, Project 1_2.wav, or Project, Project etc With the .wav being the voice over edited so that the mistakes are taken out, as a series of split clips, and the .mov, interviews split and imported into Lumafusion…

But no, Audacity does not one, sure it splits, but the moving the vertical thin black line marker thing, at 1 sample per second on a 64bit brand new machine… Not a great solution, how did this happen? What went wrong?

To me the biggest failure of Audacity is that once you start zooming in to the waveform, you loose all sense of location within the wave-form, there is no fixed full timeline view with a timeline indicator as to where you are on the time-line, and it gets so confusing what scale you have zoomed into…The vertical thin black line with the finger icon, no idea what or how to control this, and it moves so slowly, when you are trying to highlight something, it crawls at 1 pixel per second, per real time second across the screen…

Can we maybe add some sort of “shift+” turbo button, to go from 1 pixel per real life second, to 1 pixel every 1/10th of a real time second, 10times more ground covered in a real life second of time… a bit more hare, less dead whale…