wxWidgets debugging check failed on opening Audacity

I am using Audacity 2.3.2 on Windows 10.

When I open Audacity, I immediately get two messages that say : “wxWidgets Debug Alert - A debugging check in this application has failed…” and shows a bunch of info which you can see in the screenshots. The 2 messages are identical and the second one appears the instant I close the first one.

Does anyone know why this happens?
audacity bug 02.PNG

This is a known issue that affects a small number of users. Unfortunately, none of the Audacity developers or testers have been able to reproduce the problem. The message arises from wxWidgets, which is a software library that Audacity uses, and is probably due to a minor bug in that library.

The issue is logged on the Audacity bug tracker, and I will add a note that another case has been reported.

From previous reports, it seems that while this issue is annoying, it is harmless. If you click the “Continue” button (may need to click it several times), the error will clear and Audacity will function correctly.

Eeek, just got this today. Is downgrading to 2.2.2 just a matter of installing over 2.3.2? Windows 10 home here.

If you use the “EXE” installer version, and use the default installation location, then you can overwrite a previous version by running the installer of another version.

Please confirm whether downgrading to 2.2.2 fixes the issue for you. If it does, then it may be worth trying the new beta version (which is currently in it’s late stages of testing prior to release).

I have also been receiving the same error message. I tried 2.2.2 and then 2.3.3. Then I uninstalled both - there were 2 folders in the Windows86 folder. I removed the folder as well. I reinstalled 2.3.3 and I received the same message. I’ve attached a screen shot of the error which is the same as yours. I don’t know what else to do. :frowning:
Audacity Error.jpg

Click the “Continue” button. You may need to click it more than once.

Which version of Windows do you have?

Windows 10. I do press continue until it clears. Just wasn’t sure it wasn’t messing with the program.

That’s good - the issue is what I thought it was.
This is a known issue that occurs for a few users. We think it occurs if the computer has an incompatible version of FFmpeg installed as well as the correct version.

Take a look in “C:\Program Files (x86)\FFmpeg for Audacity” and tell me what you see in that folder.

(Link to relevant bug tracker so that I don’t have to search for this again: https://bugzilla.audacityteam.org/show_bug.cgi?id=2074#c12)


Here is a screen capture of the folder. Do I need a newer version?

Patricia Callow
Boise, ID
Ffmpeg capture.JPG

I think that looks OK.
Do you have any other versions of FFmpeg installed? (look in “**C:\Program Files (x86)*" and "**C:\Program Files*”)


I did a search in both folders. It looks like Any Video Converter and Skype may also have that file. Also something in Windows and Avast.
I’ve attached screen shots as I’m not sure what you need to see. Thanks for the help. Patricia
Audacity Error FFmpeg3.JPG
Audacity Error FFmpeg2.JPG
Audacity Error FFmpeg.JPG

Neither am I. For some reason, it appears that Audacity is attempting to load the wrong version of FFmpeg before loading the correct version. I’m looking for anything that might give a clue as to why that is happening on a few machines (including yours) but not others.

One thing that you could check. Look in “Edit menu > Preferences > Libraries”. Then, while taking care to not change anything:

  1. Click the “locate” button in the “FFmpeg” section
  2. Copy the location address
  3. Click the Cancel button
  4. cancel out of the Preferences dialog
  5. Paste the copied address into your reply.


Here you go. I found it under Edit / Preferences / Libraries. I notice it is dated 2014. It does have a button to obtain a current copy. Hope the screen shots help. Thanks again for pursuing this. Patricia
FFmpeg location4.JPG
FFmpeg location3.JPG
FFmpeg location2.JPG
FFmpeg location1.JPG

From the comments on the bug tracker, I was expecting to be able to recognise what was wrong, but I don’t. I must be missing something because everything looks OK as far as I can see. Hopefully there’s sufficient information in this thread that someone will be able to spot the problem.

Is the problem still happening in Audacity 2.3.3?

Hello, I was able to fix it on my system and figured it would be worth sharing (I was browsing the web for a solution to this as I had the same problem and came across this thread). I am currently running Audacity 2.3.3 on Windows 10 Professional edition.

I navigated to *C:\Program Files (x86)\FFmpeg for Audacity* and used the uninstall tool. In my particular system I also have an extra storage hard drive and found another instance of FFmpeg installed there and I uninstalled that as well. I must’ve installed it there at some point in the past and forgot about it. I also uninstalled any old, separate installations of LAME that I had neglected to remove ever since LAME was built into Audacity. After uninstalling all of these, I reinstalled Audacity itself. After doing so, I reinstalled FFmpeg. The problem that OP and I were experiencing did not appear any more.

Hope this works for others :slight_smile:

Thanks for the update haiichuu :sunglasses:

I have added your comments about multiple FFmpeg installations to the bug thread : https://bugzilla.audacityteam.org/show_bug.cgi?id=2074


I also ran into this problem with 2.3.3 on Windows 10 today. I had Audacity 2.2.2 on a Windows 7 PC that worked great for several years, and today I moved it to a new Windows 10 PC and started getting two of those same wxwidget popups when launching Audacity 2.3.3. Here is what I observed up until it started working:

  1. The W7 with Audacity 2.2.2 had NO FFmpeg installed at all, just LAME 3.99.3. No issues.
  2. Installed 2.2.2 on W10 and overlaid relevant info in audacity.cfg and brought over the entire “Chains” folder with what was on the W7 machine to attempt to restore same functionality. No issues.
  3. Installed 2.3.3 over 2.2.2 on W10. Got wxwidget errors. I had NO FFmpeg installed anywhere on the W10 machine at the time, just LAME like on the W7.
  4. Installed FFmpeg from recommended site and into Program Files(x86) as recommended. Same errors. Pointed Audacity to it in “Libraries” preferences, got same errors after reboot and launch.
  5. Uninstalled 2.3.3, and deleted Audacity folders from Program Files(x86) and Appdata Roaming folder. Rebooted.
  6. Installed 2.3.3 again with “Reset preferences” checked. Checked “Libraries” in preferences and it found both FFmpeg and LAME libraries on its own, as I didn’t delete them. No problems launching.
  7. Tried restoring relevant info into audacity.cfg again, this triggered the same wxwidget errors again on launch.
  8. Put audacity.cfg back to what it was, No errors.

At that point I stopped messing with the .cfg file and instead went manually through the preferences screens and made the settings match the other machine. I was too relieved to debug it any further and am continuing to cross my fingers!
So in my case it looks like there was something in that .cfg file brought over from the v2.2.2 on Windows 7 machine that caused the problem… although I don’t see anything in there referencing FFmpeg.

Hope this helps.

Do you still have that .cfg file? I’d be very interested in trying to work out exactly what caused the problem - it sounds like something needs to be fixed.

Here is the original .cfg from the v2.2.2 on the Windows 7 machine… I must apologize, there IS a reference to FFmpeg in there, I must have fat fingered something in the search. Let me know if there is anything else I can provide.
audacity.cfg.txt (7.79 KB)