Won't record - red triangle ??

Audacity 2.3.0 Windows 10. I’m a longtime user of Audacity having recorded over 2500 audiobook tracks and love it. But recently it won’t start recording when I click the Record button; it just freezes up and refuses to do anything; the microphone and speaker panels on the interface are greyed out and it kinda smirks at me. (may be my imagination)

The only change I can see is a red triangle has popped up on the timeline and right clicking on it says “timeline actions disabled during recording”. To the best of my knowledge I have never used this function before and don’t really know what it does. Also there is a strange ’ push pin’ on the timeline now with the option of pinning of unpinning. Have no idea of what these do but they may have something to do with the not recording problem. I do not wish to pin anything.

I’ve searched the help base but no solution found. Any help or suggestions would be most appreciated since this is probably my own fault. I am in the middle of recording a book and this is kinda frustrating. :confused:

Transport > Transport Options > Pinned head…


Thanks for the suggestion Koz. That does not seem to start it recording.

What happens if you then click the “Stop” button? Is Audacity still “frozen”?

Yes. It goes back to default, looking like it is ready to record. Before clicking any thing there is a nice green triangle on the left of the track. If I hover over it, the message ‘click to pin’ appears. When clicking the Record button, the green triangle changes to Red and another Red triangle appears over the recording head and it does not move or record. Clicking the ‘stop’ button causes the red triangles to disappear and the green triangle appear again to the left and above the track. So it does appear to be frozen since the record button stops things completely.

Nothing is turned on in the Transport options.

Normally you would leave that “un-pinned” as a green triangle, but this is not the cause of your problem.
For now, don’t worry about what “pinned” and “un-pinned” mean, just leave it un-pinned (as a triangle)

That’s normal. The red color simply indicates that Audacity is now in “record mode”.

That triangle indicates the recording position (where the “record head” is on the timeline.

So this is the problem that we need to solve.

Look in the “Transport menu > Transport Options” and ensure that “Sound activate recording” is NOT selected (not ticked).
The “Overdub” option (also in “Transport menu > Transport Options”) should normally be selected (ticked).

Good, so Audacity isn’t actually “frozen”, it’s just not recording.

First thing to try:
Reboot your computer, then Launch Audacity ensure the “Transport menu > Transport Options” have “Overdub” selected (ticked), and "Sound activated recording NOT selected (not ticked), then try a test recording.

Are you using WASAPI host with loopback input device to try to record what is playing on your computer?

If so the Audacity won’t record (and the record head won’t move) unless and until it picks up an active input signal…


Windows 10, audacity 2.3.0
Ah ha! I think I have isolated the problem: my Rode A1-1 interface. I have been recording with my Rode NT1-A micrphone into my Rode A1-1 interface and from there into my PC via a USb. This has been working but stopped. Removing the A1-1 from the loop and using an older microphone with a direct USb connection, suddenly Audacity can hear the microphone with no problem. I do not intend to use the old mic and intend to find out why Audacity is not recognizing it. Well, it Does recognize it, since it shows that as the mic input, but ijust gets no sound from it and that would explain why the recording t rack stops and nothing gets recorded. hmmmmmm. Onwards into the unknown! Oh and any help with why this is happening would be appreciated.

ood, so Audacity isn’t actually “frozen”, it’s just not recording.

First thing to try:
Reboot your computer, then Launch Audacity ensure the “Transport menu > Transport Options” have “Overdub” selected (ticked), and "Sound activated recording NOT selected (not ticked), then try a test recording.

I have rebooted my computer and Audacity does record now with everything exactly the same as before. Frustrating but perhaps it tells you something. What could be happening that ‘fixes’ my audio input with a reboot but t hen later goes wrong? I thank everyone for their input and hope i won’t need to reboot my PC several times a day. :unamused: As always, any wise comment is most welcome.
EDIT: the Transport options are all not clicked, nothing is active including overdub.

Audacity only looks for audio devices when it is first launched, or when you explicitly tell it to “Rescan Audio Devices” (from the “Transport” menu).

There are many reasons why a USB device may temporarily lose connection, for example, if the computer CPU becomes 100% busy, then the USB is likely to be disconnected until some CPU is available to run it (other common reasons include, cable / plug problems). Although a USB audio device may reconnect automatically, Audacity will not see it because it is effectively a “new” device, but the old (disconnected) device will still be listed. The most convenient way to fix this if it occurs, is to “Rescan Audio Devices” (or restart Audacity, or reboot the computer).

I had this problem with Windows 10. I am using a PreSonus AudioBox USB 96 Audio Interface (which is excellent BTW). I needed to update the PreSonus interface driver in Windows. That cleared the red triangle problem for me. Hope this helps.

Thank you for taht information. I will definit ely give it a try. As a note, my old Yeti microphone does not have this problem, it is always available and never gets ‘forgotten’. But thanks again for taking the time. I will reinstall my Rode mic and give it a shot! :smiley:

I will reinstall my Rode mic and give it a shot! > :smiley:

Hi, Did you manage to sort this as I am having the same problem and I feel your frustration.

Am using Windows 10 and Audacity 2.3.2 and tried all the options as you have, reebooting, re-installing audacity and Rode NT1 mic, it recognises its there when I rescan for devices but when I press record, all I get is the red arrow which kind of flickers and is stuck and doesn’t move as it should when you record. I too have been using Audacity with no problems before.

I thought maybe it could be a driver? - it happened with my Yamaha keyboard too and I re-installed the driver for that, then it worked but the next time I launched the program, it refused to record as above again. :frowning:

A little add here - I just came across this issue for the first time ever, and the only difference between my previous normal operation and the appearance of this glitch is that I ran Ableton Live 10 after my last Audacity session, but only “slept” the laptop afterwards rather than shutting it down, with Ableton still active.
Very next Audacity session - red triangles.
If indeed the problem is loss of USB device connection, I suspect that Ableton took control of the USB audio so it was not available to Audacity.
Perhaps running any other program that uses the USB audio devices (and possibly even if they are then shut down, if they don’t “release” the USB) may be one cause.
I need to do a controlled test now to confirm my suspicions, as I just rebooted the laptop, closing Ableton on the way.

That’s likely to happen if any app using ASIO is running.

Audacity does not support ASIO out of the box (due to licensing restrictions), and ASIO tries hard to grab exclusive access to the audio device (sound card), thus preventing Audacity from using that audio device.
A possible workaround if you have more than one audio device available (such as a USB audio device and an internal sound card), is to use the ASIO app with one device, and Audacity with the other.

Had the same thing…and rebooting fixed it. Weird. I changed the battery in my wireless mouse right before this…could be that set the no record, although the record button was down…but no cursor goiong etc. … anyway …thanks!

This just happened to me and unplugging my usb mic and replugging it back in fixed the issue for whatever reason, try this before rebooting if anyone else comes across this forum

I am happy to see this on forum, as I have been having the same problem the last few weeks. Using 3.2 Audacity and Windows 11. Can anyone tell me a fix to this problem? Thanks in advance