When using pitch shift ..

Hi, I have just tried to pitch shift five cd tracks and after the conversion had finished all the tracks were 7 minutes 16 seconds long (the size of the longest track) is this a bug as I’ve not noticed this problem before, or do I have to convert each track individually ?

Which version of Audacity?
Are you using Audacity’s “Change Pitch” effect?
Are the tracks all the same length after changing the pitch, or after exporting the files?

Thanks for your reply
I’m using Audacity 3.2.1 and all the tracks look the right length in the Audacity window when converted, it’s when I’ve exported them they are all 73.40 Mb, so if I try and play one track that is 4 minutes 8 seconds long, it shows as 7 minutes 16 seconds long with 3 minutes 8 seconds silence at the end.

Sorry 3.1.2

Yes, I’m using the change pitch effect with high quality stretching.

How are you exporting them? Are you using “Export Multiple” (based on “tracks”)? If not, try that (see: https://manual.audacityteam.org/man/export_multiple.html)

Yes I’m using export multiple, and the tracks button is selected, another strange thing is I converted two of the tracks after posting on the forum (of different lengths 3.41 and 4.39) and that worked, then I tried the remaining three (with the 7.16 track included) and again all three came out at 7.16???

Do all of the tracks in the project start at time=0?
Perhaps you could post a screenshot of the project?
(See here for how to attach an image file to your post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

Actually after closer inspection the 7.16 might be after 0, if that is the case how do make them all start at 0? As when I rip a cd using EZCD, I have it set to delete silence from the beginning and end, so I would have thought all would start at 0.
Here’s the screenshot you asked for
Audacity screenshot.png

That certainly looks like the first track should export as around 7:30, the second track a bit over 4 mins, and the third track around 3:40.
If they are all exporting as 7 mins something, try importing the files back into Audacity to see what they look like.

Yes, after I import back into Audacity they are all the same length
Audacity screenshot.png

Oops wrong one
Audacity screenshot 2.png

I can’t reproduce that on Linux. Perhaps someone else on Windows can test to see if it’s a bug.

I can’t reproduce this on W10 with 3.1.2


Are you applying any other effects eggnog ?

Sorry for the delay, no, I import the tracks, select all, effect, high quality pitch change, then run

I’ve just tried it without high quality stretching and they all have the correct times ??

I’ve just tested with Audacity 3.1.2 on Windows 10 with high quality stretching, and I can’t reproduce the problem.
Are you certain that you are using version 3.1.2 ? (Look in “Help menu > About Audacity”)

Yes, it’s definitely 3.1.2
Audacity screenshot 3.png

In this post: https://forum.audacityteam.org/t/when-using-pitch-shift/63380/12
the tracks have been padded with silence up to the length of the longest track. When exactly does that happen?