Voice morph/effect. (To a target souding voice.)

Heya. I’m completely new to this. I’ve been messing around for hours trying to learn this, and trying to figure this problem out, but I can’t seem to find a solution, not even via google searching.

I’d like to be able to morph a source voice so that it sounds like an effect I’ve heard. I have a certain source voice in mind and a certain target sound I’m trying to get to.

The source is just a speech synthesizer. The target sound I’m looking for is a sound from a video game. (Bloody Roar.)

It’s the “Hyah!” sound that Yugo makes when he throws certain punches/kicks in his wolf form. At 12 seconds, you can hear a series of "Hyah!"s when he does a flurry of punches.

That particular “Hyah!” sound is what I’m going for. The way it sounds kind of growly, but also has that high-pitched quality to it. (I think they call it timbre? I’m not sure.)

I’ve been messing around in audacity for hours on end, spanning a couple of days, trying to figure it out. I have some test text-to-speech audio that I’m trying to make sound the same as that effect. But I can’t seem to do it.

Most of my time has been spent playing with the vocoder. I extracted the “Hyah!” sound and used the Paulstretch effect to make it long enough to be a carrier, but it doesn’t work. The voice can be made growly, but that high-pitched feeling just doesn’t go into it no matter what I do.

If I’m understanding vocoders right, I’m starting to think that the vocoder is not what I’m looking for. The carrier only modifies the modulator where they have overlapping pitches? Which means the hich-pitched feeling will simply never apply. It has to be added in somehow, yet somehow still match the voice.

Does anyone have any ideas about how this could be achieved?

Attached are my best efforts so far.
The sample of the “Hyah!” sound:

Vocoder-Ready stereo file.

(Text-to-speech vocal in the left channel, paulstretched sample in the right channel.)
(Vocoder settings - Distance: 1; Vocoder Bands: 40; Amplitude of original audio: 100; Amplitude of white noise: 0; Amplitude of Radar Needles: 0; Frequency of Radar Needles: 0.)

The outcome:

If you are vocoding speech [with noise] then I’d recommend using a high-resolution vocoder , rather than audacity’s native vocoder, see … https://forum.audacityteam.org/t/how-to-make-vocal-like-burzum/38219/3

Now the bad news : the MDA talkbox high-resolution vocoder is not working with 2.1.1 version of Audacity, [ the last time it was working was in audacity 2.0.6 , I think ].

Hmm. I downgraded to 2.0.6, but now the only plugins that appear are the default ones. The new ones are still in the plugins folder, but there’s no option to enable them.

Sorry for the double post.

It seems like the paulstretch is destroying the high-pitched quality by making a lot of noise when it stretches something.

I’ve noticed that if I just copy and paste the sample itself over and over again, and then vocode it, I hear some of that high pitched quality to it, but it’s extremely faint; you can barely hear it. It goes in and out according in the result the same way it goes in and out in the carrier. (Due to copy/pasting the sample leaving quiet periods between.)

It still seems like vocoders, at least Audacity’s vocoder, don’t work. I’d like to try to get a high quality vocoder and try that out, because I’ve seen some videos where people used hardware vocoders and got really high quality monster sounds just by vocoding their voice with animal growls and stuff.

IIRC in 2.0.6 you have to tick a box in “Preferences”, then restart Audacity, to scan in the plugins ,
see … https://forum.audacityteam.org/t/gsnap-now-in-plugins-but-audacity-ignores-it/32355/2

Progress! I wasn’t able to get the other one to work. Re-scanning it didn’t fix it. Instead, I found this vocoder online. (Sorry if this is no longer within the scope of this web forum.)

It gets me much closer to what I’m going for, but there’s still some wonkiness that I don’t know how to fix.

Using that program’s default settings, and dropping the full unedited sample in as a carrier (it automatically loops short files), this is the outcome:

I suspect those weird low-pitched sounds are where the speaker’s inflections (?) aren’t matching up with loops of the audio. But whenever I try cutting it for it to loop that, then the effect is lost.

It’s almost as if I have to somehow drop the sample itself in at every syllable manually to get it to do what I want.