Version 2.1.3 (and 2.2.1) hangs up on "Timer Record"

Hello. This is my first posting.

Windows 10, Audacity version 2.1.3 As the subject line implies:

So far the only problem I’ve encountered is when I set Audacity to record using the timer function, it records for 12 seconds them just hangs up. i have to go into task manager in order to stop the program.
Otherwise it will record manually.

One reason I installed Audacity was to record a radio program from 11 to 7 so I was testing Audacity using three minutes as a test. I tried this multiple times and every time it hangs up at 12 seconds.

Anyone ever seen this?

Can you do it manually? Can you make the recording without the Timer?

What show are you recording for 8 hours? I record radio shows for 27 minutes or 53 minutes.


Yes manually records fine. I recorded about a 10 minute clip with no problem.

I didn’t know there was a newer version. I downloaded this one maybe a couple of months ago. I’ll get the newer one and see if it works better.

As far what I am wanting to use Audacity for: Sunday at the 70s on WVEK 102.7.

Mainly to listen to when traveling instead of having to constantly search for stations.

I’m too cheap to subscribe to Sirius and their programming is awful and they repeat the same songs over and over. I might subscribe if I was a truck driver.

2.2.1 is available for Windows from here:

If you continue to have troubles, you might consider going into manual record and set your Personal Device to ring at the 8 hour mark to walk over and stop it.

If you’re trying to use your computer for other services during the recording, that may be where the hangup is occurring. Audacity does not play well with others. You lose your computer for 8 hours.

Note as your recordings get longer, saving them becomes more of an adventure. Perfect Quality but long WAV files start running into format troubles. Different parts of the system fail past 2GB and 4GB WAV files.

If you limit yourself to listening with maybe simple cutting to length, MP3 may be used. MP3 doesn’t make a very good source for production editing. As you get fancier and fancier with production editing, MP3 sound quality gets worse and worse.

FLAC format makes perfect large files, but not everybody can play them.

You can use Audacity Projects for this, but people have had problems with longer Projects and they can be brittle.

Does the station have a podcast? Download it and avoid all these problems.


I have a several computers so the idea is to just set “time record” the night before and walk away from the computer and let it do it’s thing. I have not tested Audacity on my Windows XP machine to see if the same thing happens . I really don’t want to use my XP machine anyway because it doesn’t have as much space on the hard drive.

So I downloaded the latest version on Windows 10 and the same thing happens. However it doesn’t quite “hang up” at 12 seconds as I expected. More less the computer is just unresponsive. Audacity continues to record, but the window says the elapsed time stops at “12” seconds. However at the bottom it shows the correct elapsed time and the audio graph (for lack of a better term) at the time shows the program to continue to record.

The only way to stop Audacity, I have to hit CTRL-ALT-DEL and stop it through the task manager.

Now here is the workaround. When I go back into Audacity, the program asks if I want to load “unsaved work” or something. So I just hit “yes” and it loads what has been recorded. I have only tested this on a few minutes of recording.

I have not set a test recording for say for 3 minutes to see what happens after 3 minutes. To see if the program stops itself and becomes responsive. That is something I should try.

Could it be the program is designed so you can’t “mess with” the computer while it’s recording? Like I say, my plan is to just set the record timer and walk away and come back later so that is not a concern.

Right now the program is recording my radio show until 7 pm. I’ll see how it goes.

And just like that, I’m out.

You need somebody with intimate knowledge of what Audacity is thinking about while it’s recording in Windows. Having a portion of the program fail without a formal crash is most unusual.


Well I’m baffled I run a couple of W10 laptops and I cannot reproduce this at all - not on 2.1.3, the latest 2.2.1 released version nor the 2.2.2 alpha development test version.

Testing done using you 3 minute test use case - all proceeded fpr the full 3 minutes and terminated properly.

I also use these machines for a weekly capture of a two-hour overnight show unattended as I sleep and that has never stopped short.

There is a moonphase bug that we know about whereby Timer Record doesn’t stop but just carries on - but I’ve only had that once on the past few years and releases:

There is also this known bug which stops the Timer Recording short:
but I don’t think you are messing with the system clock, are you?


Well I tried the 3 minute recording test and Audacity kept going after 3 minutes. So I’m baffled. I will shoot a short video and post it on YouTube to show you guys what’s happening. I’m going to test it on XP SP3 to see if I get the same error.

I do know Audacity won’t run on an XP machine with a fresh install running SP1. I get a missing driver error on that machine. I was not planning on installing SP3 because that machine only has 512 MB RAM and SP3 dog knots anything under 2 GB RAM.

I am having the same issue with Audacity 2.21 on a Windows 10 machine. The timer stops at 11 or 12 seconds while Audacity continues to record. Task Manager is the only way out. I have repeated the issue with varying timer lengths with the same results.

This sounds like the moonphase bug that we know about (as I wrote above) but we have no idea what causes it:

None of the developers or QA folk can reproduce this with any regularity (or even at all) whicjh makes it very hard to track down


I tested Audacity on my Windows XP SP3 machine and it works with no problems at all. I made a 2 hour test clip and it’s currently converting the file from .WAV to MP3 format right now. So it must be an issue with Windows 10. I’ve kind of been out if the loop for awhile but I remember with Windows 7 there is a compatibility option that can be turned on if some programs won’t run right. Too bad , most software was backwards compatable up to XP. I’ve got a bunch of MS DOS and 3.11 programs that run on XP just fine.

It’s a nasty surprise. Windows 10 is not a Windows upgrade. It’s a new OS and software has to be written or certified for it. Some software happens to accidentally work most of the time, but those can be time bombs.


I struggle to believe that it is a problem with Windows 10.

have been running Audacity on Windows machines for over 10 years now and all of that time I have been recording 1 and 2 hour shows unattended overnight every single week - and since the 1.3.x Beta series of “releases” I have only experienced this once (and with no obvious cause - that one being set up exactly the same as all the others). Over that Time I have run this on desktops and laptops running XP, Windows-7 and latterly Wiindows-10 (I skipped W8).

I wrote in the bug thread back in September 2013
I am a very regular user of Timer Record, using it several times a week to timeshift radio shows and internet webcasts. Whilst it used to exhibit this behaviour for me occasionally with the early-mid 1.3.x releases I can safely say that I do not recall this happening ever on either the 2.0.3 release nor the 2.0.4 alphas that I have tested regularly on. Nor has this occurred during 2.0.4 RC1 testing.

In January this year I wrote there:
Over the past months I have been using the Timer Record on latest alpha nightlies on my W10 laptop 3 times a week (or more) with one to two hour recordings and it has never failed to honor the set timings, always completing accurately on time and with no over-run.

At the end of June this year for the first time I encountered this bug (on W10) - and lost the recording:
I experienced this moonphase bug for the first time in a very long time last night waking to a a still running 8 hours of recording that was scheduled to stop after 2 hours. The Timed Recording could not be stopped with the Stop button - I was forced to use Task Manager to abort the Audacity app.

On re-launching Audacity I was fully expecting to see Auto-recovery do its job- but no, all it launched was a clean empty Audacity window with no offer of recovery.
I attempted to open the Audacity project - I got an warning message of thousands of orphan files - I elected to continue without deleting those. The project them opened as an empty project.

Subsequently I have continued to use Timer Record for these weekly 1 and 2 hour unattended project recordings all on Windows 10 and with no problem at all, with Audacity terminating the recording at the scheduled time anfd successfully making the requested automatic project save and automatic export of a 16-bit WAV file.

What puzzles me is that I used to get this a lot in the early to mid 1.3.x beta series, but partway through 1.3 Betas and an in subsequent 2.x.x release the problem (mainly) does not occur - except that every now and again the problem raises its ugly unexplained head.

None of the developers can offer me any clue as to what changed in mid 1.3 series that caused the reduction in the occurrence of this bug - so it remains a moon-phase mystery.

I have tried to get the original developer of Timer Record to have a dig into this - but he is otherwise occupied with paid-for employment and other projects.


Turbofiat, are you recording from an FM Tuner feeding an external USB soundcard to feed the PC? Or are you recording a webstream?

Reason I ask is that Gale Andrews wrote in the bug thread back in Feb 2016:
Where we know the device concerned for the 2.1.2 reports, it is a USB recording device.


Since users Turbofiat and FL Coast both report in this Forum thread that this errant behaviour occurs at the 10 second mark or so, I decided to do a little testing (based on earlier reports in the bug thread of excessive CPU usage by Timer Record -

So, testing on my whizzy new(ish) 256 SSD W10 laptop I find:
a) Normal recording consumes just under 3% of CPU
b) Initially Timer Record consumes 3% of CPU
c) After 8-10 seconds Timer Record CPU shoots up by 400% to 15% or so - and continues that way

So it looks as though some Timer Record event occurs at the 8-10 second mark - but what it is I have no idea (but this may offer a clue).


I also note that when Time Record is underway (testing on W10 on 2.2.1 and 2.2.2 alpha) for the first 8 seconds or so when the CPU usage remains low the sliders are nicely static. After that time the sliders in the Mixer Toolbar and the Transcription Toolbar flicker as though they are being (unnecessarily) redrawn. I also observe similar occasional flickering of the icons in the Device Toolbar.

With normal recording no such flickering occurs.

On my Windows 10 machine I was using an old AM/FM/SW radio with a mono to stereo adapter plugged from the earphone jack into the line in Port on the computer. And set to record on mono.

On my XP machine I was using my cell phone but a stereo 3.5mm cable.

OK so no USB device just the onboard soundcards - thanks for the information.


I also meant to add I was using the FM radio on my Moto Z cellphone. Verizon blocked the FM radio for a few years until someone filed a complaint with the FCC. Apparently it illegal to hinder someone from listening to free broadcasts in the United States. Verizon did it so they could sell more expensive data like having to use Tune-in radio just to receive local radio.

I initially though this “Moon phase” you guys were talking about was a web browser but I that must be Pale Moon or Moonlight.
I tried to do a search on this moon phase but everything that pops up is based on the actual moon.

It is based on the actual moon. It’s a metaphor for an undesirable event that might appear every 30 days or so. Almost impossible to troubleshoot.

A far older metaphor is “top-dead-center” where a single-cylinder farm motor would occasionally stop at the end of the work day with the moving cylinder at the exact, perfect top of its travel making it all but impossible to start the next day—for no apparent reason.

That’s not to say there aren’t steps that can be taken. The range of efforts is not limited to making it better. It’s valuable if someone can reliably make it worse.

“If I overload my machine with activities, it fails once a day rather than once a month.”