Version 2.1.3 (and 2.2.1) hangs up on "Timer Record"

WC, I have the issue trying to record a timed event from computer line in or a webstream.


I’m totally foxed Wayne.

I can’t get this to happen with 2.1.2 on:
a) Windows 10 laptop (plus recent Creators Update)
b) Macbook Pro with macOS 10.13.2 High Sierra
7) air-gapped XP desktop fully patched with Service packs

Any chance you cam make a Youtube vido to show us your steps from soup-to-nuts - i/e from opening Audacity, set up TR and on to the failure?


Here is a video on YouTube. I thought I would try it not recording anything, just setting the timer. At 11 seconds the timer stopped and the only way out was through Windows Task Manager. I did notice while watching the video back, when the timer reached the 11 second mark, the volume adjustment bar starts to blink. This was on a Windows 10 laptop with Creators Update, a fresh boot-up, no other devices connected to the laptop, and the only other program started (other than normal Windows stuff) was the screen recorder.


Hi Wayne,

thanks for that YT video - the only thing I can see you doing differently to me is that you are only choosing the automatic export and not the automatic save - I usually select both.

I will experiment doing that to see if I can reproduce this (Im a bit busy on other stuff right now - but I’ll get to this shortly).


But boy, you do have a very busy, full, desktop … :wink:

I may try experimenting with that too

Thanks Peter, I guess it’s nice to know that everyone’s house doesn’t look the same.

With that being said, I did a little housekeeping and removed everything from the desktop other than “This Computer and Recycle Bin” icons. I also set automatic export and automatic save and ran the same test. Same results.

Guess I will continue to set my alarm clock.

Thanks for trying,

Hi Wayne,

I just tried on 2.2.1 and 2.2.2 alpha with just the automatic export in play and it sailed on in both cases past the 12 seconds or so to full completeion.

I’m totally baffled - this works so well for me 99.99999999% of the time, I rely on it a lot for precisely what you are trying to do.


From what I remember, I don’t even get an option to “close” the program when running Audacity on Windows 10. If I hit the “X” the program doesn’t even respond and ask if I want to close the program. I have to hit CTRL-ALT-DEL and stop it using task manager.

I selected both the save and export options within XP SP3 and Audacity works flawlessly.

Still not sure why Audacity won’t run on XP SP1 on a fresh install. I get some sort of missing driver error. It maybe Audacity requires a plug-in which was later incorporated into SP2 or SP3. Like back in the old days MAME (if anyone remembers MAME) required Direct X that had to be downloaded from Microsoft when with running Windows 95. Later on Microsoft incorporated Direct X into Windows 98 and XP.

The only issue is the conversion to MP3 format is a little slow (about 7 minutes for a 2 hour audio clip recorded in mono). But is a 12 year old PC. No big deal since it can be selected to do so automatically after the recording stops. I have several computers and can dedicate one particular computer to special projects. I just didn’t want to use this particular computer because it only has a 145 GB hard drive and I’ve used about 75% of it so I am a bit low on disk space.

If you are wondering why I am recording in mono at 44 KHZ is more about disc space than audio quality. Most of my road trips are 400 miles and having to constantly having to find stations every 15 to 30 miles is a pain. The factory Delco radio in my 1997 Chevy van is not the best anyway so it’s not that big of a deal. So it would be great to load up several 11 hour clips onto an SD card.

People go on about how you should upgrade (well buy a whole new computer) to Windows 10 and all and there are good reasons to do so but for the same reason I like to hang onto older machines running older operating systems. I still have quite a few programs (like Audacity for example) I use every now and then that don’t seem to run correctly on anything later than XP. Some dating back as far as Windows 3.1! MAME and Paint Shop Pro are two of them.

One program I use is one of the first versions of WinAmp dating back to the early 2000s. Before they went to using skins and such. This is what I used to use to transfer MP3s onto cassette tapes before they started making car audio decks with SD card slots!