unable to overdub

Hello…I`m using Windows 10…64 bit…Audacity 2.2.2

Ive been unable to overdub..I get a message that says...error opening sound device..change audio host..or..recording device...or recording sample rate \ \ Ive checked and unchecked both the overdub button and the software playthrough…when the boxes are unchecked I am able to record a second track but I cant hear the original…when I check either or both I cannot record and get the error message

any ideas ?


In overdubbing, both sound directions have to work perfectly, not just recording. What equipment are you using? You can only do perfect overdubbing with some microphones, preamps or soundcards. Almost all of them can overdub, but not all of them let you hear yourself while performing.

The answer may depend on how you’re doing it.


thanks for responding

I am using a custom built gaming computer…i dont know all the specs but I can find them for you if you let me know...atm Im using an Allen and Heath Zedi8 mixer and a Sterling ST155 condenser mic…it plays and records ok just won`t let me hear to overdub

I had been using an Asus laptop with an Alesis multimix 4 channel which I never had any serious trouble with…this mixer was plug and play and did not require a driver…the new mixer does

any suggestions ?

That should be enough to go on. I need to drop in and out of Real Life.


I’m looking for the magic words “Zero Latency Monitoring.” That’s when the mixer will produce a special headphone mix with your live voice mixed with the Audacity backing track.

It doesn’t mention anything like that.

More later.


thanks ive been working on this a while

Separate controls for the USB playback channels allow you to blend USB audio with the Main Mix and Aux Mix independently.

That’s from the instructions. I have no idea how to do that, but that’s what you need for overdubbing.

The mixer will handle 24-bit 96000 sample rate quality, but you may not want to actually record like that. I would start small. Audacity > Edit > Preferences > Quality > Sampling: 44100, 16-bit.

Edit > Preferences > Recording: Overdub. De-select everything else in that panel.

Back out on the Audacity device toolbar, does the Allen & Heath have personalized USB identities? My Shure Mic Pre actually has a name on their connection: Shure Audio. My Beringer just looks like USB Audio CODEC. Make sure that’s selected for both recording and playback.

If you’re unsure which connection name belongs to your Allen & Heath, look at the list of devices. Disconnect the Allen & Heath, Transport > Rescan… look at the list again. Does the right thing vanish? Plug it back in. Transport > Rescan.
Screen Shot 2018-07-15 at 14.09.11.png
Let us know if you get lost.

Additional notes: Do you like to record YouTube and other on-line audio? Those settings don’t work for overdubbing. You need the Allen and Heath setting for both record and playback.


You did throw mud in the game with the custom gamer computer. I don’t know if the soundcard is going to respond correctly to the commands and settings. While you’re doing audio production, make sure all the gamer stuff is turned off and not just napping. Also make sure you’re not running any chat or conference programs. Skype?? That can mess up the sound pathways even when the app is napping.


I don`t understand about blending usb and mix…I have 2 buttons on the front of the mixer with labels that say usb out and source selection…pushing different combinations of them makes no difference

I have the rate at 44100 16-bit…Audacity recognizes my mixer no problem…I don`t record anything off the internet…just acoustic guitar and vocal through the mic occasionally an electric guitar

when I say gaming computer I meant to say I play games on it…i am not at all tech savvy…I did tell the people who I bought this from I need a machine that will handle protools…All I really need is Audacity if I can fix this

2 buttons on the front of the mixer with labels that say usb out and source selection

That fuzzed me out,too. As near as I an tell, you can send Pre-Fade, Post-Fade or Mixer Master out the USB connection to Audacity to record.

Mixer master out is pretty simple (I think). That’s the red fader on the right.

Pre-Fade is anything before the volume controls lined up along the bottom. Use that to send something down the USB other than the show mix.

Post fade picks up the sound for the USB after those individual faders.

I get a very firm impression that you got a special purpose mixer that may not be exactly what you want. I think you’re missing some important controls and buttons.

I can usually walk up to a mixer and say, “Push this button and that button and it will all start working.” I’m lost on this one.

The Zero Latency Monitoring mixers have controls for headphones. Line-Out (mixer live performance), USB (or computer) playback, that’s the backing track; or both. I don’t see any way to make this mixer do that. It’s like the INFO summary from the store is talking about a different mixer.

I can pull down the manual and see if I can figure it out.


anything will help…Ive used this old Alesis 4 channel for several years with Audacity and was developing a buzz that I know came from the mixer but it was old..i figured I got my 99$ worth...if I cant fix this I may buy a new one which might be the only solution…this was supposed to be an upgrade

I’m so close to throwing in the towel. I have to draw the signal pathways in my head and they don’t make it any easier because some of the controls aren’t labeled.

As I understand this: The little white buttons along the bottom are PFL, Pre-Fade Listen. Assume you’re microphone is plugged into mixer channel 1, turn up the two red knobs about 3 o’clock. Push that PFL and the fifth PFL. That should deliver your microphone performance mixed with the backing track from the USB/Audacity playback to your headphones.

Meanwhile, advance the big red slider and your live performance should make the sound meters jump. It should also go down the USB cable to Audacity to be recorded. If I did it right, the backing track will not go down with it. That should give you a clean track 2. You can use the Audacity SOLO and MUTE buttons for each track to select what you hear as backing track.

Now that you’re using 44100, 16-bit, is Audacity still complaining unable to reach… yadda, yadda?


I don`t know what you mean by the fifth PLF…the labels on the buttons are cryptic but there are 2 of them…on top it says USB out…underneath that is a button that says M1-M2 obviously mics 1 and 2…below that L-R pre…underneath that a label that says L-R post but no button just a label…next to the whole deal a bracket that says source select…again I have tried every combination and nothing

Now all at once I can`t record anything…no track no overdub…nothing…setting the bit rate does nothing

Im confused..its as though this system has a mind of its own which is impossible since its just a machine…hopefully

since then Ive hooked up my old Alesis mixer and everything works fine except for the buzz which im sure is coming from the mixer which is acceptable as it is so old...next step is to buy a new Alesis 4 channel and see if it works..ive been messing around with this for 2 months and I dont want to haggle with sweetwater so it looks like I’m stuck with it…hopefully it will work with protools ?

1 other question…how do I change the windows 7 to 10 in my tag ?

OK. One at a time. These PFL buttons. The unlabeled ones. One through five.

Screen Shot 2018-07-16 at 19.33.09.png
#1 should shuttle your voice or microphone to your headphones with the tall red master fader all the way down.

#5 should shuffle the USB backing track to your headphones. That’s your overdubbing mix.

You don’t know how long it took me reading the instructions to get that.


Is it still complaining about not being able to connect?


Sorry it took so long to get back to you…I usually only do this on the weekend

Its doing something different now...I cant record at all…when I hit the red button a track appears but there is a message " Try changing audio host…recording device and project sample rate "

Im 99% sure I have the settings where they are supposed to be and Im checking again now now…not sure what to do now…I recently updated my entire system but I was having better results with my cheap laptop.

Check that the Windows privacy settings aren’t getting in the way. See here for details on what I mean: https://forum.audacityteam.org/viewtopic.php?f=46&t=100117

everything works fine just the way it is except 1 thing…when I click the record button the entire project moves 10 seconds forward


Does it shift as it’s recording, or after you’ve stopped recording?