Split (bug?) causing weird bahaviour and huge project size

I’m using Audacity for years now as a professional voice-over talent & producer.
Recently, I was forced to upgrade to 3.x.x from the 2.x.x old versions I was using, because I bought the Nectar 3 plugin suite, which unfortunately doesn’t work with the older versions.
Apart from the impossibility to use any form of keyboard input, while a mouse button is pressed (awfully annoying & the main reason for me not to upgrade before), there’s apparently a totally strange behavior of the “split” function that’s seemingly random and also might be the reason so many people are posting about huge project sizes.

Here’s what happened today:
My wife recorded around 30 minutes of video narration. She prefers to record without pauses, so she doesn’t punch over mistakes, but records on. So, I need to cut out any errors later while editing. Not a big deal, she doesn’t make many mistakes :slight_smile:

For the edit, I have the original audio as sync-reference in track 1 and the actual recording in track 2.
My normal workflow in previous Audacity versions was always to:

  • paste silence up to the start of a segment I’m syncing
  • check the audio is more or less in sync within that segment, removing mistakes
  • move on, unless there’s an error that needs to be rerecorded, in which case:
  • mark the part to rerecord with two splits (“F” button while the part to replace is selected),
  • either leave it be, or silence the selection, keeping the splits for easy identification of the problematic spot
  • move on
    This way, I have the complete recording in sync, with spots to be redone marked by two splits.
    The project can then be saved (OneDrive), opened on the recording PC, after which the mistakes can either be rerecorded in a new track after each other (wife version), or at the correct spot in the project (my version).

Today, I did exactly that, and after saving the project, was a bit surprised to see its size as over one GB (30 minutes of original audio + 34 minutes of my wife’s recording).
Then, I opened the project on our recording PC, so she could do the retakes.
It was a bit weird, as the recording PC was behaving really sluggish, but recorded OK.
I saved the project again, opened it on my editing PC and nearly got a fit.

Copy-pasting bits from track 3 (retakes) into track 2 (recording) apparently doesn’t do anything. Something happens, but the pasted bit vanishes.
As I noticed that the recording track is longer than it’s supposed to be (there’s about 1:30 minutes additional stuff at the end), I started experimenting. It turns out, there are a large number of clips of different lengths UNDER the actual recording (covering each other up), with something showing after the end.
I then “selected all”, and “joined” the audio (ctrl-j). This produced OVER 8 HOURS OF AUDIO in the main recording area.
This audio must have been hidden underneath the actual track, with ctrl-v pasting content “somewhere” down there.

The only way for me to salvage a few hours of work (that luckily worked), was to export each track as wav, import it into the old Audacity, and work on the retakes there.

This seems like some sort of major bug, or at least completely obscure behavior. No wonder the project is over a gig! It somehow saved 9h of audio, instead of 1h…

Does anyone have a usable workaround for this mess? Right now I’m one step from finally ditching Audacity and investing some hours (in addition to money, probably), to switch to something actually working…

In Audacity 3.1 new clip trimming features were introduced which allows you to hide audio at the beginning and end of a clip. See: https://www.audacityteam.org/3.1.0-video, particularly at 1:06.

Is it possible that you somehow trimmed off audio, when you intended to delete it?

This sounds like you are running into some of the (bug) issues around the new “smart clips” feature. (See the video that jademan linked to).

Unfortunately there’s currently a lot of issues (bugs) around this new feature. Until they are fixed it may be best to go back to a slightly older version of Audacity. If you want the new “AUP3” project format, there’s Audacity 3.0.5, or for the old “AUP + _data folder” project format there’s Audacity 2.4.2. Both of these older versions are available on FossHub: https://www.fosshub.com/Audacity-old.html

This is really disappointing.
Basically - it seems that the whole project became a buggy mess.
I really loved the program up to a certain point. I’d still use 2.0.4 for editing, as it’s by far the most comfortable version. Maybe some of the follow-up versions would also work, but that’s the version I used until last week.
For recording, I installed a slightly later version that already pretty much broke editing (key presses not registered together with mouse button), but introduced punch-in recording (that 2.0.4 lacks). By the way, I posted the editing issue some time ago, and the thread seemed to indicate that there are quite a few users who also think that it’s an important part of their editing routine…

Unfortunately, just to be able to use a plug-in that really helps my workflow, I had to “upgrade” to 3.x.x

Since then, it turns out that punch-in recording is f*** in the latest version, and no one seems to care (as can be seen on the forum). Now it turns out, that another “feature” makes simple editing a nightmare, introducing “phantom tracks”, behind other tracks, that can’t be accessed, but use up tons of disk space.
How are these releases called anything but pre-alphas? It seems that every iteration breaks more than it fixes.
And the only advice being - “go back to pre 3.x.x”?

This project’s really f*** up. Time to look for something that works.

For what it’s worth, I’m still using Audacity 2.4.2. I’d like to be able to use the new AUP3 format, but I’m waiting until there is a sufficiently stable and reliable 3.x version for Linux before I upgrade (though I do still test every new release and log issues when I find them).

My 2c:

Audacity is in a bit of a strange place at the moment.
The most stable version IMO, is still 2.4.2 which is only available in 32 bit.
Any newer version that is available as 64 bit, is still very buggy to be considered for any serious professional work.

This then, leaves the “power” users in a pickle as most new plugins are only released as 64 bit.
To make matters even worse, VST2 is pretty much outdated and the new “norm” being VST3, which AFAIK,
no Audacity version supports.

I also have no trust in the stability of the new project format, just too many reports of things going wrong.
In a domestic environment, a corrupt project is a real pain, in a professional one, a complete catastrophe.

With each passing day that these things are not fixed (bugs and VST3 support), the less Audacity becomes relevant in audio work.

In the past, it was understandable that Audacity always lagged a bit as regards the latest technologies as it was just volunteer devs.
With the acquisition by Muse, I was hoping that they would throw money and resources at it to “speed” things up.
Don’t know what has happened but, I feel that the only changes that were made, did not address many shortcomings but instead
just added features that could have waited and many new bugs could have been avoided.
This is a huge pity as it has some great features and offers a simplicity over more traditional DAWs which often are not required.

Maybe I’m just being too pessimistic but I reckon the writing is on the wall.
I have already started modifying my workflow where I use a full featured DAW and use Audacity only when I require it’s unique features
such as Nyquist scripts/plugins or sample by sample “painting”. All my new plugins are used in the DAW itself and don’t have to worry
about them being compatible with Audacity.

Some DAWs will allow you to call Audacity as an external editor which makes passing clips back and forth a bit less tedious.

Where I can (and if technically possible) have also being slowly porting some Nyquist plugins to VSTs.
This then also adds the advantage of realtime “tweaking”.

In all digital media, there has been an exponential change and upgrading of technology in the past few years, and I fear that Audacity
is no where near where it should be, to take advantage of these new advancements.

Sorry if I sound too negative or if my post comes across as a rant, it’s not my intention.
I really like Audacity, have for many, many years, just not happy with the path it seems to be taking lately.

According to the commit logs, VST3 support has been added in the development version: https://github.com/audacity/audacity/commit/88d75d9213f511313a8e9f23120250aaae300eaf

There’s some pretty advanced work going on behind the scenes to integrate AI processing into Audacity. Some information here:

and some other interesting work:

and the current roadmap:

but, to be fair, it seems that most, if not all of those cases are linked to working on inappropriate data storage for an open database (such as cloud storage or network storage). The manual does talk about about best practices regarding working with the new format, but people rarely check in the manual.

The problem is that Muse have been bold (possibly overbold) in deciding that their first major change should be the additon of an effects stack per track which will permit real-time non-destructive editing with effects, something that has been the subject of many feature requests in the past.

In order to do this a lot of under-the-hood refactoring of effects and other underlying structure has had to be done - and this, I think, is much harder and taking longer than Muse anticipated (and inevitably introduces new bugs that must be found and fixed).

For my money I would instead have worked on getting rid of wxWidgets and creating a shiny new GUI to give Audacity a lovely new look. Muse do have plans, and a design, for this but that is not scheduled until 4.0 (which is a while away).


But Muse do have plans for providing Audacity with different workspaces, so:
a) simple interface for simple recording and minor editing
b) power user interface
c) Podcaster interface
d) etc.

I, myself, would be an a) user :sunglasses:


Hi Steve and waxcylinder,

Wow, those are some pretty impressive features that are planned, you have both restored some faith in me.

Of course the big question then has to be, when? Will there be beta releases in the meantime?

One big problem which I didn’t mention, is Audacity’s habit of using the same places to store info about plugins (presets) and your preferences.
I find this to be a big hinderance as when one uses (or tries) a new version, it messes up all the settings of the previous one.
Can I not request that each version have a unique place to store these?
It would obviously vary slightly depending on OS, but can’t a sub directory (under where the main executable resides) be used?

This is the biggest reason why I don’t even bother trying new releases, surely I’m not alone?

But given the planned features, I am prepared to get a standalone machine to experiment on.
Due to cost, it will probably be a windows machine and I’m assuming the minimum requirements for the latest Audacity will be
something like an i5, 16GB RAM and HD gfx (at least 1920 X 1080).


When will the audio level problem I posted about (already 2 years ago) be fixed?
It’s the problem of Audacity sending the wrong audio level (too high by up to 6dB) when using external plugins.
It affects all OS’s.

Others (including waxcylinder) have also encountered this problem:

You can already do that.

Add an empty folder in the same directory as the Audacity executable, and name it “Portable Settings”. After restarting Audacity it will use the “Portable Settings” folder instead of the default location.

Here’s an example on Linux:

Portabel Settings folder.png
and the contents of the Portable Settings folder:


Thank you Steve.
I knew about “portable settings” but assumed that it only applies to a portable version of Audacity.

So are you then saying that any 3.x version of Audacity will honour the location if one creates that folder?

If you have a reasonably modern Mac, you could use a virtual machine.

Running Windows 10 in a virtual machine requires that the host machine is pretty powerful, lots of RAM and a good amount of disk space. Linux can be a lot less demanding. Xubuntu (Ubuntu with XFCE desktop) runs beautifully in Virtualbox on my Mac Mini.

On Windows and Mac, yes.
On Linux yes, but not with the AppImage version.

(Also worked with Audacity 2.x and 1.3.x (I don’t remember if Portable Settings were supported in Audacity 1.2.x or earlier - perhaps not).

First reason I wanted to use Windows is that it’s easy to find lowish cost used laptops as many people are upgrading
to Win 11 and their machines are (artificially) limited to Win 10 max.
Hey, if they feel that they may be missing something by not using Win 11, then power to them.
It means well priced machines on the second hand market for me.

Secondly, although I use Linux on a daily basis too, always find that compiling latest Version of Audacity is a pain, or the repos don’t have it,
or there are some short comings in the app image or flatpak versions.

As for Mac, I do have two Macbook pro’s (i7) but the OS is kept at 10.12 for compatibility with some software I need on them.
This then limits their use for VM’s and the latest Audacity too I’m assuming.

Great, thank you Steve.
So now the big question… where or when can I download and try an Audacity version with some of those new snazzy features?

Sorry, no idea. I’m quite frustrated by the rapidly increasing bugs and slowness of them getting fixed.

Steve wrote:

Sorry, no idea. I’m quite frustrated by the rapidly increasing bugs and slowness of them getting fixed.

Me too and partly the reason for my first post.
I feel that Muse is hurriedly moving along with new features, not a bad thing, but ignoring many old bugs
that will carry through to newer versions, not good.

That’s one thing that has definitely improved over the last year or so. I’ve not tried, but it should be fairly straightforward to write a (Python / Bash / name your preferred scripting language) script to automate the process. My current procedure is:

  1. Delete the old build files

cmake -G “Unix Makefiles” -DCMAKE_BUILD_TYPE=Debug -Daudacity_use_ffmpeg=loaded …


cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -Daudacity_use_ffmpeg=loaded ..



make -j`nproc`

or if there haven’t been any changes to libraries or headers, just

make -j`nproc`

Full details here: https://github.com/audacity/audacity/blob/master/BUILDING.md

OK great, will definitely be giving it a bash. :wink:

Even Ricky Martin sang his praises about it… :laughing: :laughing:

You can always download the latest “master” build from GitHub (you will need an account to enable the downloads - but they are free):

If you’re feeling really bold and adventurous you can try out the variaous branches of the developers from the same GitHub page (for that you really need to follow the Pull Requests and the Issues log too - and the developers’ Discord channel - in order to understanf what is going on).

Latest master will give you the emerging effects stack - see the new button in the Track Control Panel. It won’t yet give you the new Audio Setup toolbar (that is in ksoze95’s branch “Audio Setup Rework” - it’s on the second page now).