[RESOLVED] The Notch filter don't want to work !

Hi everybody,

For Audacity 2.4.2 on W10.

I found in my stereo wav sound file an artifact to be deleted so I isolated the glitch in the spectral logarithmic view and invoked the notch filter after having identified the corresponding frequency with the spectral analysis tool. When invoking the notch filter, its window pops up and I put the frequency in the first field and left the Q to 1. Result : no artifact cleaning ! I did the same thing with a Q = 3 to no avail. Q = 5, same result.

Does anybody have any clue on what’s happening here ?

Best regawrds

Describe the glitch. As a fuzzy rule, notch filter doesn’t do anything useful with ticks, pops, or other very short time duration disturbances. The tool needs time. Motor whine, computer fan, kettle whistle, etc.

My silly metaphor is telling somebody to identify all picket fences whose pickets (boards) are six inches apart.

Screen Shot 2021-06-19 at 18.00.56.png
Then you present them with a fence that has one picket.

Ummmmm. Not enough to go on.

There’s another possible error, too. Where is the notch? If it’s above about 10,000Hz, many people can’t hear that high.

What’s the show? Describe the performance.


spectral editing has it’s own notch-filter called “Spectral edit multi tool”
https ://manual.audacityteam.org/man/spectral_selection.html#multi

https ://manual.audacityteam.org/man/spectral_selection.html#example

The regular "Notch filter"effect will also work, but it is less precise: (Q=3 is a comparatively blunt tool).

Hi everybody,

I used the notch filter as demonstrated here (from 3:35 min timestamp and over) : https://www.youtube.com/watch?v=A5ErzybkrGc&t=34s

Here is my artifact :

the artifact lasts about 2.5 sec,


Try using “.” instead of “,”

The notch-filter within spectral-editing is quicker to use, and more accurate …

multi tool is a notch filter.gif
https ://manual.audacityteam.org/man/spectral_selection.html#multi

This is exactly what I am demonstrating up above…


No it isn’t: the multi-tool in spectral editing does not allow you to input Q.
https ://manual.audacityteam.org/man/spectral_selection.html#multi

You are using “notch filter”, but commas are not acceptable to Nyquist plug-ins.
nyquist plugins use dot not comma.png

Hi Trebor,

I tried to put a period there but it is not accepted ! I always revert to a comma !! and my OS regional settings are set to use a period for a decimal symbol !!! Bizarre…

When I try to bypass the decimal annotation by going to the end of the figure and doing two backspaces to erase the “,0”, upon changing field, the “,0” is reinstalled.

Best regards

Hi Kozikowsky,

This is a high pitch of the ultrasonic focusing lense of my camera and it can span from a fraction of a sec to 2-4 sec…

Best regards

So… anybody, can anyone try to clean this artifact @ 8476hz here using the “notch” filter ? :


Best regards

There’s actually two frequencies
The strongest one is at about 8480 Hz, and the other is at about 7880 Hz.

I used the Notch filter with:
Frequency = 8480
Q = 8

and then
Frequency = 7880
Q = 8

Here’s the result:

Hi Steve,

Excellent !

Was the decimal on your figures in the notch filter a period or a comma ?

Best regards

My system uses the dot character as the decimal separator.

Note that changing the decimal separator character is risky because it MUST be consistent, and for most operating systems it MUST be set the same in multiple places. I’ve never had to worry about this because my computer has always use the dot character as the decimal separator.

Hi Steve

I have done NO special mod in audacity and it puts commas instead of periods as decimal symbol. Would gladly configure it to use periods but I don’t know how… Even if I type a period, it converts it as a comma !!!

Best rgards

There are no special settings in Audacity for the decimal separator. It takes the decimal separator settings directly from the operating system (in your case “Windows”, in my case “Linux”). If there are conflicting settings for the decimal separator in the operating system, then it WILL cause problems.

Hi Steve,

I reverted the Windows 10 regional settings to english (US), rebooted the pc to no avail : same notch filter with commas decimal symbol.

The next step now is to fill a bug report (feature request) to the notch filter programmer (or audacity board) in order for him (them) to allow commas as decimal symbols. Where do I fill this report/request ? I NEED this notch filter ASAP…

Best regards

It isn’t an Audacity bug. It seems that there is still a conflict somewhere in your Windows settings.

I can probably write a version of the Notch filter that isn’t affected by the Windows settings, but you are still likely to have problems with other effects. You really need to fix the problem on your computer.

To show willing and help you with the immediate problem, here’s a custom version that I think will work for you.
notch-custom.ny (1.17 KB)
Note that:

  1. As this is an unofficial customised version, there is no official support.
  2. You still need to fix the problem on Windows.

Installation instructions for Nyquist plug-ins: https://manual.audacityteam.org/man/installing_effect_generator_and_analyzer_plug_ins_on_windows.html#nyquist_install

spectral edit multi-tool is a notch filter.gif

Hi Steve,

Installation of your custom notch filter successful but… same outcome : there were no decimal to mess with, great but… it returned the same window (that I figure now it is not an error window but an “info” window) :

Notch return.jpg
with NO notch cleanup performed.

I wonder if that window is normal and usually shown regardless of the success of the operation, or shown only if a problem occurred ? You tell me !

Best regrads