Problems recording with UA 1G

Hi, I’ve had my Cakewalk UA-1G for quite some time, and have never really had problems with it. Anyways, I just redid my set up and had to replug everything in. However, now audacity doesn’t seem to want to recognize my UA1G. The current set up im using (if it helps) is two CDJ 800’s and a DJM 600 mixer. On audacity, I have it set so that my in is the UA1G, which it has always been. The UA1G is also connected to the booth outputs on the mixer and the booth monitor is set to half, like normal.

I’ve tried all the outputs I can to get something to record in audacity, but I keep getting the same message:
“Error while opening sound device. Please check input device settings and the project sample rate.”

This only happens with the input on my UA1G. Just to be safe, I tried making the output as my UA1G and my input as just the regular sound driver. I didn’t get an error but for some reason, my desktop microphone was being recorded. Nothing else.

I need some help D:


this may be helpful …

it’s not multi-channel is it ? …

Audacity does not yet support multi-channel audio tracks (more than 2 channels), though there is interest in doing so at some point in the future.

The proprietary ASIO interface standard is essential on Windows (and to a lesser extent on Mac) for low latency recording and playback. It is usually the best way of making > multi-channel recordings > on those platforms. Licensing restrictions prevent us including ASIO support in released versions of Audacity, but Audacity Beta can be compiled with ASIO support for private, non-distributable use. This page summarises ASIO licensing issues and steps to compile Audacity with ASIO support.

Cakewalk (Roland) UA-1G ASIO driver …

As of right now I’m just using stereo and using two channels on my mixer. I also use serato which only allows for two different channels. :frowning:

Are you using your UA-1G in its Standard mode - in which case the generic USB drivers should work

or in its Advanced mode - in which case you should need the Cakewalk/Roland drivers (which you should be able to download from their website)

I have the predecessor device the UA-1EX and it runs quite happily on both my XP machines in either mode.


Hi, as of right now I believe I am using it in advanced mode. I have already installed the drivers before, but maybe because I unplugged it, something weird happened? I have no clue. I’ll reinstall the drivers and see if it works.

Edit: reinstalled the drivers, I still get the same error. Just curious, what do you use for your in an out? I’m still clueless as to why this isn’t working…

The RCA inputs on my UA-1EX are fed from my passive switch (a Skytronic) to enable me to easily swap between my turntable and my FM tuner without unplugging/re-plugging.

The only output I use is the USB lead to the PC - I have Audacity set to target its output to the PCs onboard soundcard as I have some reasonable speakers attached to the PC and a set of high quality headphones that I can use for monitoring.

I also used the digital input on the UA-1EX (via the optical mini-jack socket) when I was transcribing my MiniDisc recordings as I wished to keep it stratigh Digital=>Digital and avoid the Digital=>Analog=>Digital conversions. This worked well.

I have also used the mic input on the UA-1EX with the mic that I had for my old MiniDisc portable recorder.


Sorry I took so long to answer this and bump it again, I’ve had tons of work and things. Anyways, I still can’t get it to work no matter what I do. I’m sure I have everything plugged in correctly on my side, so im guessing its the computer / audacity which is having the problem. Here is a screenshot of the problem I encounter + the options I can choose for input/output. Am I putting the right input in? The right output in? Are you seeing something that could be screwing with my UA1G? Thanks for any response and once again sorry for responding so late D:

Your input device looks fine as the USB device. For the output device I would target the Realtek directly. And can you select Windows Direct Sound as the host rather than MME.


I went to the windows direct sound, tried every one of them out and still nothing worked. Do I maybe have to do anything with my windows mixer thing? Do I need to be setting a default device up to record properly?

You might actually have an Audacity setting problem. Go into Audacity Preferences and set the sound characteristics to 44100, 16-bit, Stereo. It’s in two different panels. Two are in Quality and the third is in Devices, Recording. OK the panels and restart Audacity. Audacity defaults to 32-floating instead of 16-bit. If the process got reset buy accident, you might get that message.


You are right, it was on 32 bit, so I set it to 16 bit however I am still getting the same error message. Is it possible that my UA1g should be on the “out”? From what I remember my out was my UA1G, and it does seem to record, however, it records my desktops microphone. I’m so confused D:

I run my UA-1EX with Audacity set at 32-bit floating and it works fine with the UA-1EX set to 44.1kHz and either in its advanced or standard mode. My current understanding is that it is running in 16-bit in both those modes (down to the audio interface s/w used by Audacity, PortAudio: see this long thread from earlier in the year for some background: ) and Audacity is performing the upsampling on capture. I can’t see the UA-1G manual online but I believe that it is basically a reworked UA-1EX an should work the same.

Have you tried updating to the latest drivers form Roland/Cakewalk - see the downloads tab on:

Otherwise you’ve got me stumped at the moment.


Note: The reason I have Audacity working at 32-bit so that I get good headroom for editing tasks like Amplification and fades. On export of production files I use Audacity to downsample to 44.1kHz 16-bit PCM WAVs with triangular dithering applied.

Just to be completely sure that it is not on my end, I’m going to tell you how everything is set up exactly:

First, I have RCA cables going from the booth out on my mixer, to my UA1G inputs. From there, it is hooked up via USB.
I have the current drivers for the UA1G and have reinstalled them three times, it still doesn’t work.
When trying to record, I set my “in” as the UA1G and my out as whatever I can to try and make it work. The only thing that has been happening is:
A. I get the dreaded error message.
B. For whatever reason, it records my desktop microphone.
C. I get the error message D:

On my recording devices, my default is the microphone, however, setting my “in UA1G” as my default recording device does nothing. My default playback is just the default speakers.

Is there anything I could be missing? Will posting pictures help? Should we just use something like Teamviewer to see if it is on my end? Thanks for all the help so far by the way. I have no idea why it wants to do this. :[

ok lets start with the UA-1G what settings do you have made on the dip-switch settings on the base of your UA-1G (confsuingly for me I can see from the brochure that the dip-switch interface on yor 1G is different from my 1EX - and I can’t see an online manual for the 1G for more detail)?

What setting do you have on the front of the 1G for “Advanced Driver”? You do realize that if you ever change this setting it is necessary to unplug and replug the device to get it re-recognized by your computer.

Also I seem to remember that when I downloaded the drivers for my 1EX I was obliged to disconnect the device during the download/installtion to make the download/installation correctly. Did you do that when you downloaded your drivers?

Oh and are you running on Windows, Mac or Linux - and which o/s version?


No idea what the “dip switch” is on an UA1G but ill just list what I have. On the left hand side, I had an advanced driver that is turned to on. After this, it goes phones volume, phones digital out, phones digital in, guitar/mic switch and guitar/mic inputs/outputs. None of these are plugged in. My input level is almost max (as it always has been), and my two RCA cables are in the input/output on the other side of the device.

The setting is “on.” I have unplugged and replugged the device many time when reinstalling the drivers.


Windows 7 64 bit


The dip switches on your UA-1G are the little 2-position switches on the bottom of the device which are used to configure it.

What settings do you have there?


First thing to sort out is: can Windows see your USB device - i.e. is it one of the recording devices that is available for input? You should be able to see this from Control Panel > Hatdware & Sound > Sound in W7

ok. so then let’s start with a simple test. With the UA-1G connectd can you use Windows Sound Recorder to record sound from your input device. Does that work?


On my DIP switch, everything seems to be off? 1,2,3,4 and 5 are all down.

In my control panel, I can see my UA1G as an input and output device. I set it to default on input device. Then I tested it using windows sound recorder, however I get the message, “An audio recording device can not be found.”

Here is a poorly drawn chart because the dips thing confused the hell out of me and there are a bunch of different modes…

Thanks for the chart - useful.

I’ve finally manage to track down a copy of the online manual for the UA-1G (by goig to the Roland site rather than the Cakewalk site - Roland is the Parent co. Cakewalk is one of their brands).

ok so now we know that you’ve got is set to 44.1 kHz which is good
Switch 2 is irrelevant when you arec set to 44.1
You are set to be able to monitor so you should be able to plug headphones into the UA-1G’s sphone socke for h/w monitoring
And you are set to record from analog input
All this looks fine.

so now I am confused by the fact that you say WSR says “An audio recording device can not be found.” - this has me thinking that maybe there is a fault with your UA-1G. Do you have access to another computer that you can try it on?


I note that in an earlier post a successful W7/UA-1G user posts in this thread :

So you are sure that you have the device switched to its Advanced mode (sorry to ask again)?

So we know that at least one user has a UA-1G working properly on Windows 7