Noise Gate Issue? [SOLVED]


I’m at work on a Win 7 Pro Machine (I know it’s not supported) and I have Audacity 3.0.0 running.

I was playing around with Noise Gate (vs. Noise Reduction) to see what flexibility there was in that plugin.

What I’m finding is that in 3.0.0, I need to have the “Hold” parameter set at Zero for the effect to work on my audio. In 2.4.2, I just loaded the defaults and it worked fine.

If I don’t have “Hold” set at Zero, and I click OK, I get nothing other than that the dialog box disappears but there is no progress dialog or no impact on my audio. See screen shots below.

I am going to test this on Win 10 when I get home tonight.


Ver 2.4.2 - Before/After Noise Gate Defaults
NG 2.4.2.JPG

Ver 3.0.0 - Before/After Noise Gate Defaults
NG 3.0.0.JPG

Ver 3.0.0 - Before/After Noise Gate Defaults (Hold at 0 seconds)
NG 3.0.0-A.JPG

Thanks for the report. It’s a bug.
I can’t immediately see a fix, so I’ll log it.

The only workaround for now is to always set “hold” to zero.

Making some progress here.

The cause of the problem is due to an Audacity update that happened after Noise Gate was updated.

I’m currently testing a possible temporary fix so that you can use Noise Gate fully while waiting for the next Audacity release. I’ll post it here when I’m happy that it does the job correctly.

Here’s a modified version of the Noise Gate plug-in.
I’ve named it “Noise Gate 2” so that you can distinguish it from the original.

It is a “Nyquist plug-in”. Installation instructions for Windows are here:

After installing the plug-in, enable it in the Plug-in Manager, and disable the original Noise Gate.

When the next version of Audacity is released (we are expecting a short release cycle for the next version), you will be able to disable “Noise Gate 2” and re-enable “Noise Gate”.

Here’s the plug-in:
noisegate2.ny (8.65 KB)
Let me know how you get on.

Thanks Steve - I’ll give it a try.


Thanks Steve, seems to be working with various values for the “Hold” parameter now.



Remember that this is just a temporary workaround. When you next upgrade Audacity you should switch back to the official Noise Gate (I’ve logged the bug as “P2” to ensure that it is fixed in the next Audacity release).

I’ll lock this topic as it contains a fix that I expect others will need.