Noise Gate doesn't work at all

This bug has just come to light.
There’s an explanation and a temporary fix here: Noise Gate Issue? [SOLVED]

At first, it shows me 2 Noisegates

In addition to the fix in that post, you should ensure that you disable all versions of Noise Gate in the Plug-in manager other than the fixed “Noise Gate 2” (noisegate2.ny)