Installing LAME on Mac

I managed to download the LAME library .dmg file for a Mac but an having GREAT difficulties getting it to work with Audacity. I know for sure I don’t know how to follow the written instructions. Is there someone who can walk me through this? Thanks.

First, please tell us which version of Audacity you are using: do Audacity > About Audacity and report the full, three-digit version number. Also, please tell us which version of macOS you are using.

Did you go to the LAME download page and download this link?
RECOMMENDED Installer Package for LAME on OSX:

Once you have opened the DMG, did you double-click “Lame Library v3.99.5 for Audacity.pkg”? If you did, that should install the LAME library in the standard location for Mac.

If you are running a recent version of Audacity, it should then automatically find LAME. In Audacity, do Audacity > Preferences, then the Libraries section and verify the “MP3 Library version”.

At which point in these steps do things no work as expected?

– Bill

I’m using Audacity 2.2.1 and MacOS High Sierra 10.13.2.

I’ll try my very best to follow your instructions to the letter.


I’m having the same problem: despite downloading and trying to install Lame_Library_v3.99.5_for_Audacity_on_macOS, following instructions carefully, nothing is installed in my ~/Application Support/Audacity/Plug-ins folder. I’m running Audacity 2.1.2 on a 2013 iMac using macOS Sierra 10.12.6.

Although Audacity is working fine for normal Import and Export, I can’t find an Audacity Preferences file in the ~/Library/Preferences folder.

Several years ago I had to do the same thing on an earlier version of Audacity, and the LAME plug-in worked fine.

The LAME library is not installed into ~/Library/Application Support/audacity/Plug-ins. It is installed into /Library/Application Support/audacity/libs. If you double-click the file “Lame Library v3.99.5 for Audacity.pkg”, it will install the LAME library into the correct location, and the next time you start Audacity it will find the library. Look in Audacity > Preferences, then the Library section.

Audacity preferences (the file is “audacity.cfg”) is not installed into ~/Library/Preferences. It is installed into ~/Library/Application Support/audacity.

– Bill

I solved the problem of the LAME plug-in not installing properly by deleting Audacity 2.1.2 from my system and downloading Audacity 2.2.1 from the Audacity website. I then discovered that this later version INCLUDES the ability to Export mp3 files directly, without needing me to download a LAME plug-in.

Actually, what probably happened is that Audacity 2.2.1 automatically found the LAME encoder that you had already installed. LAME is not bundled with Audacity.
Go to Audacity > Preferences, the Libraries section, to see which version of LAME Audacity found, and where it is installed.
– Bill

I am using Audacity 2.3.0 on my Mac with High Sierra OS. I have downloaded LAME a million times and when I try to export an mp3, I have followed the instructions online up until it asks me to browse to locate the mp3 library. At this stage I hit a wall because I cannot find LAME or any dll file so I cannot save the new edited file as mp3.
Can anybody help me please. I have not much knowledge of Mac. I used to have Audacity and LAME on Windows and it worked perfectly. I do not know what I am doing wrong. It is so frustrating!!!
I would appreciate some help on this.
Thank you in advance

I suspect that LAME is not correctly installed.

Open a Terminal window and enter the following (copy and paste so that the command is exactly right):

ls  "/Library/Application Support/audacity/libs/"

What is the output message?

I’m having the same issue. This is an outline of the problem, and the corrective steps I’ve taken (no luck thus far):

I’m struggling to get past this error: Audacity can’t find the Lame library. This msg (familiar to a lot of us, I imagine) appears when I try to export to MP3.

“Audacity needs the file mp3lame.dylib to create MP3s.”

I clicked on the button “To get a free copy of Lame …”

I installed the library from the DMG, relaunched Audacity. I got the same message (Audacity needs …).

I downloaded and installed the latest version of Audacity for MacOSX (I’m on Mojave 10.14). Launched it. Can’t create MP3s. “Audacity needs …”

Any suggestions about what to try next? Thank you.

Here are the instructions in the Audacity Manual for downloading LAME on Mac:


Steve: I followed your instructions regarding ls. I get the following output:


In Finder, I can’t find the path listed in your recommendation (although I’m fairly sure I’ve been in the Application Support folder previously).

But the path must be there, right? Otherwise ls wouldn’t return libmp3lame.dylib

I’m researching the problem. This, again, is the path:
/Library/Application Support/audacity/libs/

I was able to export an MP3 (meaning I overcame the problem with Audacity not finding the LAME library; BTW I’m on Mac 10.14) thanks to Steve’s recommendation to use ls at the command line to find the path of mp3lame.dylib

Here are the steps that worked. At the command line, type:
ls “/Library/Application Support/audacity/libs/”

That tells you where the file is located (if it IS on your system). The file wasn’t listed when I searched USERS (an interesting problem itself with Finder). I had to search only on the hard drive in order to find it.

Once you know where it’s located, you can export to MP3 by directing Audacity to the file, following the path listed by ls at the command line.

Mojave 10.14.3

Exact same issues as everyone else. Trying to convert file into MP3 - Spent hours now.
Doesn’t matter how many tutorials I follow or read all the suggestions here I can not do it!
Yes I’m a donut.
Yes I need a walk through before I smash the Mac up!! Unbelievably frustrating.
Thanks in advance

I’m experiencing the same issue of not being able to install and access Lame. When I run the Lame installation package, it does not create a lib directory in Library/Application Support/audacity and .dylib is not installed; only the AutoSave and Plug-ins directories exist. I’m running macOS Mojave 10.14.3 and have Audacity 2.1.1. I tried a fully clean install; I removed the Audacity folder from both Applications and from Library/Application Support, reinstalled Audacity and then Lame, Library/Application Support/audacity is not recreated (yet - I haven’t done any other operations in Audacity other than try to set the mp3 export library location). I did review the install log in the Mac Console, and there are two errors but this doesn’t seem to stop the installation process:

2019-02-14 15:28:06-08 Js-MBP Installer[11436]: -[IFPKGDerivedDocument sortedPackageLocations]: result = (
2019-02-14 15:28:06-08 Js-MBP Installer[11436]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: location = file://localhost
2019-02-14 15:28:06-08 Js-MBP Installer[11436]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: file://localhost/Volumes/Lame%20Library%20v3.99.5%20for%20Audacity/Lame%20Library%20v3.99.5%20for%20Audacity.pkg
2019-02-14 15:28:06-08 Js-MBP Installer[11436]: Set authorization level to root for session

I can provide the full log if that’s helpful.

My issue was solved - in the installation instructions I missed this tidbit:

“Click through the steps in the installer. This will remove any previous libmp3.dylib at /usr/local/lib/audacity and install the 3.99.5 libmp3lame.dylib file in the system library at /Library/Application Support/audacity/libs/.”

So while Audacity by default looks in the user directory, LAME is indeed installed in the Library directory at the main hard drive directory. Alas RTFM…