Help - Internal error at D:\a\audacity ....


I’m running Win 10 and Audacity 3.1.2 and I got an error (see attached) when trying to open a project as well as when I attempted to open the two previous backups of the project that I made. I can go back to one version of the project that I have that does load, but that is a few steps further back in the process. I was hoping to get my current version back or one of the two recent backups I made.

The message mentioned “D:\a\audacity.…” and I do have a D: drive, but it is my system backup drive and there is no “D:\a\audacity…” path/folder on that drive. I do have the option turned on to see hidden files as well.

All my .aup3 files are on my C: drive and I am loading the project from my C: drive.

Any ideas about what might have gone wrong and how to fix it?



This is what is in the problem details box that pops up:

“timestamp”: 1637962472,
“event_id”: “8a5a867011650041842a5347e5cccdae”,
“platform”: “native”,
“release”: “audacity@3.1.2”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19044”
“exception”: {
“values”: [
“type”: “Internal_Error”,
“value”: “Internal error at line 547.\nPlease inform the Audacity team at https://.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false


So if you care to zip up your .aup3 file and upload it to a public file server, then post (or PM me) the link, I’ll take a look at it.

Thanks jademan - I sent a PM and a link to the file on my google drive.

OK, the good new is that this project loads OK on the new 3.1.3-Beta, which some are hopeful will be released very soon. :smiley:

We have a 3.1.3 beta for you to test. It should significantly speed things up (especially loading in) and also fixed a crash, but it did require large under-the-hood changes, so we want to know if anything breaks with real projects.
Please download and test it out on > Release Audacity 3.1.3 Beta 1 · audacity/audacity · GitHub

Unfortunately, since we can’t reproduce your issue on 3.1.3, the developers tend not to be interested in pursuing this kind of problem.

I tried using 3.1.3 to copy the entire project (Ctrl+A, Ctrl+C) to a new 3.1.3 project (Ctrl+N, Ctrl+V) and while this duplicated and saved OK, I had the same problem trying to open it in 3.1.2. I was able to load your project in an special test version of Audacity I have that bypasses the new 3.1.x features, but when I did this, some of your smaller clips ended up with no audio - I am not sure just why.

I also noticed you had some audio before zero. I am thinking this could be contributing to the problem but I don’t know.

As I see it you have three options:

  1. Wait for 3.1.3 to be released.
  2. Migrate to the the 3.1.3-beta now (which cannot be recommended)
  3. Use the 3.1.3 beta to extract the portions of the project that you need and re-import into 3.1.2.

I was trying to do step #3 myself, but I ran out of time - it is a little time consuming due to the size of your project and I have other things on my schedule. :wink: However, there is no reason that you could not do this yourself:

What I try to do is SELECT a small set of tracks (possibly just one), then Ctrl+C to copy it to an Ctrl+N(ew) project via Ctrl+V (paste). Then I save the result as a separate project, and test to see if I can load it into 3.1.2.

Hopefully, I would be successful with that, and hopefully, can merge these project together with 3.1.2. Of course there are no guarantees.

Good Luck. :smiley:

Thanks jademan - I will pursue the copy/paste option with 3.1.3 and see how that goes.

Any guesses as to why it might load in 3.1.3 but not 3.1.2? It’s likely not a corrupt file because it loads in 3.1.3. Not a big deal for me to know, just wondering.

Thanks again for looking at this - I really appreciate it!


jademan - the copy and paste to a new project and then opening the new project in 3.1.2 worked great. Thanks for the work around!


And thank you for your report. I’m glad you got it all working. :smiley: