Saved file won't Open

Hi all,

I’m using the latest 3.1.2 version of Audacity on Windows 11. I’ve been using Audacity to edit audio for the past several months without much issue. Today I was editing some audio and saved and closed the file. Not more than ten minutes later I go to open it and I get the error listed below. Now the file won’t open at all. Any ideas on what’s wrong or how to regain access to my file? Thanks.

Internal error at D:\a\audacity\audacity\libraries\lib-xml\XMLWriter.cpp line 547

Problem details:

    "timestamp": 1637616333,
    "event_id": "eb45b8f9d651eb4693b64c3c59af88ff",
    "platform": "native",
    "release": "audacity@3.1.2",
    "contexts": {
        "os": {
            "type": "os",
            "name": "Windows",
            "version": "10.0.22000"
    "exception": {
        "values": [
                "type": "Internal_Error",
                "value": "Internal error at <path> line 547.\nPlease inform the Audacity team at https://<path>.",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false

I can’t say that I have seen this error before. If you want to zip up your .aup3 project file and upload it to a public file sharing service then post (or PM me) a link, I’ll take a look at it tomorrow or Wednesday. (I have another project ahead of yours).

Thank you very much for the offer, but I’ve kind of (?) fixed it. I had originally made the file in 3.1.1 and recently updated to 3.1.2, which I was using when I worked on and saved the file today. I decided to try uninstalling and reinstalling 3.1.1 instead, and the file opens just fine. I’m assuming there is some kind of error with saving files in 3.1.2? But regardless, it seems I’ve solved it :slight_smile:

There were known issues in 3.1.1, and there are no known issues with 3.1.2.

This would be really helpful if you can share the problematic AUP file so we can fix the issue!

But looking at the problematic line - this issue will definitely be fixed in the upcoming 3.1.3 beta!

I have the same issue right now. I am using Audacity 3.1.2, can someone help me fix this. Badly needed. Thanks

So I’m running out of town right now - but I expect to be back later today. If you care to zip up your .aup3 file and upload it, then post (or PM me) a link, I’ll take a look at it when I get back. :smiley: No promises as to whether the issue can be fixed. :frowning:


This looks like a problem I recently had. The solution for me was to open the file in the beta version 3.1.3 and then copy each track from that project to a new project in version 3.1.2. I loaded version 3.1.3 as a portable version so that it did not interfere with my live 3.1.2 version.

Maybe that will work here.


Here is the original thread - Help - Internal error at D:\a\audacity .... - #6 by mafg1953

Others have already said it, but I wanted to chime in and confirm. I’d been using V 3.1.2 for several weeks with no issues, but today it refused to open a 2.5 hour audiobook chapter I’ve been working on for a week. Scared the s**t out of me. But I read the posts on this thread, whacked 3.2.2 and reinstalled 3.1.1 and the file opened no problem. Crisis averted . . .

Bottom line, keep all your install files handy.

whacked 3.2.2 and reinstalled 3.1.1