Dubbing not working

Hello, I work on Windows 10 with Audacity 3.1.3 version. I connect microphone to M-track Duo interface to pc to sing. I record the first file and it works fine (and I can hear myself in the headphones while recording). If I try to dub a second file on it, it doesn’t record. I already set M-Audio to “2 channels; 16-bit - 48000Hz” as per supplier instructions and same values in Windows 10 Audio panel. Still not working. So sad I just bought M-track and cannot fix this issue. Thank you for any helping and sorry for my poor English.

OK, a couple of things:

  1. Are your headphones connected directly to the PC or directly to the M-track?
  2. Can you hear your recording when you play without overdubbing?
  3. Try both WASAPI and MME
  4. Don’t try to mix stereo and mono. (2 channels = stereo)


  1. Are your headphones connected directly to the PC or directly to the M-track?
    wire connected to M-track
  2. Can you hear your recording when you play without overdubbing?
    yes I can hear myself during the first recording
  3. Try both WASAPI and MME
    tried WASAPI but still not working, I got the error “invalid sample rate”
    invalid sample rate.png
    (see screenshot)
  4. Don’t try to mix stereo and mono. (2 channels = stereo)
    OK I usually sing on basis with stereo features, I tried to add my voice in stereo but still not recording;

Today I deselected “play other tracks while overdubbing” and I succeeded in recording my voice but I cannot hear the basic track so I sing without hearing anything. :unamused:

I hate Windows. :imp:

UPDATING: now it works :laughing: I do not know how I did, but I fixed it. I just post a screenshot of my setting in case it might be usueful for others:
I set 16-bit PCM - 44100Hz, MME, 1 (mono) channel recording
It seems solved (for now :mrgreen: )

Thanks for the update and the screenshot.

No I guess I messed up, it is not working still :unamused:
Now I got in touch with M-Audio service since it is not possible to select their requirements 16bit-48000Hz (quality studio) in Win10 audio recording settings, that selection is unavailable (16/24/32 bit can be selected but they all have 44100Hz only)
recording settings win10.jpg
, they are now checking a solution since I need to use Audacity and I must fix this issue. If you have any further idea, I would be more than happy to make attempts :unamused:

Hmm… Let me try to digest what you have said… … … …

… … … …

It doesn’t really make any difference what speed you select - 44100 or 48000, just try to set them all to the same value.

Also check your playback settings.

:laughing: I mess a lot with technical issues :innocent: I guess it’s a problem that Win10 doesn’t allow me to set 48k hz where I should. I thought it accepted it but I later saw it changed by itself the value at its convenience :open_mouth:
I asked M-audio to check this because if I cannot set in Win10 correct values, this issue might affect Audacity working. I do not know why I made selections and Windows changes it, you discoverer it once you step again to check values and you find them misteriously updated :smiling_imp:

once you step again to check values and you find them misteriously updated

You may find “Mysterious Updating” can be caused by applications other than Audacity. If you like to use Skype, Zoom, Meetings, and others, their settings can hang around and mess up other apps. Make sure everything is closed before you do production. If you’re on Windows, you might want to Clean Shut it Down and start over.

Shift+Shutdown. Not Shutdown and not Restart. Do not let anything else start.

When you type numbers in the screen, only the screen gets them. When you press Enter, the machine tries to apply your numbers to the system. You have what happens when that fails. There was a note a while back that Windows didn’t like 48000 sample rate very much and likes to stick at 44100. I don’t remember, but that would do it.

Whatever you do, Audacity needs both sides of the system, recording and playback, to match for overdubbing.

48000 is not the super high quality professional sample rate. It’s the video rate. 44100 is the Audio CD rate and 96000 is used in studios.

Dubbing is when you copy some production work from one machine to another. Overdubbing is when you listen to an existing backing track and add voice or music to it.

There was another forum posting where Overdubbing repeatedly failed for no known reason. Still working on it.


Is it a coincidence that they are both M-track Duos ?

…in the meanwhile I got a reply from M-audio service to try to sing on my bases by using AKAI MPC beats but that software is a mess for non-technicals :confused:
It seems to me that no other programmes are running while I work on Audacity but Winzozz is always working in shady manners :imp:

Updating: I finally got it working with these settings:
audacity overdubbing settings.png
windows audio settings.png
strange I had to change output from M-Audio to "Microsoft sound mapper" (??) to make it work, now headphones jack is connected to pc. The only pity is that I cannot hear myself while overdubbing but the result it’s ok, it is correctly recorded and I am used to not hear myself while my band plays live :mrgreen:
Just a note: M-Audio instructions suggest to set to 48000hz the input but it is not accepted by Windows, in any case 44100hz quality is enough for me (not a PRO :unamused: )
Should you have any suggestion for hearing myself while overdubbing, I would be very very obliged :blush:
Meanwhile, I thank you again because with your forum you saved me. You are GURUs.

Plug your headphones into the M-Track Duo. I don’t have a manual for the Duo, but I’d guess that the “Monitor” knob controls the amount of “live” microphone in the headphone mix.

If I set headphones to M-Audio interface, both in Win10 and Audacity, the overdubbing does not work. I push red record button (or Shift+R, or record via drop-down menu), Audacity opens a new track but it immediately stops. I asked M-Audio service for suggestion, they told me Audacity works in a weird ways with some audio interfaces. I know some other users are facing the same issue but, as I told M-Audio service, for instance they suggest in their manual to set 48000hz but Win10 does not allow me to do it, there is no selection available rather that 44100hz. :unamused:
To me it’s ok even not to hear my voice while singing but I guess it would be a mess for any instrument player. The instrument would sound deft.

That looks to be the root of the problem (and it has nothing to do with Audacity). The native sample rate of the M-Audio Duo is 48000 Hz, so setting Windows and Audacity to 48000 Hz sample rate should allow simultaneous recording and playback without any sample rate conversion.

I don’t know why Windows will not let you set the Duo’s sample rate to 48000 in Windows. If you can sort that out then I expect that everything will work correctly.

Sometimes Windows will provide different options depending on how you access the settings. Try accessing them like this:

  1. reboot the computer
  2. open the run dialog with Windows logo + R
  3. enter: mmsys.cpl
  4. press the OK button

Note that the sample rate should be the same in both the recording and playback tabs.

Yes I definitely think it’s all about Win10 blocking any changing in settings, preventing correct Audacity running.
I just discovered a discussion up to year 2018 about this issue in Windows forum, same problem faced by those who had a new audio interface. So I guess Audacity will work properly with fine settings. I just tried your solution to access the settings via "mmsys.cpl" but it still shows only 44100hz in recording field. Is this selection supplied by drivers coming from M-Audio (which I downloaded before installing the interface, so I could complain with M-audio for non-working drivers) or it comes from Win10 ? Sorry but it’s hard to me to understand the source of what Windows shows :confused: Should the selection come from Win10, how can I maybe update the drivers for only that part ? Surely you know it :mrgreen:

I’m not an expert on Windows as I usually use Linux, but I think that Windows should be getting the list of available sample rates from the M-Audio driver.

You previously wrote that: “they suggest in their manual to set 48000hz”. I’d suggest that you ask them how to do that (and explain that the option does not appear to be available in the Windows Sound control panel). Ensure that they are aware that you do not want to use ASIO, just the normal Windows sound system.