Can't overdub with M-Audio M-Track DUO

I’m running Windows 10 Pro Version 22H2 OS Build 19045.2364
Chip: AMD A8-7600 with Radeon R7 3.10GHz
8.00GB RAM
I am using an M-Audio M-Track DUO audio interface, fed by a Mackie 1202-VLZPRO mixer.
I am running Audacity 3.1.3 (I have now also tried 3.2.3 without success)

Overdubbing in Audacity works perfectly well with various other interfaces I have, including a Behringer UCA222 and an old ZOOM H2 HandyRecorder.

Audacity refuses to mobilise the second track of an overdub effort, after doing a great first recording. The second track sits frozen at “start” while I can hear the audio for the second track in the headphones via the M-Audio interface. SO, I have exactly the same problem as stated by others here, with the same symptoms.

Audacity bluntly refuses to work with this particular Audio interface, which is otherwise a good device, though its latency is not really good. My bare bones Behringer UCA222 has way better latency, but Behringer no longer supplies the ultra-low latency driver. So, I am keen to do overdubbing using the M-Track device. NO CAN DO. Audacity freezes on any attempt to overdub.

I’m out of ideas here. I have contacted M-Audio. They are absolutely zero help in this process while having the audacity (no pun intended) to congratulate themselves in e-mails to me on “how well” they have “helped” me as client.

Check the settings in “Preferences > Devices” and try both “MME” and “WASAPI” as the “host” setting. (Close and restart Audacity after changing).
Ensure that “buffer” is set to 100, and “latency correction” to -130 (negative 130) - you may need to tweak the latency compensation when overdubbing is working, but these settings should be “safe”, whereas “unsafe” settings can cause the problem that you have described.

If no success with either, go to “Preferences > Quality” and try changing the sample rate from 44100 to 48000. (Close and restart Audacity after changing).

Yes. I see you still haven’t had this working since you reported this issue last May: Can't overdub with interface - #17 by HarryBoo

But misery loves company. You are not the only one with this issue with the M-Audio M-Track. For your reading pleasure:

I think someone was successful by changing to Scarlett and another by sending Audacity’s output to the PC headphones.`

Let us know if you ever get it to work. :smiley:

I installed Audacity 3.3.3 today, and now overdubbing works with the old settings and the same M-Audio M-Track Duo interface. Strange, but true! Well, well, well.

Thanks for the update. :grinning: