Audacity stops recording during silence [SOLVED]

I am trying to record audio from my computer.

I used to just hit record and play the sound I need to capture, and then cut out some of the silence.
Now Audacity will not record until sound starts playing.
It is a problem, because it doesn’t catch the beginning of the sound I am playing.

I tried toggling sound activated recording and it didn’t work.

If I forgot to include anything please let me know.

Which Audacity?

Transport > Transport Options > [_] Sound Activated Recording should not be checked.

Restart Audacity and make sure it stays unchecked.

Koz

my audacity version is 2.3.2

I tried this and it didn’t work.
I currently have sound activated recording off.
It stays off when I restart audacity, but it acts as if it were on.

What are you recording,
how are you recording it,
and what settings do you have in the device toolbar?

I am recording text-to-speech from a website. Here is a link: http://www.ttsdemo.com/

Here’s the steps for how I record it:

  • Type in the text I want translated


  • Hit record on audacity


  • Play the text-to-speech program


  • Hit stop on audacity


  • Repeat until I have all the recordings I have


  • cut out the really long pauses (I want a little silence between the clips so they are easier to cut)


  • export the recording as an mp3

I think that’s all the steps.

my settings for the device tool bar are:

Audio Host: Windows WASAPI
Recording Device: Speakers (High Definition Audio Device)(loopback)
Recording Channels: 2(Stereo) Recording Channels
Playback Device: Speakers (Realtek High Definition)

I think that’s everything

Are you recording in mono or stereo?

If recording in stereo:

  1. Launch Audacity

  2. Add a new mono track (tracks menu)

  3. Click the Record button. Recording should start straight away.


    If you are recording in mono:

  4. Launch Audacity

  5. Add a new mono track (tracks menu)

  6. Hold the Shift key down and click the Record button. Recording should start straight away.

The Shift key is required in the mono case to tell Audacity to record to a new track.
The Shift key is not required in the stereo case because Audacity will start a new track anyway (it can’t record stereo to a mono track).

Alternatively, if your sound card has a “Stereo Mix” option when MME is selected, you could use that instead of WASAPI loopback, and would then not need to add the “dummy” track.

I am recording in stereo.

I tried both of your suggestions and neither worked.
My sound card doesn’t have a “stereo mix” option.

I’m sorry if I’m getting irritating.

If the work-arounds don’t work you might try [u]Total Recorder[/u] which has it’s own virtual driver (and is supposed to be “foolproof”).

Awhile back when researching this issue with WASAPI I found [u]this technical/programming site[/u] that explains the root problem:

Another oddity is that WASAPI will only push data down to the render endpoint when there are active streams. When nothing is playing, there is nothing to capture.

That means that there is nothing you can do against that behavior. If there is nothing playing, nothing will be captured.

Their solution was to run a program called “silence.exe” (which I guess plays a continuously-silent stream) but Google doesn’t easily find the program they are talking about.

Curious. Are you certain that “Sound Activated Recording” is NOT enabled?

How much is missing from the start?

Are you using a laptop computer?
Are you able to make normal microphone recordings?

I am certain.
I tried it with Sound Activated Recording enabled and disabled just to be sure.
Neither works.

The first word sounds cut off.
It is noticeable and makes the recording unusable.

I am using a desktop computer.
I can make normal microphone recordings, but I have a low quality microphone.

In “Edit > Preferences > Playback”, ensure that “Micro-fades” is not selected.

micro-fades is not selected, but the other two (vari-speed play and always scrub unpinned) are selected.

This doesn’t make sense. Let’s go back a few steps.

When Audacity is set to record from WASAPI loopback. You press the record button, and what exactly happens?
What do you do next?
What happens then?

Here’s everything that happens after I press record:

A lot of the buttons and drop down menus on the toolbars are greyed out.
The green upside-down triangle that says “Click to Pin” turns red.
An audio track appears that reads (stereo, 44100Hz,32-bit float).
There is a red upside down triangle on the timeline action bar to follow the recording.
The red triangle constantly flickers but doesn’t move unless sound is playing.

I play some audio(YouTube video) and it follows along recording what audio is playing.
The toolbar called recording level fluctuates along with the audio track displayed beneath the toolbars.
When I turn off the YouTube video (but keep recording in audacity) the red triangle stops, leaves a space of one half of a second in front of the recorded audio, and starts flickering there.

If I hit stop the red triangle on the timeline disappears and the click to pin triangle turns back to green.
The disabled buttons and menus can be used again.

I think that’s everything.
Could it be something else on my computer causing the problem?

I’m sorry if I’m getting irritating.

Not a problem. We think you may have discovered a previously unknown oddity. You’re a celebrity.

I can make normal microphone recordings, but I have a low quality microphone.

We’re not so much concerned with the voice quality as we are whether the microphone works at all. It’s part of the testing system. We’re collecting lists of what works and what doesn’t.

I am using a desktop computer.

Right there is something missing. Desktop computers tend not to have built-in microphones. How are you getting a microphone into the system—in detail.

Koz

OK, Please make a short recording (say 5 or 6 seconds) of the text to speech, and Export it as a WAV file, then upload the WAV file with your reply. (See: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

This is a “feature” of Microsoft’s WASAPI host it only records when there is an active signal. when there is no active signal recording pauses and will restart once an active signal resumes. It is not an Audacity issue, it’s not something we can do anything about.

This page in the Audacity Manual talks a bit about this (I will try to make it clerarer for the Manual for the next release)
https://manual.audacityteam.org/man/tutorial_recording_computer_playback_on_windows.html

Peter.

OK so I spent some time updating a couple of relevant pages in the Manual

  1. The Device Toolbar page - where I added a bit about WASAPI loopback pausing with no active signal
    https://alphamanual.audacityteam.org/man/Device_Toolbar#Audio_Host

  2. The tutrila on recording computer playback. I added a similar bit about WASAPI loopback pausing with no active signal - and I took the opportunity to tidy up and refresh this page
    https://alphamanual.audacityteam.org/man/Tutorial_-_Recording_Computer_Playback_on_Windows#Windows_WASAPI_loopback_recording

These changes will only become generally visible one the next release, 2.3.3, is out. I cannot update the released Manuals they are set in stone.

But thanks rlmfan066 for the nudge to revisit and refresh those pages.

Peter

Here is my audio recording in WAV file format.
If there’s anything wrong with it let me know and I will make another one.