Audacity stops recording during silence [SOLVED]

What are your settings in “Edit > Preferences > Devices” in the “Latency” section?

My settings in the “Latency” section are:
Buffer length: 100 milliseconds
Latency compensation: -130 milliseconds

I have a headset with a microphone on it.
First I plug it into the computer.
Then after I open Audacity, The Device toolbar reads this:

Audio Host: MME
Recording Device: Microphone(High Definition Aud ← (It cuts off here for some reason)
Recording Channels: 2(Stereo) Recording Channels
Playback Device: Speakers (High Definition Audio ← (Here too)

I can then use the microphone to record things normally.
I press record, say stuff, then hit stop.
It works okay with the microphone.
Would you like a small recording of that for troubleshooting too?

Try setting “Latency compensation” to zero.

As waxcylinder wrote, when using WASAPI, if there is no active audio stream, then there is nothing (not even zeros) for Audacity to record, so Audacity is left waiting for the data. In many cases this is rather convenient as you can set Audacity to record, and then start the thing that you want to record, and there is no leading silence to trim off after.
The problem in your specific case, is that the speech starts immediately at the start of the audio stream. By default, Audacity applies a little bit of latency compensation - it moves the track back a little to the left to compensate for latency delay. It is this that I suspect is clipping of the start of the first word.

That worked!
Thank you guys very much.

I don’t know why it was working the way that it did.
Sorry for the inconvenience.