Audacity on Big Sur

I’ve just been testing Audacity on my Macbook Pro with the newly downloaded Big Sur macOS 11.0.1

The good news is that I found that Audacity 2.4.2 and the latest alpha test build for the upcoming 3.0.o run fine on Big Sur.
I tested recording, importing playing.

Big downside the Big Sur wallpaper is HORRIBLE (IMVHO) - that is definitely gonna go when I remember how to do it.
Big Sur wallpaper.png

Good to know. Thank You.

macOS 11.0.1 (Big Sur)

Something is chewing up the processor or memory and causing audacity to get dropouts.
Screen Shot 2020-11-17 at 11.27.55 PM.png
This is when recording additional audio onto a pre-BigSur audacity file.
At one point the macOS crashed and a crash report was sent to them, and another time the crash report was for audacity and sent it off.

I just tested on my Macbook Pro with 11.0.1 Big Sur - opened an existing one hour project and then did a further 30 minute recording

a) I don’t get any drop-out markers (and I do have that facility turned on, I checked)

b) Audacity doesn’t look that resource hungry - it’s taking 24-25% CPU and 80-81MB memory

Screenshot 2020-11-18 at 15.18.40.png
Screenshot 2020-11-18 at 15.19.10.png

I also tried running some other resource-hungry apps like web-stream download and playing a movie - but still no dropouts.


Fortunately, you’re not stuck with the default desktop.

This is my gray background. It is intended to be neutral 77 across the board.

Nothing like the desktop/background competing with colourmatching.

The old laptop had a thunderstorm over the San Gabriel Valley, dramatic and desirable (and gray), but things kept getting lost in the cumulonimbuses.


This may have changed by now, but Desktop > Apple (upper left) > System Preferences > Desktop and Screen Saver.

Screen Shot 2020-11-18 at 9.09.59 AM.png
At one time I had to build the colour, but the last Mac had one close enough.


You betcha Koz
Screenshot 2020-11-18 at 17.51.00.png
Big pregnant female reef shark at Fakarava French Polynesia - best shark dive I’ve ever done, many hundreds of sharks across the atoll channel in the current some of them coming really close like this girl.



Right after Big Sur came out, my Audacity stopped working. I thought it was a problem with the USB cord connecting my interface to the computer. I occasionally had problems with it disconnecting. Then, I bought a new interface and a new cord, and tried those, and still couldn’t hear anything from my microphone. I have re-installed the drivers, re-started my computer, everything I could think of. The only thing that finally fixed the issue was installing Big Sur (which I had held off from doing for fear that it would make Audacity stop working).

It worked just fine for a week, and now, yesterday, it stopped working. This time, it’s saying that Audacity needs to get updated to be compatible with the new OS. When I press record, nothing happens. Sometimes I get an error message about the bitrate.

Why would it work for a week just fine and then decide to stop functioning?
Anyone else having this problem?

You need to update your audacity to the current mac version (64-bit) (2.4.2):

See also:

Just a big thank you for this thread. I have been hesitant to update only for the fact I don’t want to worry about Audacity LOL

I will update now. Thank you!

I’m already on the current Mac version 2.4.2…

I just tested it, and it actually records just fine when using my built-in mic. It’s only when I connect to my interface and pro mic that it just won’t record. Thoughts on that?

Perhaps you can test your interface and pro mic with Garage Band.

I am on macOS Catalina 10.15.7
with Audacity 2.4.2

I was checking to see if there were know problems by upgrading to BigSur It appears as there should not be any issues with Audacity as there are with some other softwares
Thanks for everyones input!

Hopefully this is the correct thread for this…if not please let me know.

I’ve updated to Mac OS Big Sur and while Audacity seems to mostly perform well, every so often I have to close it down and reopen when I get a pop up error message saying “Error opening sound device. Try Changing the audio host, playback device and the project sample rate.”

I use Bose USB audio as my preferred sound output and until Big Sur, I never got these messages. Any suggestions, and I have tried changing the audio host to the onboard Mac output and it works fine so it appears on Big Sur, to be some issue with the Bose output.

Check that the USB lead is securely plugged in at both ends and try using a different USB socket on your computer.

This problem may occur if the computer temporarily loses connection to the USB device. The computer will automatically reconnect if it can, but if that happens Audacity does not know that a new connection has been made and will still try to use the original connection - that leads to an error in Audacity because the original connection is no longer available.

If the problem occurs again, rather than restarting Audacity, try “Transport menu > Rescan Audio Devices”, then check that the correct devices are selected in the Device Toolbar.

I am noticing some bugs working in Audacity 2.4.2 and Big Sur.

Using the Time Shift Tool was definitely giving me problems.
I could highlight the clips, but many times I just couldn’t time shift them.
A little cursing and some random clicking around (but usually rebooting) Audacity would get it to work.

Also noticed that applying filters (Amplify) and (Bass and Treble) caused Audacity to lock up many times.
Had to Force Quit to get out of those. This was particularly frustrating.

Other than that, it’s working okay for me.
I am not a power-user though. Just a hobbyist.

Have you got the preference for “Editing a clip can move other clips” turned “off” in Tracks Behaviors preferences:

It is set “on” by default - if you turn it “off” it can stop clips moving when there is not enough room.

I can’t make Time Shift fail on 2.4.2 or the latest alpha test build I have for 3.0.0 on Bug Sur macOS 11.1

I can’t reproduce this behavior with 2.4.2 or alpha test 3.0.0



je suis sur MAC OS 11.1, Macbookpro 2019.
Je n’arrive pas à enregistrer ma carte son avec Audacity 2.4.2 comme je le faisait avant, en utilisant l’appli Sound Syphon (elle ne supporte pas encore cet OS).
Auriez-vous une alternative?
Soit en utilisant une autre application tierce ou une manière différente de procéder?
Je remercie d’avance toute personne susceptible de répondre à ma demande,

Admin - Google translation
I am on MAC OS 11.1, Macbookpro 2019.
I cannot record my sound card with Audacity 2.4.2 as I did before, using the Sound Siphon app (it does not yet support this OS).
Do you have an alternative?
Either using another third-party application or a different way of doing things?
I thank in advance any person likely to respond to my request,

So far, so good…except one problem: the playback indicator/bar used to move steadily across the screen regardless of how much I’d zoomed in. Now, when I zoom in, it “ticks” from point to point. This does not affect playback sound…but it means that I have less visual feedback of exactly where the playback is vis a vis the waveform.

Has anyone else noticed this? And is there due to be an upgrade specific to Big Sur soon?