Audacity Not Recognising Mixer


I have connected my Pioneer DJM-750 mixer to my MacBook (OS Mojave) via USB.

The mixer driver is on the correct settings, and my laptop is recognising the input, see below.
Screenshot 2018-11-05 at 17.45.18.jpg
Screenshot 2018-11-05 at 17.41.07.jpg

However, Audacity just isn’t recognising the input, see below.
Screenshot 2018-11-05 at 17.43.07.jpg
I feel like I’ve tried everything, at this point I’m thinking it’s some stupid simple setting that I’ve missed somewhere.

Any thoughts what might be the issue?


Have you given Audacity permission to use recording devices? (see:

Hi Steve,

Yes I have, here’s a screenshot.

There was a very similar problem posted a while back. They were also using a USB device, Audacity 2.3.0 and Mojave. (You have not said, but I assume that you are using Audacity 2.3.0 - if not, you can update from:

The problem was eventually resolved, but unfortunately they were not sure which step fixed it. You can find the topic here:

Yes, I recently updated to 2.3.0.

Thanks, I’ll check it out.

I’ve read through this post a few times. However I’m struggling to find the “Audio Devices” panel. Where can I find this?

You mean as in this post: Can't record from USB interface after upgrade to Mojave - #19 by Reg_H

That’s in the macOS Sound settings.
If I recall correctly (I’m not currently on a Mac), you get to it via:
“Apple menu > System Preferences > Sound”

That’s what I thought, but my settings aren’t as extensive.

Hello Guys,

I bought a new MacBook Pro having Mojave and have the same issue with my pioneer DJMS9. Since there is no option to use the 3.5mm jack on MacBook to record with audacity I tried to use the DJMS9 directly for recording. Plugged with USB C, the MacBook recognizes the mixer and I can select my pioneer in the input window instead of the MacBook internal microphone. But I keep having the same issues: the sound preference window is saying „the selected device has no input control“ and audacity is giving the same error message „9997 Invalide sample rate“.

Any help is highly appreciated since I need to record a lot of music throughout my mixer to audacity.

Thank you :pray:t3: :slightly_smiling_face:

Hi im having the same issue with a DJM S11, did you manage to get a resolution to your issue?

Given that you’re reply to a very old post I doubt that they will reply.

I think the “right” answer is to use Serato DJ Pro as Serato and the DJM’s are designed to work together.