No signal from USB turntable (Mojave) [SOLVED]

Currently installed:
Audacity 2.3.0

Previously using:
Audacity version

laptop 1:
Version Mac OS Mojave
10.14 (18A391)
MacBook Pro (Retina, 13-inch, Mid 2014)
Processor: 2.6 GHz Intel Core i5
Memory: 8 GB 1600 MHz DDR3

laptop 2:
macOS Mojave
Version 10.14 (18A391)
MacBook Pro (13-inch, Mid 2012)
Processor: 2.5 GHz Intel Core i5
Memory: 8 GB 1600 MHz DDR3

Hi there. old forum member, although I haven’t needed to log in for ages, and as with so many of these things, I couldn’t locate my former user info, so now I’m a newbie once again.

The only thing I’ve ever used Audacity for is digitizing my record collection, as all of my audio processing is done with different software on a Windows system. My PC is in a studio that is tied up most of the time, however, so for the purposes of digitizing records, I’ve been using Audacity on a couple of older laptops - both MacBook Pros - one from 2012, and one from 2014, which allowed me to work from different locations in my house. The turntables I’ve been using are AT-120 USB, and I had been encoding at 24/48kHz.

After upgrading [?] both laptops to Mojave, I realized that Audacity was no longer recognizing the input signal from the USB turntables. A bit of research brought me up to speed with Audacity 2.3.0, but the end result was the same. System Preferences showed me that the laptop was receiving the signal, but it wasn’t getting through to Audacity. The results were the same for the mic input.

I’ve tried completely wiping all trace of Audacity from each laptop, and doing repeated fresh installs, each time changing one single setting: bitrate, sample rate, etc. Each time, the results were the same : input signal showing up in System Preferences, but not in Audacity.

I read about the likelihood of Mojave not playing well with Audacity, but I haven’t gotten any nag prompts complaining about Audacity being a 32-bit application.

Additionally, I can play a file in Audacity, and hear the signal through the built-in speakers / headphone jack. So, it’s not like Audacity is broken per se, but there seems to be some kind of secret handshake I don’t know, in order to get the input signal into Audacity.

Hopefully this makes sense the way I’ve explained it; I’m not completely dense, regarding audio or the basics of home computers, but I don’t generally mix the two, and this has me baffled only because everything had been working just fine until I upgraded the laptops.

Any helpful suggestions that I can understand would be greatly appreciated - thanks!!

I’m jealous! If I had input levels at all, that would be a better situation than what I’m currently dealing with!

I should add to my scenario that the behavior for the built-in mic on both laptops is the same as the USB line in; that is, the Sound Preferences on the laptops does register an incoming signal from the mic (as with the USB), but when I open Audacity, the options for any incoming signal - mic or USB - are non-functional, and all I get is a flat line for a signal.

I’ve split your posts from the other topic because it gets very confusing if multiple questions are asked in one topic.

I presume that you connected the turntable before launching Audacity? If not, try that first.

What settings do you have in the device toolbar?

Could you show a screenshot of that so that we can see what you mean.

Ah, sorry about that! I saw a few different posts which indicated that other folks were dealing with similar issues as mine, so I thought it was okay to join an existing thread rather than create a new one.

Yes; I learned with the previous version that Audacity would not “see” the USB turntable unless it was already connected, so that is always connected before I open Audacity.


Here’s a snap of an active window, while I am playing an LP on the turntable, and I’ve expanded the toolbar a bit to show what the settings are.
Screen Shot 2018-11-01 at 8.20.50 AM.png

Here’s a snap of System Preferences; which shows that the LP is registering a signal via USB.
Screen Shot 2018-11-01 at 8.14.23 AM.png

You may need to enable access to the USB device under Security & Privacy.

Are you able to record from the MacBook microphone?

Well, I’ll be! That did the trick, alright! At least for the 2012 MacBook Pro; I’ll get to the 2015 laptop in a bit, but having gotten this sorted, I can’t imagine the results would be any different.

This solution wouldn’t have been entirely intuitive to me, as I don’t recall having done that with the previous version of the Mac OS and Audacity, and looking at the tab (which I’ve attached below), it would only indicate access for the microphone. Evidently, the USB access seems to be controlled by that as well, which wouldn’t have occurred to me. At any rate, thanks for that!

I’m attaching a snap of what that looks like, in case that might be helpful to other folks experiencing this same issue.
Screen Shot 2018-11-01 at 9.05.56 AM.png

Per my second post in this thread, that was not working, same as the USB input.
However, since I tried your suggestion in the Security & Privacy tab of System Preferences, both the microphone and the USB are now registering a signal in Audacity. Thanks again! Hopefully, this will prove useful to others with the same issue.

It’s one of the new wonderful features of Mojave (and Windows 10).

Thanks, I’m sure it will be.

Let us know if it fixes your other Mac, then I’ll close this thread and mark it “Solved” so that the solution is easier to find.

I’ve had a chance to set up Audacity on the 2015 MacBook Pro with the same configuration, and it works fine, so I reckon we can consider this one solved!

Thanks again for the assistance with this!!