Can't record from USB interface after upgrade to Mojave

I’m really sorry for being on the steep part of the learning curve with this problem. Thanks in advance for your help and understanding.
I just uploaded to Mojave (Version 10.14) on my MacBook Pro (2.9 Ghz Intel core I5). It took about 30min and everything went smoothly. Then I Launched Audacity 2.2 which I had been using for over a year and a half without any problems. I was working great!
When I launched Audacity 2.2 (as usual), I recall there was an indication that it was not compatible with the current oS and that I needed to update to Audacity 2.3.
I then down loaded and installed the newer Audacity version 2.3.
Now when I try to lay down a track the fields that relate to my external USB interface selection go gray. Nothing is recorded.
However, If I use internal mic as a source, as a test I am able to get a signal recorded and the device field stay blue with “Built-in Microphone” Also if I go to device manager in Mac’s system preferences I’m able to select and see signal being delivered by the usb Interface. Aa always. so sound is being delivered to the MacBook.
I studied the post that I was able to find related to this. For example, I went to security & Privacy and verified that Audacity had access to the “microphone” box was checked. I have also gone through many Restarts in an effort the make this work.
Really frustrating and many hours lost.
Seriously, I would really appreciate direct experience/knowledge insights and viable corrective actions.
Thanks and Take Care

I have not updated to Mojave because Macs have been peeling off support for 32-bit applications and I still run some very desirable 32-bit applications. Audacity is a 32 bit app. I stopped at High Sierra. That seems to work OK.

There have been postings from people with Mojave trouble.


I have the same problem. Upgrade to Mojave broke Audacity 2.3.0. Though Settings > Sound > Input shoes the computer is receiving sound (Input Level shows fluctuating sound bars as album is played on USB Codec 2 turntable), Audacity detects nothing. This after restarting Audacity with Phono plugged in and turned on, and checking all other “Audacity not recording” recommendations. Seems like 2.3.0 needs a fix.

Seems like 2.3.0 needs a fix.

I don’t think this is a “fix” problem.

3.0.0 will be the first 64 bit version?


2.3.1 is planned to be the first 64-bit version for macOS.
2.3.1 will still be 32-bit for Windows.
On Linux, Audacity may be built as 32-bit or 64-bit, depending on the machine that it is built on.

Hi Again,
In my wandering to find a solution. It does seem (depending on the hardware in you Mac) that Mojave runs at 64bits. In my quest for a solution I found someone said that if you power up the Mac while at the same time holding down the 3 and 2 keys (directly on you laptop, not Bluetooth keyboard) it will run in 32bit. Similarly if you do the same thing with the 6 and 4 key pressed down it will run in 64bit. Powering up with nothing pressed… it will wake up in 64bit mode. I tried it and I did not work for me. I could have done something wrong. Perhaps this could be a clue for one of you smart guys. Good luck.

Mojave is a fully 64-bit operating system. As far as I’m aware there is no “32-bit mode”, but Mojave CAN run 32-bit applications.

See this post: No signal from USB turntable (Mojave) [SOLVED] - #6 by SonArc

So now I’m confused… are you saying that 1) When I installed Mojave and then received an automated notification that Audacity needed to be updated that was not correct? and 2) When after I installed the new Audacity update and encountered that USB interface was not working (Initial post) the problem was not related to the new Apple OS Mojave running in 64-bit mode?
If so, then I am back to square one. By the way because of this saga, I purchased Logic Pro X and the USB interface works fine. Too bad in a way, because I really honestly prefer Audacity. Hopefully I can get this resolved and set Logic Pro aside and revert back to Audacity.

Apple are implying that Audacity needs to be updated, but that is not strictly true (alternative fact :confused: ).
Apple are wanting to abandon support for 32-bit software, but there’s still a lot of 32-bit software in use, so they are putting up a big scary message any time you run 32-bit software, saying that the app needs to be updated “to improve compatibility”.

Despite the warning, Mojave still supports 32-bit apps, but it is the last version of macOS that will. Apple have said that they are abandoning 32-bit software after Mojave.

All versions of Audacity for Mac to date, are 32-bit. The next version of Audacity (2.3.1) is planned to be released as a 64-bit application for Mac.

It’s probably nothing to do with 64-bit / 32-bit.

It’s more likely to due to the new “security features” in Mojave. By default, Mojave disables access to all recording devices for all software except for Apple software. For non-Apple software, you have to manually set the privacy settings for the “microphone” to allow the application to access the recording device. That’s what this post is about: No signal from USB turntable (Mojave) [SOLVED] - #6 by SonArc

OSX updates are the worst for anything audio. I have a friend who is still on leopard because he can’t use anything past that with his MOTU interface.

Have you got time machine installed? can you roll back to a previous OSX?

Yes as I said earlier Audacity does have access to the Microphone. I Click on it to see if it maps the the app and it does.
As you can see that LogicPro also has access and works.
Screen Shot 2018-11-02 at 8.52.58 AM.png

Please also post a screenshot of you “Sound” settings.

Yes I have time machine installed. I would prefer not to revert back because other apps will likely be problematic.

Again here is the behavior. I can play music out of audacity through the USB interface. When I “Rescan for Audio Devices” the device fields turn darker and the up/down arrows turn blue. But… when I hit play (or record) the device fields turn light gray and the uptown arrows turn to black and white. As you can see by the attached pictures.

I wish my technical skills were much better sorry, or that I found the problem on my part and was confessing the solution.

Given the flow of discussions and recommendations and that Logic Pro works fine it’s my belief that the current version of Audacity 2.3.0 has some sort of bug. By the way, I even tried reinstalling 2.3 and also reverting back to without any success. and the USB Interface is plugged I directly as always.
Screen Shot 2018-11-02 at 9.52.11 AM.png
Screen Shot 2018-11-02 at 9.51.51 AM.png

here are the sound setting that you requested Group 1
Screen Shot 2018-11-02 at 10.13.46 AM.png
Screen Shot 2018-11-02 at 10.13.20 AM.png
Screen Shot 2018-11-02 at 10.13.06 AM.png
Screen Shot 2018-11-02 at 10.12.47 AM.png

Group 2 sound settings you requested
Screen Shot 2018-11-02 at 10.16.22 AM.png
Screen Shot 2018-11-02 at 10.15.54 AM.png
Screen Shot 2018-11-02 at 10.14.00 AM.png
Screen Shot 2018-11-02 at 10.13.46 AM.png

Hey Steve,
Lastly please keep in mind that if I set the device to Internal Mic and Speaker it plays with out turning gray.
Screen Shot 2018-11-02 at 11.47.42 AM.png
So to me Mojave is granting access to Audacity.
Screen Shot 2018-11-02 at 11.47.42 AM.png

In Audacity “Preferences > Quality”, set the default sample format to “32-bit float”.

In “Group 2 sound settings”
“Audio Devices > UMC404HD 192k > Output” set Source: Default / Format: to “2 ch 16-bit 44.1 kHz” (if available).
Please say which options are available here as there may be a better combination, but Audacity only supports 2 channel playback.

Audacity → “Audio Device Info” has a “Save” button at the bottom. Please save the info and attach the saved text file to your reply.

Could you also post the “Input” part of this:

Good Morning Steve

Thanks for the requests.

  1. In Preferences I set the Quality to 32-bit float. Picture attached. Note that there is a also Settings for Real-Time Conversion and High Quality Conversion

  2. In Audio Devices>UMC404HD>Output
    2-Ch was not available. Every option is 4 channel.
    Format relates only to speed select options 44,100 48,000, 88,200 96,000 176,400 192,000 Hz.
    Input bit depth is fixed at 24-bit Integer regardless of what output is set too. Picture attached
    It is set to 44,000 Hz and other is fixed on 4-ch 24-bit integer

  3. In Audio Devices>UMC404HD>Input
    Always 4 channel
    Format options are integer 16 or 24 bits
    Which can be selected with the rates shown in #2
    I set output to 4ch 16-bit integer 44.1kHz

Audio device info attached

I made the 32 bit float change and changed input to 16 bit and tested there was not change Bummer.
deviceinfo.txt (2.24 KB)
Screen Shot 2018-11-03 at 1.13.57 AM.png
Screen Shot 2018-11-03 at 1.50.27 AM.png
Screen Shot 2018-11-03 at 1.40.40 AM.png

Here are two shots of the audio devise input screens the previous not showed the device output screens
Screen Shot 2018-11-03 at 2.03.18 AM.png
Screen Shot 2018-11-03 at 2.03.50 AM.png

According to this (from deviceinfo.txt), Audacity and the UMC404HD are configured correctly and working.

Selected recording device: 3 - UMC404HD 192k
Selected playback device: 3 - UMC404HD 192k
Supported Rates:

What are you using as a sound input for the UMC404HD?

Is the UMC404HD showing an input signal is present? (the green LED associated with the input level should flash on when there is sound, and off when there is silence).

What happens if you now try to record?