Audacity 3.0.0 on Windows 10 struggling


I’ve been using Audacity for several years on the computer (windows 10) I"m using now, and had great success.

I upgraded to the new Audacity 3.0.0 a few days ago . . . and now, well, trouble.

Recording is fine, good news.

But editing? Well, Audacity spends more time “not responding” than is reasonable. OK, before the upgrade, sometimes I had to wait a minute or two for a longish process to run. But now? Well . . . everything might start fine. Cut a few seconds of audio, copy/past a few seconds of audio, save a file - might go quickly for awhile. And then, something happens, and these simple requests take many minutes. Yesterday I was having some luck with restarting (the entire computer) each time this sluggish behavior started. Maybe once every 30 minutes I would restart. But today, it seems worse. I’ve started reading a book to distract myself while I try to let audacity do whatever I’ve asked it to do. And twice now it’s been “not responding” so long that I’m not sure it’s ever coming back.

I know there were significant changes in Audacity 3.0.0. I’m wondering if it is not using memory efficiently . . . maybe not cleaning up after itself . . . I don’t know. I saw a reddit post and another post on this forum that let me know I am not the only windows 10 user having trouble.

So, can anyone tell me, are the Audacity coders aware of and working this apparent Windows 10 trouble? Or . . . maybe I should revert to an earlier version? I appreciate your advice.


I did a lot of QA speed testing on both. W10 and macOS 11.2.3 Big Sur to ensure that we weren’t suffering performance degradation with 3.0.0 versus 2.4.2

The only thing that we know can be slower is closing projects and exiting Audacity - as the new project database structure does its clean-up compaction then to get rid of unused temporary workspace - many of the effects run a little faster.

I was even using the alpha and Release Candidates as my production setup for the past four months or so and I regualrly work on 2-3 hour projects and I noticed no slowing down versus 2.4.2


I’ve recently been testing with very large projects (5+ hours) and found there can be very slow clean-up / compaction when undoing big operations (such as undoing an effect that has been applied to many hours of audio). I’m finding it quite annoying, though it’s unlikely to occur very often during normal work (I’m just seeing it a lot due to the type of testing that I’m currently doing).

I experienced the same issues. At first 3.0 worked well and I was pleased. Over the weekend, the slow down began. I do audio-only work and to remove .1 second of breath noise takes over a minute. When the program was first installed I had no issues with this. Any suggestions? I have tried uninstalling and reinstalling, but that does not help.

At this point, I would like to revert back to 2.4.x and wait 6 months or so

Not off the top of my head.
Do you have any idea what may be different now compared with when you first installed?

One possibility is that it may not be directly due to Audacity. On Windows I sometimes find that things run very slowly because of Windows checking for, or applying updates. Running Windows update manually and rebooting the computer generally sorts that out.

NO, nothing has changed. When it first happened, I shut the laptop down, ran a root virus scan, then use CCleaner, including the option for registry cleaning. I run the program 3 times. My windows updates are not automatic. I get a notification. As I said, it worked fine, no issues. Now, making edits on spoken audio is running through molasses.

Jeepers, I’m glad I’m not the only one to notice this. I asked the same question in the Audacity Users Group on FB and no bites. Yups, Start recording, works great. about the 3-5 minute mark, edits a re molasses slow. still testing to see if there is a file size or recording length that gives a clue.

Are you using Audacity 3.0.0 or 3.0.2?
Were your projects first created in 3.0.0?