Audacity 2.3.X will not record input on Catalina

I use audacity to record internet radio streams from sources that are not commercial/no copyright infringement issues.

before I updated my mac to Catalina public betas, i was able to use Audacity (2.3.0, .1, .2) + soundflower to funnel audio to be recorded.

at the moment, with Audacity 2.3.0, 2.3.1 or 2.3.2 and Catalina public beta, I cannot record.

I’ve checked my privacy settings, nothing to select or change there. I’ve also tried using Source-Nexus as the input, did not work.

I lastly tried using Wavepad + soundflower and that DOES work. Garageband + soundflower also DOES work.

I have a feeling that something in Catalina has changed since Mojave - and Audacity may need to be updated for that.

anyone else notice this ?

Soundflower is no longer supported. Try IshowU Audio Capture.


so neither Soundflower nor Source-Nexus extensions are supported as inputs for Audacity ?

I will try one more thing - use wavepad with Source-Nexus as the input to see if that records.

I am using wavepad as an alternative but prefer to stick with audacity.

i’ve tried using the Sound-Nexus extension as the input source for Audacity - does not work.

with Wavepad - both Sound-Nexus and Soundflower extensions work as audio inputs.

Not quite sure if my issue is due to my configuration or other. I have had this problem only recently, with up to the last 3 releases of Audacity and while on the Catalina beta.
In the past (Mojave and earlier), was able to use Audacity + soundflower just fine. Anything else I can try (like looking for leftover files from previous installs to remove before reinstalling again) ?

neither Soundflower nor Source-Nexus extensions are supported as inputs for Audacity ?

I can’t comment on Source-Nexus, but I was a SoundFlower fan and had to give up because it was starting to get unstable and unpredictable.

last 3 releases of Audacity and while on the Catalina beta.

Was there a reason to be using a Beta Operating System?


i’ve not had any issues yet with either extension.

since they both work with other audio software in catalina … I’ll check to see if a future audacity update will resolve this.

in the meantime, wavepad is straightforward enough for my needs.

i suppose this would be a good thing to bring to the attention of the developers. if 10.15 officially releases next month and this issue remains, i’m sure there may be some interest in fixing it.

I can make this worse. I can’t find anywhere that says iSeeU is 64-bit and is expected to run under Catalina. I can find mention that it’s not and it doesn’t.


I have the same problem cannot even record from the mic. must be an access problem that needs to be sorted by audacity

See this Forum announcement Audacity under macOS 10.15 Catalina

And many thanks to noraa for posting that workaround


this worked for me, thank you …

[additional] - must always launch audacity from a terminal window using the open command … closing terminal also closes audacity.

hopefully 2.3.4 will fix this …

I have not been able to get audio capture to work using iShowU Audio Capture. I was able to get Audacity working under Catalina, but not audio capture. I downloaded the latest iShowU Audio Capture (which mentions Catalina), but so far no joy.

Have others had this same experience. Can anyone verify successful capture using iShowU Audio Capture and Audacity under Catalina?

See this Forum announcement:


I don’t understand why you are referring me to that forum announcement. I had already found that and used it to get Audacity working under Catalina, which I thought was clear from my post. This thread is all about audio capture under Catalina.

Am I missing something?

Because Catalina (and other macOS’s) regard a connected USB device as a “microphone” so the fix for non -recording with a USB device like that is the same as the fix for mic recording.

Can you make a recording with your microphone or onboard mic?

If so then you have a different problem and we will need more detail.


OK, I got it working. For others who might end up here, the following clarifications and additions to the forum post might be handy:

First, although it does say this in the forum post, it isn’t completely clear that even after the permissions are set up, you ALWAYS have to start Audacity from the Terminal if you want to record, even with the permissions set up from the first time you record. This is a bummer, but it’s OK for a temporary workaround until 2.3.4.

Second, you won’t be asked for access to the microphone until you actually try to start recording, the forum post isn’t super clear about that.

Finally, the reference to the issue in Mojave (if you follow the link) is actually a bit of a red herring, because it tends to imply that if the microphone is enabled for Audacity in system preferences, then the permissions issue is resolved. This is NOT the case.

The good news is that this indeed was the issue with iShowU Audio Capture. It works fine under Catalina once everything else is set up.

@jandyman - thanks for the feedback, I’ll have a look and think about updating that announcement :slight_smile: :sunglasses:


OK jandyman - does this re-work look better to you?