Problems recording samples from Spotify on macOS [SOLVED]

  • Audacity 2.2.1
  • macOS 10.14.1 Mojave
  • Scarlett 2i2 Audio Interface
  • Spotify

Hello, I am trying to experiment with grabbing samples from Spotify using Audacity. For my recording device I have the choice of: “Built in Line Input”, “Built in Digital Input” and “Scarlett 2i2 USB”. None of these options appears to produce any recorded sound. What am I doing wrong?

I found a free and workable solution with SoundFlower at Apparently it’s an old Cycling '74 product so it’s got a good heritage! To use it I had to fire up Utilities/Audio MIDI Setup, select the new Soundflower (2ch) entry, then hit the gear wheel options button below, and select Use This Device for Sound Output to redirect Spotify to Soundflower. Then when using Audacity, I was able to select SoundFlower (2ch) as my recording device, and all was well!

The only problem is that I haven’t sussed out how to actually hear the audio as I record it, so I’m having to rely on timings at the moment., but that’s okay!

That is extremely old / obsolete, and in my experience it’s not very stable on modern Macs.
There’s a much newer version called “iShowU Audio Capture”
(Note this is not our product and we don’t provide technical support for other people’s software, but here’s the link:

Okay, cool! I’ll check it out. Thanks, Steve!

iShowU seems to work fine, although I still cannot figure out how to monitor the sound as I record. Any ideas, anyone?

I’ve checked the page at and have set up the Multi-Output Device as described. I then selected the “iShowU Audio Capture” as the recording device and the “Multi-Output Device” as the playback device.

Maybe I’m doing something wrong because although Audacity is capturing the audio from Spotify, as I mentioned before, I’m not hearing anything while the recording is taking place.

It’s not a massive problem because after I export the audio from Audacity, I’m hacking it to bits in Ableton, but it seems a little strange that it is not allowing me to minitor in real-time.

I’ve sorted the problem. I’d forgotten to select the “Multi-Output Device” in “System Preferences” → “Sound” as my selected device for sound output.

This is really cool because it looks like I can leave my audio settings set up like this on a continual basis, and not have to faff around changing devices according to what stage in the process I am at.

Conclusive proof, if any were needed, that macOS is a dream OS for anyone doing audio stuff!

Thanks for the update. I’ll close this topic now as it provides a confirmed solution. To summarize:

The problem:

Mac computers have no built-in ability to record sounds that are playing on the computer.

The solution:

Install “iShowU Audio Capture” from and configure as described in the Audacity wiki here: