Another problem with the new export

Dear specialists, hello! I found one more problem with the new export. It persistently set sample rate 44100 hz rather than I write 48000 hz. I have to rewrite it each time! Please make the export remember the last rate value. Thank you!

Testing on W11 wuth Audacity 3.4.2

It seems tha Audacity remebers and reuses the last-used setting while the app remains open.

BUT after closing and relaunching Audacity, indeed it does rever to a rate setting of 44100

However it looks to me as though the rate you get offered may actually depend on the sample rate of the track that is being exported - I don’t know wahat happens if you have a project that has tracks at different sample rates (and i don’t have time right now to experiment).

Since you want your exported rates to be 48000 why not set your projrct rate and default project rate to 48000 (Audio Setup button or Audio Settings preferences). That way recordings that you make (on new tracks) will be 48000. But note that you may be importing other audio files with different rates into your project.


Hi! I tried to set project rate 48000 hz - it doesn’t help, export dislays 44100 anyway. But in an “old” export there was no such problem. Please, modify so that I could “fasten”, “consolidate” this 48000 in export settings.

What rate are the tracks in your projects in?

It depends on file, I downloaded. Almost all are 44100 hz, but there’re some files with 48000 hz. In the latest version there’s no bar “Project rate”, I often even don’t know. But I want the resulting mp3 to have 48000 hz. Earlier threre was no such problem, my settings were remembered and not returned to defaults.

It will default to match the file you opened. If you import more than one file into a project, I believe it will default to match the first.

If you record, it should default to your preferences.

MP3 might be different if you import a high-resolution file because MP3 doesn’t support higher than 48kHz.

Why do I need “default” or “match the file I opened”? I need a specific value, no matter what rate an opened file has. In practice it may be 32000, 22500, 11025 or less.

To rewrite a value each time - you agree, it’s not normal.

Why do I need “default” or “match the file I opened”?

You know what you’re doing, but the typical user does not. The samplerate is set to something that’s appropriate to the project once (in the case of a single track consisting of 44.1k it’s just that), and for subsequent exports of the same project it remembers what you chose. It doesn’t however remember the last choice you made across different projects.

It look I have to retutn to audacity version 3.3.3. Nightmare! It doesn’t allow me to chose settings properly, changes to it’s own.

No way I can undestand. I set project rate 48000 hz. Why does the export still suggest me 44100?


So, what’s the meaning of setting project rate? Can it be fixed? In the sense: I set project rate as 48000 - the export also suggests me to save with 48000?

Before 3.4, project rate would be automatically set for the first imported file and then used for both playback, recording and export. Since 3.4, you can change the sample rate used for exporting independently of recording and playback rate. In the case of Opus, the bandwidth even is independent of the samplerate.

Anyway, now it’s extremely uncomfortable to export mp3 with 48000 hz. It’s just easy to forget to rewrite the value in the field, after export I don’t remember whether I set 48000 hz or forgot. And earlier there were no difficulties. Can it be fixed? For example to add in Edit - Preferences - Import/export a new paragraph: default export sample rate (something like this).

And earlier there was no difficulties.

In previous versions of Audacity, you’d need to change the project rate in the bottom left corner of the app after importing before exporting, and in 3.3.3, you’d need to go to Audio Setup → Audio Settings to change the sample rate before exporting. Did you do that? If not, you’ll have exported in previous versions with an unwanted sample rate as well.

Can it be fixed? For example to add in Edit - Preferences - Import/export a new paragraph: default export sample rate (something like this).

This is not something I want to add to the preferences. It may be a use case for export presets though.

If all you want to do is convert sample rates, using ffmpeg directly is probably worthwhile. The following command:

$ ffmpeg -i input.mp3 -ar 48000 output.mp3

converts the input file to use a 48000 Hz sample rate.

The other use case that this would address is those folks that desperately wanted an Export as MP3. See the second suggestion in this outstanding enhancement request:


Certainly, I did it. But…I had an opportunity to add the link to Macros. There were no problems.


Now…it’s useless, “Export” has by default 44100 anyway.

I guess, it won’t suit. I propose, that if you change project rate to 48000 hz, default export rate would also be 48000 (so that they would match). Now 44100 is rigidly fixed, I have no idea why. More precisely, it sets the same value, as an imported file, and it can only be changed manually. I consider it’s not right. For example, what if an imported file has the rate 32000 or less? You’re gonna have to change manually

Imagine, you imported such file. You can easily when exporting not pay attention to the value or just forget to change. And the resulting file will have sapmle rate…22050 hz. And you won’t even know about it!

There is kind of an argument for the initially offered rate for the export in the Export Audio dialog should be the Project Rate that is current at the time.

The basis for this argument is that if the user is working on his/her project at a particular rate then it might seem reasonable to offer that same rate as the starter rate for any exports - it certainly shouldn’t always be 44,100.


That’s what I’m saying. But I’d prefer to have an opportunity to set the specific value. Then there’s no need even to change project rate.