-9999 Unanticipated host error [SOLVED]

About two years ago in a USED BOOKSTORE I purchased, NEW, an AUDIOLOGY USB Turntable, MODEL #: AU-RPUSB-550WD (I never unpacked it until this week ~ AUDACITY Software Version 1.2.6).
I kinda figured the software would be old, Hahahaha, as it would be right at home with my ol’ LP’s. Ha ha ha. Anyways …
I carefully read the audiology Manual supplied with the Turntable to properly familiarize and prepare myself and then procedurally prepared the Turntable and then Installed (without Compatibility Operating System (OS) adjustment(s) to an earlier OS version, like: WINDOWS XP, of WINDOWS) the audiology supplied AUDACITY 1.2.6 versioned software in a stock HEWLETT-PACKARD PAVILION 590-p0xxx in the WINDOWS 10 (update build versioned 10.0.19043 (KB5007289 (2021-11 Cumulative Update Preview for .NET Framework 3.5 and 4.8 Windows 10 Version 21H1 for x64 (Updated 04DEC2021 (1754hrs CTZ (USA))))) Environment. … had to see what it was going to do in a virgin AUDACITY state. It Installed and, without Launching the New Installation I Closed the “audacity.exe (Setup Executable)”, I Logged out of my Win10 User (Administrator) Account and Restarted the computer after the install without launching the installed. After Restart and Log In and about 8 minutes (allowing all the Win10 environment to complete a start-up) I opened the AUDACITY 1.2.6 program and procedurally performed the audiology manual’s Software Configuration. I proceeded to Record a 45 RPM Peter Frampton 1:35 song for a test. It failed with, and Noticed me to, an “unrecognized host” error … that was essentially the entire message unrecognized host ~ no code of error.
Now I keep my machine fairly-well locked up and away from most MICROSOFT (and other environment programs) undesired action(s) … so I checked a few things that I felt were associated with the failure to communicate … I found nothing … I came to Audacity’s web site and poked around did some study research (I Read) of materials and concluded it may just be ancient software issue plus I picked up a few pointers from Audacity. I downloaded the latest Software Version ~ x64 (as the supplied was an System x86 on the audiology Installation CD).
After closing out all open programs and disconnecting from the Internet I uninstalled the 1.2.6 Install from the WINDOWS Control Panel - Programs and Features Application Window. When completed I processed another Restart as mentioned earlier. I opened the “audacity-win-3.1.2-64bit” Install File and performed an Removing Preferences Installation getting rid of any residual(s) of possible carry-overs (thus, hopefully eliminating any previous audacity preferences remaining after the 1.2.6 Install and uninstall - hopefully). I followed the same procedure as before in Software Configuration and paying attention to Audacity Setup and Configuration

    "timestamp": 1638660489,
    "event_id": "d278cef493dbfc409aa1245de9bd9428",
    "platform": "native",
    "release": "audacity@3.1.2",
    "contexts": {
        "os": {
            "type": "os",
            "name": "Windows",
            "version": "10.0.19043"
    "exception": {
                "type": "Error",
                "value": "Error opening recording device.\nError code: -9999 Unanticipated host error.",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false

An Record yielded the above.
Okay, so, I don’t do very well with MICROSOFT’s idea of using pictures with no words as an interface for computing so my Win10 Environment is like WINDOWS XP (with a Start Menu And a Task Bar).
Right-mouse click the Volume in the System Tray and “Select” Open Sound settings. “Scroll” down to the near bottom to the “Related Settings” Section and “Select” Microphone privacy settings. Double-check the “Allow access to the microphone on this device” Section for: Microphone access for this device is on, if it is “off” then “Select” the Change box-button and in the pop-up window that appears “Click the toggle button” to “Activate” to be “on”. Next, “Scroll” to the next Section “Allow apps to access your microphone” and Double-check to ensure it is “on”, if “off” then “Click the toggle button” to “Activate” to be “on”. Now “Scroll” past down all the entries in “Choose which Microsoft Store apps can access your microphone” to the Section of “Allow desktop apps to access your microphone” and Double-check to ensure it is “on”, if “off” “Click the toggle button” to “Activate” to be “on” (this usually trips to match the previous “Section: “Allow apps to access your microphone”” when it was/is activated) and then right below it in the listings ought be the “Audacity Cross-Platform Sound Editor”.
That’s the cure that allowed my Audacity to function.
I created tonight an unnarrated screen video (ScreenRec *.mp4) of my cure. A YouTube viewing Here (uploaded 08DEC2021).

Hope this helps out with an issue of occurrence of “-9999 Unanticipated host error”.
Respectfully, ZARDOZ

Thanks for posting the detailed solution.
I see that you have uploaded the video to YouTube, so I’ll give some prominence to that link: https://youtu.be/lU6D_Jhy_3w
I also posted a trimmed version of the video here: https://youtu.be/TSPjNCdVhmA

There’s a short version of the same solution in the FAQ in the manual: https://manual.audacityteam.org/man/faq_recording_troubleshooting.html#vista_7

Topic closed as “solved”.