Error opening recording device

I keep getting an error when trying to record with my stand mic. I keep getting an error -9999 for some reason. The mic is plugged in and it’s not happening with any other recording device I have, just my stand mic. I’m running Audacity 3.1.2 on a Windows 10 machine. I have absolutely no idea what’s going on, as I’ve tried going through the FaQ and it has not been able to resolve the issue.


“timestamp”: 1638830715,
“event_id”: “847b486cb762b242b8c8469b085c9d59”,
“platform”: “native”,
“release”: “audacity@3.1.2”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19043”
“exception”: {
“values”: [
“type”: “Error”,
“value”: “Error opening recording device.\nError code: -9999 Unanticipated host error.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

Hi Shadowblitz0001,
Did you check this -9999 Unanticipated host error, A Resolve in this Windows Arena Section of the Audacity Forum? If you did already and that was no cure another exploration can be visited providing you disclose what you have accomplished to alleviate the issue. A solution may be found else where in the Win10 environment or a possible exploration of the Audacity program itself. Help the Forum to help you. Thanks Shadowblitz0001.
Respectfully, ZARDOZ

Hi there,

I am a new user to Audacity and Windows 11 and I want to use my setup for multi-track music recording, using guitars, bass, keyboard and Theremin etc…
I kept getting error code 9999 - ‘unanticipated host error’ - meaning ’ Error opening Recording device.
I had the overdub settiing turned on, to enable me to listen to previous tracks.
I had tried most of the other fixes suggested by other users and admin, such as disabling anti-virus programs, checking microphone access settings etc, but to no avail.
What seems to have fixed the error for me was to reset the audio quality, firstly in Windows - Sound - Properties for the line input and output settings both to 16 bit 48000Hz, and also in Audacity - EDIT - Preferences - Quality.

So for me, Leaving everything set to the default (44100 Hz) was causing the error code 9999.

Incidentally, I am using a Behringer UCA222 audio interface and the Windows default CODEC AUDIO driver was causing bad audio issues - I managed to download an old Behringer driver - ’’ dated 30/10/2009 and this seems to work quite well.

Thank you for sharing. :smiley:

A Transport > Rescan Audio Devices sometimes can also correct this issue, along with what you said - microphone permissions. Note that when you are using Overdub, it is important that both your input and output rates agree with each other and with the Audacity project rate in the lower left-hand corner.

And this is another solution that corrects a different issue… Was the bad audio also being recorded or did you just hear it during playback ?

The bad audio I experienced with the default CODEC AUDIO driver was extremely low level and distorted sounds on recording.

Thanks again for sharing. :smiley: