Cannot Record

Windows 10.
Audacity 3.1.2
I hit the Record button and get an error message.
I tried uninstalling and downloading 3.1.1, then 3.1.0 and I still get this error message.
What do I do?

“timestamp”: 1638560293,
“event_id”: “aae12f6a13e53643afd5193faf35bd36”,
“platform”: “native”,
“release”: “audacity@3.1.0”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19042”
“exception”: {
“values”: [
“type”: “Error”,
“value”: “Error opening recording device.\nError code: -9999 Unanticipated host error.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

What are you trying to record from? The microphone built-into your laptop? Something else?

hello ,

i am trying normal voice record through laptop mic but it showing error for recording and for mp3 file as well i am using windows 10 can you help me to get rid this issue asap

thanks gajendra

Hi godfella007,
I am new here to the Forum (I suffered the same error code and got it remedied in my WINDOWS 10 (v. 10.0.19043) earlier this day … About two years ago in a USED BOOKSTORE I Purchased, NEW, an AUDIOLOGY USB Turntable, MODEL #: AU-RPUSB-550WD, with AUDACITY Software Version 1.2.6 (I never unpacked it until this week) and I got the latest AUDACITY Software 3.1.2 today and installed it …. I’m working on writing out the process I used to cure the error in the WINDOWS 10 environment using a stock HEWLETT-PACKARD Tower computer. I expect to have the POST ready within the next 12 hours ~ if not sooner, I’m kinda a stickler for details and plus I get to document the process still fresh in my brain before I forget it. Keep the eyes peeled … Soon
Respectfully, ZARDOZ

Thanks. I’m looking forward to your answer!

I believe ZARDOZ posted his solution here: