[WINDOWS 10] Pressing any key on keyboard causes audacity to stop working

I’m running audacity version 3.0.0 on Windows 10, and as the title states, using any key causes audacity to crash. It started yesterday where pressing spacebar would occasionally freeze audacity, then led to spacebar always doing it, and now it happens when I press any key.

When it ‘freezes’, the app is still running and slightly responsive but I can’t actually interact with it, aside from scrolling up and down. I cant click anywhere on the timeline, I can’t use any of the buttons in the toolbar, etc. All I can do is scroll up and down, and I also can’t close it (I’ve used task manager)

So far I’ve tried uninstalling and reinstalling and double checking preferences to make sure the keybinds are correct, both of which didn’t work. Any help greatly appreciated! :smiley:

Update: I’d like to add that using my keyboard to type numbers in for effect values crashes it too.
To be more specific, I was trying to change a number in a delay effect and when I pressed “5” on my keyboard, audacity crashed.

I’d also like to add that it is not specific to this project, and happens in any audacity project.

Try this:

  1. Reboot the computer

  2. Locate the hidden folder
    (where “” is your username)
    and rename it so something like:

Now try running Audacity. You should see the “Welcome” screen when Audacity starts.

Hello. I would like to report that I am having this exact same problem. Also, the above solution did not work. Neither did reinstalling the program.

Between the period when Audacity was working normally and when this started, I did not install any new programs or change any settings anywhere. The only thing I can think of that might be the culprit is a Windows update, which I think happened sometime around Thursday or Friday.

Very curiously, after some time trying to get it to work, it somehow did again…until I turned off my computer. Now I’m back to repeatedly reloading it and hoping the magic happens again.

I’m actually quite desperate to get Audacity to work again, for my job. If you have a recommendation for an old version to try, please let me know.

Thank you.

Just did this and it’s unfortunately still happening ^^’

I apologize for the double-post.

I just fixed the problem by rolling back the last Windows update, per the instructions here:

For the record, I’m in Japan (and am using a Japanese version of Windows). The update which I rolled back apparently occurred on March 17th.

After doing this, I’ve reloaded Audacity multiple times looking at multiple projects, and it’s worked every time.

No problem :wink:

Thank you for the update - that is very useful.

Just tried uninstalling the most recent updates and it still seems to be happening :confused:
Opening projects works fine up until the moment I press anything on my keyboard…

Also since you mentioned you’re using Japanese windows, that may actually be relevant, as I have my system locale set to Japan …
I’ll try changing it to US English and update with any results :stuck_out_tongue:

UPDATE: Solved it!

While changing my locale wasn’t the issue, but it was loosely related ^^’

Turns out the issue was my keyboard input language- I was using the Microsoft Japanese IME set to romaji instead of the default English keyboard, which seemed to be causing the crashes. Maybe an issue with how Audacity treats inputs from other languages?

Thanks for reporting back pikap - glad you got it sorted :slight_smile:


In case it’s meaningful to anyone, I’d just like to add that changing the input language on my system, which has had the last Windows update rolled back as I described, does not seem to affect anything. Audacity is working regardless. I’m using Windows 10 Pro.

Glad you found a solution, pikap. :slight_smile:

It seems to be a combination of factors:

  1. Languages that use ‘Unicode surrogate pairs’ (characters with more than 2 bytes).
  2. A recent Windows update.

In my case, reverting the Japanese IME settings to an older version solved the problem.

Sorry to bring this back from the dead, but I wanted to post a small update in case anyone had the same problem as me again.

Windows just did a major update, which I let my laptop install. The problem discussed here came back.

I went into Microsoft IME settings and found a switch for something like “use previous version” (it’s in Japanese, so I’m translating). This fixed the issue.

That’s all!

Hi! I’m so excited!! I think I found a solution!

I’m using Windows 10 in Chinese Traditional, ever since I started using Udacity, it freezes 9 out of 10 times when I use my keyboard for any instruction, such as copy paste, ctrl + Z, ctrl + S etc…I tried reinstalling and it doesn’t work.

After I read someone’s reply about him being in Japan, I thought maybe it has to do with my language setting.

So I did the following:

  1. I went into Window’s language setting (not keyboard setting), add ENGLISH to the option. However, note that I was always able to use English on my keyboard before this action.

  2. Now on my Windows desktop page, bottom right corner, it displays ENG.

  3. Restart the PC.

  4. Double check that it still displays ENG.

  5. Start the audacity file, as long as it keeps displaying ENG, I can use my keyboard for any actions. BUT, as soon as I switch to Chinese Traditional, AND using English under Chinese, audacity freezes again.

I hope this helps :slight_smile:

I totally agree with this point. When I was using the Vietnamese of Microsoft, Audacity was crashed. And when I have used another program to typing Vietnamese, and using Microsoft English, this problem was solve.

Microsoft have been having problems (bugs) with some of their IMEs (example: https://support.microsoft.com/en-us/topic/you-might-have-issues-on-windows-10-version-20h2-and-windows-10-version-2004-when-using-some-microsoft-imes-63696506-47d2-9997-0b72-41a68e328692) which affects some applications (including Audacity).

The recommendation is to update Windows, and if that doesn’t work, roll back to use a previous version of Microsoft IME that worked and update again later. I think they may have finally resolved these issues, in which case fully updating Windows should fix the problem.

Had the same problem with Win10 JP IME.

Simple workaround for now is remember to swap from the IME back to “US Keyboard” when using the program.
For most folk Win+Space should suffice to swap.
Note you may have to separately install this “US Keyboard” depending on your version of Windows.

This worked for me for a while, now it started happening again more frequentliy than ever…

Thank you for sharing the solution :+1: