Windows 10 error opening or Internal PortAudio error[SOLVED]

Thanks. I suppose it could even be a bug caused by the WDM-KS support. Does Audacity 2.1.1 which does not support WDM-KS require stereo mix to be enabled before any MME, DirectSound or WASAPI input will record?

Addressing everyone here, generic Realtek drivers not matched to the motherboard would be a last resort. “In theory” they should be less likely to work than the Microsoft audio drivers for the device that come with the version of Windows.


And the answer to it is the same.

Audacity does not officially support Windows 10 yet.

The first step is to go to the web site of the computer manufacturer or motherboard manufacturer and see if you can find audio drivers for Windows 10 meant for your specific computer.

If Audacity does not work with the manufacturer’s official Windows 10 audio drivers, please see:


I have just installed Audacity 2.1.1 for test purposes.
With Stereo Mix deactivated in the Windows Sound Applet, WASAPI is working just fine.
Still with Stereo Mix deactivated, and with MME or DirectSound selected as “Audio Hosts” in Audacity, the “Recording Device” box was not populated: it was greyed out, and the drop-down was not clickable. And of course, I got the usual “Error while opening sound device” message when I tried to record streaming audio.

Now with Stereo Mix activated in the Windows Sound Applet, and with MME or DirectSound selected as “Audio Hosts” in Audacity, the “Recording Device” box got populated normally. I was able to record streaming audio normally. This is with the Audacity Project rate set at 192000, and Stereo Mix set at 192000 Hz. Both are supported on my system.

Thanks, Robert. So it is not entirely to do with WDM-KS.

You might possibly find that 2.0.2 Audacity download latest version does not have this issue - some changes we made for 2.0.3 to improve audio device behaviour on Vista and later apparently introduced quirks on a few machines.


Further discussion about WDM-KS split to:
Providing a build with WDM-KS support - Windows - Audacity Forum.

The Realtek driver that worked for me is Realtek HD Audio Driver WHQL


Already a newer one, but I’m sticking with what worked for me. As always YMMV.

Thanks for reply, i have been to Dell website and downloaded most up to date sound drivers but still with no luck, have also upgraded another PC from windows 7 to 10, again Audacity will not work with sound device not being found.

Have now installed version 2.03 which works correctly with no problems on both machines so i will have to stick with this until a fix is found. (Anything above 2.03 will not work for me with win 10)


Thanks for letting us know.

Were those most up-to-date drivers actually marked as for Windows 10? As I said, you may be able to use Audacity 2.1.1 with drivers for Windows 7 or Windows 8, or even Microsoft-supplied drivers, as an alternative to using 2.0.3. Any Windows drivers marked as “WHQL” in dxdiag are not totally generic.


I created an account to post my solution to this problem. Turns out I had a program called Morphvox installed which created a software mic called screaming bee. Disabled said mic and re-scanned for audio devices under transport and bam no more problems.

Windows 10
SB Audigy
Audacity 2.1.0

Thanks, neomatrixj2.

Do you have the latest version of MorphVOX from The latest version does claim support for Windows 10.


“Could not find any audio devices. You will not be able to play or record audio.”

Just thought I’d add that this Windows 10 problem has been an Audacity-killer for me. I tried to update some drivers, but whether they’re the right ones or not I don’t know. It didn’t help. I don’t know what kind of motherboard I have. The advice here is too technical to be helpful to me. I’ve wasted enough time on this, so now I have to move on and try out some of the other free products to see if they can do what seemed so easy for me with Audacity. It’s too bad, because I’ve used Audacity for years and been happy with it.

Have you tried Missing features - Audacity Support? If you have a branded computer like Dell, HP or Lenovo, you don’t need to know the motherboard manufacturer - just go to the web site of the computer manufacturer and look up your specific computer model.

As it says on the Wiki page, Audacity 2.0.3 should still work even if you have inappropriate sound device drivers. But if you do have inappropriate drivers this could make recording difficult, even with other software.

We’re happy to help, but please start a new topic and tell us your computer make and model number. If you have externally connected audio devices, tell us their makes and model numbers.


I did find the box for my non-brand name motherboard – Asus P5LD2 – then searched for the drive – Realtek HD Audio driver – downloaded it, extracted it, installed it – a long process requiring 2 reboots – and the result was the same. Nothing. What a waste. So some day I might have another go at getting Audacity to work on my Windows 10 system, but for now I have to quit wasting time, and I’m moving on to Wavosaur to get some work done. What a shame.

I had the same problem…Contacted microsoft, said it was audacity responsibility to adapt to win 10. Suggested I contact my PC maker which happens to be Dell. Got on Dell web site and located driver,"Realtek high definition Audio driver 6.0.1.
Audicity program seems to be working now. Good Luck

I’m pleased that you got it working, but to clarify one point: It is NOT Audacity’s responsibility to provide hardware drivers for the operating system. That is entirely between the hardware manufacturer and the operating system manufacturer (in your case, between Dell and Microsoft). The problem that many people have experienced when updating to Windows 10 is that their older sound card drivers do not fully support Windows 10 (or “Windows 10 does not fully support older drivers”, depending on which way you chose to look at it). In that sense, the computer sound system is not fully functional and needs fixing (by updating the sound card drivers so that they are fully compatible with Windows 10).

Hi everyone.

I believe I have found the issue, if you’re using a Windows 10 Realtek HD Audio driver. The problem seems to be, that the “Stereomix” device does not have a valid default format set. This confuses either Windows, the driver or Audacity and leads to the problem.

You can fix this by going to the RealTek HD Audio Manager, click on the “Stereomix” tab and select a default format. Once that is done, just restart Audacity and it should work – it did for me.

Here’s a screenshot of that page to this posting.
(Sorry for it being in German, but the driver defaults to that on my OS. :stuck_out_tongue:)

Thanks, HedAurabesh.

“Standardformat” in the Realtek control panel should be the same as the “Default Format” (in English) setting in Windows Sound.

So, did you see “Internal PortAudio error” or only “Error opening sound device” in Audacity?

And what was “Standardformat” in the Realtek control panel showing before you changed it?


There have been references to ‘stereo mix’ in this thread. I just upgraded from win 7 to win 10 and lost stereo mix - nowhere to be found. I have the Realtek HD Audio system. I went through all the usual driver update stuff to no avail. And of course no ability to record with Audacity anything playing on my PC. Then I saw this page: As directed, I specified Windows WASAP as the audio host (leftmost dropdown menu just to the left on the little microphone icon), and all was well. Apparently Audacity then uses some ‘loopback’ feature - whatever - without this I would not have been able to record the way I need to with Audacity. Yikes!

Yes, Audacity uses Microsoft’s Loopback Recording method.


Thanks HedAurabesh - your solution fixed my error while opening sound device.

Mine was blank like you stated. Just clicked DVD-Format and now all is good again for recording Stereo Mix.

Any of you here who could not resolve Internal PortAudio Error, please try and start a new topic to let us know how you got on.