Internal PortAudio Error

When trying to run Audacity in Windows 10 professional (64bit), I get the “Internal PortAudio” error. I have tried uninstalling and reinstalling as administrator, rescanning for audio devices via Audacity’s “Transport” menu, and downloading and installing the FFmpeg libraries (again).

Attached, you’ll find the following:

  1. Audio Device Log
  2. DxDiag info
  3. Audacity Log

Any help provided will be most appreciated.

Thank you,
DxDiag.txt (75.7 KB)
Audio Device Info.txt (121 Bytes)
AudacityLog.txt (2.14 KB)

Thank you for the attachments.

Make sure you have been into Windows Sound and enabled all recording and playback devices.

If all the devices are enabled and working in other applications, you’ll have to use some other driver for the sound devices to use them in Audacity.

Have you been to and seen if there is a Windows 10 audio driver for your computer model? If not, or if you already have their recommended Windows 10 audio driver, then you could try going into Windows Device Manager and rolling back to the standard Windows (Microsoft-provided) audio drivers.

You will probably lose stereo mix, but if Audacity can then see your audio devices you should be able to use Windows WASAPI loopback in Audacity to record computer playback.


Thank you for the expedient reply.

In response to your suggestions:

  1. All recording and playback devices are enabled

  2. Sound is working through all devices and in other applications (except Audacity)

  3. I have downloaded the audio drivers from the website you listed, install them, and record my experience with Audacity in my next post.

As far as rolling back my audio drivers and using Windows WASAPI loopback to record computer playback, that has yet to be tried.

Thank you again,



I’m a little embarrassed to report that installing the audio drivers fixed my issue with Audacity.

Regardless, I thank you for your help.


I’m a Windows 10 Pro user, and have had nothing but trouble getting Audacity 3.0.x working. All my audio devices work great for every other application, but I went ahead and followed the recommendations to reinstall drivers, restart both Windows Audio services: to no avail.

The only solution I’ve found is to downgrade to Audacity 2.3.3. Every version after that (starting with 2.4.1) results in the PortAudio error on startup. Clearly something went wrong starting with that version.

I had the same problem and finally I made it work, uninstalling all my audio devices and restarting the PC. The difference after restarting the PC was that one of the drivers disappeared. I don’t remember exactly its name, something starting with WS.