Windows 10 error opening or Internal PortAudio error[SOLVED]

I recently just updated to Windows 10. I was planning to record something on Audacity, but for some reason it is not working. Whenever I try to record it says, “Error while opening sound device. Please check recording device settings and project sample rate.” It says something similar when I start it up. It was working perfectly fine yesterday, but now it doesn’t. The only difference is that it is now on Windows 10. I looked up everywhere how to fix and nothing works. I tried uninstalling and reinstalling, downloading a newer version, Checking if recording devices are enabled, etc. I am wondering if there is anyway to fix tit besides what I said? Or if you are working on a Windows 10 version of Audacity?

What is the exact version of Audacity that you are using?
Note that the most recent version of Audacity was released before Windows 10 was officially released, so Windows 10 is not officially supported (though it is believed to work OK).

What were you planning to record and how were you planning to record it?

Which recording device were you trying to use?

We can’t guess what else you tried. If you don’t tell us what “etc” means we will not know what you have tried and what you have not tried.

I am experiencing similar errors. In addition to “Error while opening sound device. Please check recording device settings and project sample rate.” my system also says that there was a “audioport error”.

Okay, basics. Windows 10. Audacity 2.1.1.

I have verified that all sound devices appear in the system audio devices list and that all are enabled. Rebooted (actually several times). Audacity 2.1.1 was the second upgrade (when I clicked on audacity website from the help file, it directed me to (or I blundered to) Audacity 2.1.0. So the problem has gone from Audacity 2.0.7 through to the most current (2.1.1).

I have tried running audacity in compatibility mode first selecting Windows 2008 and than Windows 2007. I have run the Microsoft app that checks for software compatibility issues. I have reinstalled using the “reset preferences” option. I have used the menu option to rescan devices. All without success.

I have never had trouble with Audacity so I am completely new at troubleshooting the app. That speaks volumes to the quality of the application.

I am open for suggestions on what to try next.


I was going to record my voice. I am using 2.1.1. and devices are enabled. I also tried everything on the faq that was under my problem. Nothing worked.

I am having the same problem. When the program starts I get an error box:

Error Initializing Audio

Could not find any audio devices
You will not be able to play or record audio

Error:Internal PortAudio error

Preferences: Devices shows blanks in all drop down boxes.
(The line under Host: says Using: PortAudio V19-devel (built Jul 11 2015 15:43:45)

Audiacity 2.1.1 Windows 10 (Did complete uninstall/reinstall)

Built in apps and VLC working fine.

I am not sure this is relevant, but I thought it might help.
I am still using Audacity 2.1.0-alpha-Jan 12 2015 because of support for Windows WDM-KS. This version of Audacity worked fine under Windows 8.1 x64. It is now working fine under Windows 10 x64. I could and still can record live streaming radio using WDM-KS, WASAPI, MME, or DirectSound indifferently. Updating to Windows 10 did not make any difference. However, note that I updated my audio driver to the latest available version from my motherboard manufacturer’s site.
Also note that StereoMix has to be activated for WASAPI, MME, or DirectSound to work. WDM-KS does not need StereoMix to be activated.

Error Initializing Audio

Could not find any audio devices
You will not be able to play or record audio

Error:Internal PortAudio error

I get the above when to use Audacity 2.1.1

I record voice overs for radio shows


All you guys that are getting the error:

Error Initializing Audio

Could not find any audio devices
You will not be able to play or record audio

Error:Internal PortAudio error

Please see this topic:

Thanks, it worked. FYI the Realtek driver I had was quite new, I did find a newer version, and voila!

I tried to download all of the new drivers, and I already have them. There was no audio driver, though. Nothing works so far.

Going to the computer manufacturer’s (or motherboard manufacturer’s) site is always the best place to start.

In my case, HP have not yet provided Windows 10 audio drivers for my laptop. HP’s Windows 8.1 audio drivers that include stereo mix do not have stereo mix if used on Windows 10 and cause the internal PortAudio error (no devices) in Audacity.

HP’s Windows 7 audio drivers that include stereo mix also do not have stereo mix if used on Windows 10 but Audacity recognises these drivers and I can record computer playback using Windows WASAPI (loopback).

Audacity also recognises the basic Windows 10 audio drivers that Microsoft provide if I roll back to those in Device Manager. However those drivers do not provide stereo mix and also only provide audio output for the built-in speakers and not for the audio output port.

So for now I use HP’s Windows 7 audio drivers on Windows 10 so I can use the audio out.

Do you mean Robert that stereo mix has to be activated for any WASAPI, MME or DirectSound input to work? If so that seems like a bug somewhere.


From what version of Windows did you upgrade and did you upgrade over that Windows installation, replacing that old version?

What is the make and model number of your computer?

What microphone exactly are you trying to record with (make and model number)?

Have you tried Transport > Rescan audio devices in the Audacity menus?

Assuming you have some audio devices in Audacity, then after rescan audio devices, open Help > Audio Device Info…, press “Save” then attach the “deviceinfo.txt” file. Please see here for how to attach files:


I have had the same problem… No audio devices are shown in Audacity at all, these however are shown correctly in all other programmes and work with no problems. I updated from 8.1 where audacity worked correctly. I have reinstalled audacity several times with no luck. All relevant drivers are up to date as far as i can see.

Have you been to the web site of your computer or motherboard manufacturer to look for Windows 10 audio drivers? That is the best way to update drivers.

Reinstalling Audacity, even if you enabled the Reset Preferences option in the installer, is not going to achieve anything as far as I am aware.

Using earlier or Microsoft drivers might help though of course that is normally not encouraged - see


I have a Gigabyte motherboard with integrated Realtek audio. The Gigabyte download site has an updated (2015/07/21) Realtek HD Audio Driver valid for all Windows systems up to Windows 10.

Yes, Stereo Mix has to be activated in the Windows Sound Applet for any WASAPI, MME or DirectSound input to work in Audacity. But I can deactivate Stereo Mix in the Windows Sound Applet, and record in Audacity through WDM-KS. Note that I still have to select Stereo Mix as the “recording device” (Audio Stereo Input) in Audacity for WDM-KS to record streaming audio, even as Stereo Mix is deactivated in the Windows Sound Applet!

Note that the Realtek own site has an audio driver for all Windows systems up to and including Windows 10. High Definition Audio Codecs

I have downloaded and installed the newest sound driver and it still does not work. Advice please.

I have downloaded the most recent Realtech driver. I have reinstalled Window 10 and still get the initialisation error, What now? Some on asked for a screen shot of the sound icon at bottom rught. It is attached
Screen Shot 07-31-15 at 03.01 PM.PNG

Where did you download them from?
Do they say that they are for Windows 10?

The answer is the same as already given.

If you have correct Windows 10 audio drivers for your computer model obtained from the computer manufacturer’s site, but Audacity gives the PortAudio initialisation error, you must use another audio driver if you want to use Audacity. This could be an audio driver for your computer model and supplied by your computer manufacturer for Windows 7 or Windows 8. Or you could try opening Device Manager and rolling back the audio device to the standard Microsoft audio drivers.

The best solution will vary from machine to machine.


I’ve got the same issue. I upgraded to Windows 10 yesterday, and now when I launch Audacity a popup appears, “Could not find any audio devices. You will not be able to play or record audio. Error: Internal PortAudio error”. Ironically, when the popup appeared, the Windows 10 error sound played over my speakers.

Audacity opens when I click the OK button in the popup, and I can open an MP3. But when I try to play it, I get “Error while opening sound device. Please check the playback device settings and the project sample rate.”

I’ve got a Lenovo desktop with onboard audio that worked great with Audacity 2.1.0 when I had Windows 8.1. I updated to Audacity 2.1.1 from 2.1.0, but the issue persists. For the update, I downloaded the .exe, not the .zip.