Why is the Nyquist plug-in SETrms not working?


so I recently downloaded Audacity version 2.3.3 on my Mac OS Sierra version 10.12.16. I’m recording audiobooks and am having issues with the NYquist plug-in to check and adjust RMS levels that pass ACX standards.

I followed the below instructions to installl it:

Audacity forum guru “Koz” has written a little routine that will set the “RMS” (basically the average volume) of your track to the correct level for ACX requirements. The routine takes a little effort to run the first time, but after that it’s almost automatic.
The first time:

Go to http://www.kozco.com/tech/audacity/Documents/
Download "SetRMS (a zipped text file)
Copy the text
Open Audacity
Select some audio
Go to Effect > Nyquist Prompt and paste the text in the Nyquist Window.
Press OK. Audacity will adjust your audio so that the average volume is correct.
Any time after that:

Select some audio
Go to Effect > Nyquist Prompt
[the text from last time will be there already] Press OK.

I managed to paste it in the Nyquist prompt window under the other text, which is version 3, I guess? So it should work right, but it doesn’t. I select an audio section and apply the SETrms (or the updated Nyquist pomopt) and nothing happens. No error message. I checked and unchecked the Version 3 box in the Nyquist window. No change.

I will mention that, briefly, I did get an ACX check, which I used to get before I pasted in the SETrms text into the Nyquist window. A couple of times it popped up, then disappeared. No idea what I did. Since nothing is popping up on the screen when I apply the updated Nyquist prompt, I can no longer check the ACX levels for the noise floor and the peak level either! (though, they were in good shape before, so I guess it’s okay).

Can someone please tell me why it’s not working?

The more recent RMS normalize plugin does the same thing.

The next release of Audacity will (probably) include an effect that can normalize to a specified RMS.
In the meantime I agree with Trebor’s recommendation: https://forum.audacityteam.org/t/rms-normalize/45334/1

Some text-editors can add/change invisible characters which prevents Nyquist code from being executed.

I’ll go fix that.


We publish the Audiobook Mastering Suite which guarantees RMS and Peak. If you recorded well in a quiet, echo-free room, you may be done.


That’s the long form. This is the abbreviated version.


Still doesn’t work for me. I should note that, after I downloaded Nyquist plug-in ACX check, it somehow ended up in the Tools tab, not in the Effects or Analyze tabs (where it seems ACX check should have ended up). I found the original ACX check—the version 3 I’m referring to in my first post with which I used to check peak, rms noise floor BEFORE I got into trying to master. Before I downloaded and pasted in the SETrms. Trying to be extremely specific here:) That ACX box always popped up then I selected some audio to test peak, rms and noise floor. Now that I pasted in the SETrms in the Nyquist window, no boxes of any kind pop up on the screen.

Koz, I tried to use your directions in the Audiobook Mastering Suite, but since I can’t get the RMS Normalize plus-in into audacity, I can’t do the second step. I have downloaded RMS Normalize, but I don’t know how to get into Audacity. Can you help me with that?

I was trying to update my second post as I apparently wrote THEN in a place where is should have been WHEN. Here: That ACX box always popped up then I selected some…

By the way, I’m obviously clicking the add/remove plug-in button, but it doesn’t get into Audacity under the Effects tab. I closed Audacity afterward, then opened it again. Sometimes that helps. What am I doing wrong?

After selecting the plug-in in the “Plug-in Manager” (https://manual.audacityteam.org/man/manage_effects_generators_and_analyzers.html), click the “Enable” button. In the list of plug-ins, the “state” column should say that the plug-in is “enabled”. Then click “OK”.

When you do get it all sorted, you can send us a raw recording test. We can see if the normal mastering techniques will work and evaluate any other problems.


Note all we’re officially doing is technical testing. Everybody knows what the ACX limits and standards are and generally how to meet them. However, you still have to pass theater and reading quality. We can guess at that, but that’s totally up to their Human Quality Control.

One fairly common rejection is someone who absolutely passes ACX Check, but they got there by beating their voice up with a stick—extensive processing, stiff noise reduction, compression artifacts, etc. That’s so not going to pass. Their model is someone telling you a fascinating story at the table over cups of tea. Not listening to cellphone distortion.

One of the goals of Audacity Audiobook Mastering is to not be obvious what we did, but suddenly your voice passes.

If you’re way far along, you can send ACX a short test.


It’s not unusual to get rejected because of the amount of “silence” (room tone) in your submission. There are strict rules about that, how much to put in and where. Room tone is used everywhere, very quiet, but natural room noises, not Audacity > Generate > Silence.



I could send you a raw test, but at the moment I’m not too worried about passing it. I have not been beating up my voice at all and have some experience with voice acting. At this point, I would just love to figure out WHY I can get the plug-in for SETrms into the plug-in manager. I have downloaded it, but it doesn’t pop up as one of the many, many choices in the column. ACX checkny does, however, and yes, of course I checked the “enabled” box (so that it is no longer a “new” plug-in choice in the plug-in manager column). Enabling it still doesn’t populate it in that column. Should I just re-install the Audacity software?

That’s because “SETrms” is not an installable plug-in. It’s just a Nyquist “script”.
Nyquist “plug-ins” can be installed. Nyquist “scripts” have to be run in the “Nyquist Prompt”.

The “RMS normalize” plug-in that Trebor and I recommended is an installable plug-in. We both recommend using the RMS normalize plug-in rather than the “SETrms” script.
(Background info: I wrote “SETrms” as a proof of concept, and later I wrote the RMS normalize plug-in as a practical, installable plug-in. Use the plug-in, not the prototype).

Note to koz:

In your “SETrms.txt.zip” file, the contained “SETrms.txt” file has too much leading white space at the start of each line. This is probably a result of copying from a forum “[code]” box. In some situations, the additional spaces may cause the plug-in to fail.

Attached is a zip archive containing a corrected “SETrms.txt” file.
SetRMS.txt.zip (570 Bytes)

Okay, so I finally managed to get ACXCheck under the Analyze tab. I have no idea how it eventually ended up there, though I did reboot my laptop a couple of times. And then the RMS Normalize plug-in was also available in the Plug-in Manager. I enabled it and could use it.

My chapter passes all three criteria for ACX! :smiley:

Thanks for all the help.

Attached is a zip archive containing a corrected “SETrms.txt” file.

Thank you. Today is going to be fresh tea and cleaning up errors and mistakes.

There are at least two info links in Kozco that are dead.

As soon as I find that page I may find a lot of other inconsistencies. It’s probably old enough not to know about Audiobook Mastering.


I’m out of breath.

Screen Shot 2020-01-30 at 8.33.40.png
I believe that’s a stand-alone web document never intended to be publicly distributed. If it does appear on-line, it may be by accident. I don’t think anything points to it other than, you know, Google.

So I became one of those “Hidden Secrets They Don’t Want You to Know About.”

That whole pile may quietly vanish.