What you hear

I am using the latest Audacity Version and Win 7. On XP I used to be able to select ‘What you hear’ and record sounds from the computer. When I select it now with Win 7 I just get a flat line. Any help would be appreciated.
Thanks, LS


It’s called different things depending on the soundcard and computer.


Using W7 and latest Audacity your best bet is to set your host to WASAPI and select the loopback input.


I have been using audacity for many years completely problem free & then after upgrading to the newest version, I can’t record ‘what I hear’ anymore.
I have always used Creative Audigy soundcards but have also used audacity just as easily on computers without a seperate soundcard that has Realtek onboard sound & audacity would still work exactly the same, recording ‘what I hear’.

The issue now is I cannot now use audacity on the computers with the realtek onboard sound as the ‘what you hear’ option is no longer there & there seems to be no way to get audacity to record ‘what I hear’. It says there is no device but the computer itself is the device by which we listen to music, so why does audacity not automatically know this if someone is using onboard sound?? When I set the two drop down menues to ‘realtek’ it does nothing & any combination of the two options in the two menu fields or other preferance setting yields a fix?

I think the biggest issue here is why the 'ef anything had to change from how it has always been, it must be close to 20 years I’ve been using audacity & have never had to come the forum here before. I have been so happy with audacity that I have preached it to many hundreds of people & friends over those years & now, in the days of google screwing up everything suddenly audacity isn’t it goodself anymore? Anything we should know, like this now has google fingers stuck in it? Does anyone know of a fix for this problem?

AstralSpirit - you fail to tell us what version of Windows and Audacity you are on - if it’s W7 or later and Audacicity 2.0.6 (the latest) then the advice above should enable you to record what is playing on the computer. In particular my earlier advice about setting the host to WASAPI and loopback as the selected input device holds good - it 's what I do and it works well.

The removal of “What-u-hear” and “Stereo mix” or whatever is not an Audacity thing. Audacity here is a slave to the inputs that any particular combination of PC, O/S and device drivers that it’s running on. PC manufacturers and Microsoft seem to be making it harder to record the audio that plays on the computer - presumably to discourage piracy. Though interestingly enough my latest Toshiba laptop with W7 64-bit still offers “Stereo mix” - but I still prefer to uses WASAPI loopback.


Windows 7 was stated but not the version of Audacity.

I suppose we have to type it all out.

Download Audacity 2.0.6 from Audacity ® | Download for Windows.

  1. Open Device Toolbar - it looks like the below:
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Playback device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Recording device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Recording Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.