Voice recording is silent [HELP]

Whenever I try to record my voice, the output is always silent. I have tried changing the host interface devices and recording devices multiple times, but none of them would work. There is nothing wrong with the microphone on my computer, as I tested it out and it clearly recognizes my voice. In Windows, I have the setting “Allow desktop apps to access your microphone” turned on. In Audacity itself, I tried recording my voice with MME and Microsoft Sound Mapper - Input, no luck; I tried it with MME and “Microphone Array (Realtek(R) Au[dio]” which was also an option listed, no luck. I then tried the Windows DirectSound host, with Primary Sound Capture Driver, no luck; I tried it with Windows DirectSound and Microphone Array (Realtek(R) Audio), STILL no luck. I even tried it with Windows WASAPI and it wouldn’t work. Please help???![/size]

  1. open the run dialog with “Windows logo + R”
  2. enter: mmsys.cpl
  3. press the “OK” button

That will open the Windows Sound control panel.

Open the “Recording” tab.

Speak into your microphone. You should see a green meter to the right of one of the listed devices, responding to your voice.
Do you see that? If so, what does it say the device is called?

If you don’t see the green bar, or if it’s not moving in response to your voice, then there’s something wrong with you microphone, mic lead, sound card, or Windows Sound settings.

What happens?

Yes, the green meter appears, my microphone is working correctly. The device is called Realtek(R) Audio, but as I said earlier, I did try that audio device for recording but it still comes out as a completely silent track. (I am using Audacity 3.0.2)

Try setting up Audacity to use “MME” as “host” and “Microphone Array (Realtek R Audio)” as the recording device in the Device Toolbar.
Try recording.
If it records as a flat line, try applying the “Amplify” effect with default settings.
What happens?

With MME as the host and Microphone Array (Realtek R Audio) as the device, it does just record a flat line. I amplified it, and it was still silent, so then I amplified it a bunch of more times, and all I got was static white noise.

With MME as the host

What’s the other one? There’s two different ones.

This amplify thing is a trick because the blue waves only show you about the loudest 25dB out of 96dB. So you can actually have a recording and just not see it. That’s not your problem.

I’ve been known to lose a recording because I set up for Stereo instead of Mono or the other way around. Anything there?

Do you use Skype or Zoom? Is Skype or Zoom still running in the background? Both of those change sound settings without telling you. Close all your apps and clean shut down the computer. Shift+Shutdown > Wait > Start. Not Restart and not normal Shutdown.

That help?

This one is a little out there: Do you get blue waves and just can’t hear them? There are analog recording errors which can cause that.


My recording is set up with two channels for Stereo, nothing there. I don’t have any other applications open in the background that would conflict, just my internet browser, which isn’t using my microphone. I did a complete shut down of my computer, and started it back up again and tried to record, but that still didn’t fix the issue.

Is this a Desktop? Laptop?


What’s your microphone and how is it connected? If it has a model number, pretend I want to buy one. There’s something odd about your Windows control panel, but I can’t quite sort it.


Laptop, Lenovo. Windows 10, I think the version is 20H2. It is just the default microphone on the computer.

See if Audacity works set for mono recording instead of stereo.


I tried it on a mono recording, still didn’t work. I then decided to close and uninstall Audacity, shut down, power on, then re-install Audacity, which also still didn’t work. It is strange because just a few days ago I was able to successfully record using my microphone with Audacity (Until I updated to the newest version, maybe?)
I can still record device audio from the speakers using Windows WASAPI, that works fine.
Windows detects an input to my microphone, it detects that Audacity is using my microphone, yet nothing records.

Quick note. If you record, say for two minutes, do you get a two minute recording?

Are you trying to do this at one of the two standard sampling rates? 44100 or 48000 (lower left panel)?

yet nothing records.

I’m out.

You have achieved the troubleshooting gold standard. There’s nothing wrong with it, but it doesn’t work.

Audacity acts very strangely if its recording bitstream or service becomes damaged. Freezing or halting cursor and stuttering motion. You don’t have any of those problems. Audacity acts exactly and perfectly normal. I think it is recording the wrong thing, but I don’t see how.


Google lenovo 20h2 laptop microphone recording settings


There’s pages of this stuff.

I know this is silly, but is the Audacity recording volume slider turned up?

Screen Shot 2021-06-02 at 8.29.26 PM.png

Very puzzling :confused:

Perhaps Audacity’s “audio device info” will give some hint.
“Help menu > Diagnostics > Audio Device Info…”
(See: https://manual.audacityteam.org/man/help_menu_diagnostics.html)

Please save the results as a text file and attach the file to your reply (see: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

One more from the ancient writings.

Set it up normally like you would expect it to work. Run the recording slider all the way down, pause, and then run it all the way up. Did it follow you OK or did it jump around, and did it change anything—did recording start working?


If you are still having issues, do Transport > Rescan Audio Devices, then make sure the Audacity sample rate (lower left-hand corner) is the same as the Windows sample rate, see Direct access to the Control Panel Sound settings, specifically under the Advanced tab.

“If you record, say for two minutes, do you get a two minute recording?”
Yes, I do.

“Are you trying to do this at one of the two standard sampling rates? 44100 or 48000 (lower left panel)?”
Yes, my current sampling rate is 44100.

“Is the Audacity recording volume slider turned up?”
Yes, turned up to full.

“Google lenovo 20h2 laptop microphone recording settings
Thanks for bringing this to my attention, I’ll look more into it to try to figure out if anything’s wrong there.

“Set it up normally like you would expect it to work… Did it follow you OK or did it jump around, and did it change anything?..”
I tried it, nothing happened. The recording was still a thin, flat line.

“Audio Device Info/Please save the results as a text file and attach the file to your reply”
Not sure if it’d be of any help, but I added it as an attachment.

I checked, and my Windows Sample rate turned out to be 48000 Hz, while I had mine in Audacity set to 44100. So of course, I turned it up to 48000 Hz, and tried recording. Did it work? Still… nope.

I’m still very confused as to what the problem is, and I’ll try to look more into the standard microphone recording settings for Lenovo 20h2, if that could help.

(Not sure what happened to the attachment I uploaded in the last post… here’s my Audio Device Info)
deviceinfo.txt (4.4 KB)

Go back to that screen and scroll down.
Is Audacity listed as a Desktop app, as shown below.