USB Mic works in Windows and Older version of Audacity, but not ON 3.3.2

Continuing the discussion from USB mic recognised but not recording:

I am having a similar issue. I am using a CAD u37 mic. Had it running on an older laptop that used Audacity 3.2.5 Just got a new laptop and have Audacity 3.3.2 installed. The Mic is recognized and I have all of the setting set to use it as the recording device. I have test it in other apps and the Windows system and it can record and pick up audio just fine. I can even plug it into the old laptop and it will record in Audacity. But If I plug it into the new laptop, It will not record anything from the USB mic in audacity.

1 Like

Typically when you have a new laptop, you have to Turn on app permissions for your microphone in Windows 10 - Microsoft Support

Also run Transport > Rescan Audio Devices and run Audio Setup to make sure you have the microphone selected as your recording device.

I have tried both of those and it made no change.

Check the levels on your Meter Toolbars - Audacity Manual.

Can you record from the Laptop’s built-in microphone?

You can try switching the host between MME and WASAPI.

You can also try Tools > Reset Configuration.

Recording from the laptops built in mic just fine. I’ve tried switching from mme to wasapi and resetting configs and still no change.

And the levels on the Mixer Toolbar ?

Both the Mic and Speaker levels are set to 100 and still not getting anything from the USB Mic, but it will still pick up on the Internal mic even with the USB mic selected as the recording device.

Looks like you have not got it installed or not enabled. Forget about Audacity, close it.
Make sure USB is installed in windows , check Device manager for no Yellow Question marks and no red Xs. Then in windows sound settings make sure USB mic is working and you can see input levels rise as you YELL into it. OR search “Control Panel” and go to Sound and look at all the devices you have… is the list sensible and is USB device there. Check volume levels in windows etc. Then when sure all is working…Open Audacity and select the devices you are using Host, Input, Output.

It works just fine in Windows and other applications. Shows fine in device manager. It is installed correctly. Just does not work in Audacity.

is it a listed device in Audacity, Have you it selected in audacity.
How is it listed in windows…C-media USB device…??.. did you try mic boost…??
Do you see this device listed in Audacity…
Did you try windows mixer to at least get it working and untick or switch off any sound enhancement
If listed in Audacity and selected do you see the Audacity mic level bars go up