USB mic recognised but not recording

I have a USB condensing mic which works perfectly on my Windows 7 PC in Audacity. I’ve just bought a new Windows 10 laptop and although Audacity is recognising the device in the sound bar I am unable to monitor sound and when I click record the box appears but nothing happens. The internal laptop mic records fine.

I have tried setting up the USB mic on the laptop within sounds and devices and it recognises it just fine. What am I doing wrong?! :angry:

Further, when I’m in Sound and Devices in the control panel, when I try to click on ‘enable this device’ the bar remains greyed out and I can’t enable it, I can however disable it. I’ve tried disabing and then re-enabling the mic but nothing happens.

I am using 2.1.2. When in the Control Panel and Sounds and Devices on the laptop I am not able to ‘enable’ the mic as the option is greyed out. I tried disabling and re-enabling but the same thing happens. Just tried it again on my Windows 7 PC and the mic and cable work fine

That will be why Audacity can’t use it. The device must be enabled in Sound and Devices otherwise applications (such as Audacity) will not be able to use it.

Try unplugging the mic then plugging it back in again - preferably into a different USB port. Does the device become enabled in Sound and Devices? If it does, and it stays enabled (does not become disconnected), try restarting Audacity, or, from Audacity’s Transport menu “Rescan audio devices”, then try recording.

Hi Steve, thanks for your reply. I have tried this in both USB ports and clicked enable and it still doesn’t work. In the Properties>Hardware info it says ‘this device is working properly’ so don’t know why it isn’t recognised in Audacity…

I tried looking on my Windows 7 PC and the enable box is also greyed out there, but the mic works fine. When you speak into it the bars within the box go up and down, but it doesn’t do this on the Windows 10 laptop. Very strange. I think somewhere along the line the mic isn’t being recognised on the laptop itself.

It isn’t recognised by Audacity because it isn’t enabled in Windows (not enabled in Sounds and Devices).
The question should be: why isn’t it enabled in Windows?

What’s the exact make and model number of the USB mic? Does it require special drivers for Win 10?

Just looked and it appears the AT2020+ USB mic is not compatible with Windows 10. Marvellous. Is there a driver I can install to make it work do you know?

Where did you see that?
I looked on the AT site and they say that the AT2020+ USB should be compatible with Windows 10. Having said that, I see via Google that MANY people are having problems with this mic (and other USB mics) on Windows 10 - either low recording volume, or does not work at all.

Some things to check which ‘may’ help:

  1. Ensure that you don’t have Skype or other voip software running - not even in the background. Do this first - it’s relatively simple and safe.

  2. Ensure that you do not have any “voice recognition” software running - this may be tricky because of “Cortana”. Sorry but I can’t help here as I don’t use Windows.

  3. Some people have reported that disabling Cortana completely has fixed their USB mic problems - This is risky unless you know what you are doing, so be careful.

  4. Perhaps not an option for you, but one popular solution reported to be very effective is to stop using Windows 10. Some have “rolled back” to Windows 7, while others have migrated to Linux.

  5. Another one that you may need to ask your local PC guru to help with: Uninstall the USB audio driver (with the mic connected), then unplug the mic, then reboot, then plug the mic in and cross your fingers.

As I said, I don’t use Windows, so I think that’s as far as I can go. I hope that something in the above list will help, or perhaps someone else on this forum can offer advice, so I think that’s all from me other than wishing you good luck.

Can you attach an image of the Recording tab of Windows Sound ? You can capture an image with Windows Snipping Tool. Please see here for how to attach files:

Also right-click over the mic. Please list the exact options you see (or you can capture an image using Snipping Tool if you enable delayed capture).

It is harder now to disable Cortana than it was when Windows 10 first came out.

Cortana uses whatever is the Default recording device - not the Default Communication Device.

So if Cortana is the cause of the problem, in theory you could ensure the USB mic never gets set as Default recording device when you connect it. To do that, connect the USB mic, right-click over another recording device and choose “Set as Default Device”. Then disconnect the USB mic. Next time you connect it, it should not becoome Default recording device.