URGENT - Focusrite Scarlett 2i2 "latency" issues -

I am fairly new to the whole recording side of music
I am using a Scarlett Focusrite 2i2.
(I had recorded an overdub for a client who had delivered me a WAV - everything worked fine.)

I have a piece of work I have to deliver tomorrow - a 3 track piece. My problem is I am getting a terrible lag - I guess it is latency.
I have played around with all the settings and but I’m still getting the delay

Any help or advice to get me out this hole asap would be really appreciated

See this page in the manual: https://manual.audacityteam.org/man/latency_test.html

And this tutorial set may be useful too: https://manual.audacityteam.org/man/tutorial_recording_multi_track_overdubs.html

WC

I did the latency test - it seems the click track through my mic was around 20ms BEFORE the generated click track.
Adjusting the latency setting by +2- and -20 ms had no effect

Which tutorial is like my Scarlett 2i2?

I already performed the latency test - the playback click through my mic was appeared AHEAD of the generated click track???

If the newly recorded track plays earlier than the original track, then the “Track shift after record” is too much (too negative).

What are your current settings for “Buffer length” and “Track shift after record”?

This one is most like it: https://wiki.audacityteam.org/wiki/Overdubbing_with_a_Behringer®_UCA202_Stereo_bidirectional_USB_Soundcard

WC

I am getting a terrible lag - I guess it is latency.

Machine latency. You should plug your headphones into the Scarlett, not the computer. The computer headphone system is always going to have “one computer late” delay and echo and you can’t stop it.

The Audacity latency setting is Recording Latency. That’s the one you set to make your new track match the timing of your old ones.

Koz

Machine latency. You should plug your headphones into the Scarlett, not the computer. The computer headphone system is always going to have “one computer late” delay and echo and you can’t stop it.

The Audacity latency setting is Recording Latency. That’s the one you set to make your new track match the timing of your old ones

Yup - did all that, and latency is still a massive issue - messed with direct monitor setting on the 2i2.

missed the project deadline, now resorting to timeshifting 4 recorded lines for each of 3 pieces.

This program with the 2i2 has been a nightmare!

How did you set the recording latency? If your latency is far enough off, you can chase your tail for a very long time. I recommend using Generate > Click Track at the default values except maybe slower than normal. Set up for overdubbing and use that as the backing track. Play that into your headphones (plugged into the 2i2) and jam the headphones against the microphone.
Screen Shot 2018-04-10 at 17.08.28.png
The latency correction will be the time difference between the two tracks.
Screen Shot 2018-04-10 at 17.06.28.png
http://kozco.com/tech/audacity/clips/X2ULatencyCaptureBefore.wav

I always get the (+) and (-) correction wrong the first time.

Koz

Thanks Koz

Did that - played the backing click track back through the mic and adjusted the prefs.

One thing - the latency adjust puts an equivalent “silent” patch at the start of the recorded line. It doesn’t always do this with every track and I wonder why?

Another thing that spooked us - when testing for latency the played back click coming BEFORE the generated click - what’s that all about :slight_smile:

Will persevere today - we’ll try and deliver something to the guy and see if we can salvage something. Prob. be doing a lot of timeshifting

Do you know of a program similar to Audacity that doesn’t have this problem? Thinking of brushing up on Ableton

Cheers

Here’s my “easy way” to set up latency correction…


Firstly, ensure that the prerequisites are all in place:

  1. Does Audacity record via the microphone? If yes, proceed, else fix this first.
  2. Can I hear the recording through my headphones when I play it back? If yes, proceed, else fix this first.
  3. Can I hear myself through my headphones without a delay or echo? If yes, proceed, else fix this first.
  4. Can you record a second track (shift + R) and hear the first track play while the first track is recording? If yes, proceed, else fix this first.

So when that’s all working, move on to latency correction:

a) “Edit menu > Preferences > Devices” → Set “Track shift after record” to 0 (zero). Then click OK. (Buffer length should normally be about 100, but don’t adjust this if microphone recording is working OK)
b) Generate a 30 second click track with “Generate menu > Rhythm track”. Set the “Beat sound” to “Ping”.
c) Place you headphones close to the microphone (as in Koz’s previous image, and press “Shift + R” to start recording to a new track.
d) Allow the recording to run for 6 or 7 seconds, then stop the recording (spacebar).

You should now have a recording that looks something like this:
tracks000.png
Note that the clicks in the newly recorded track are after the clicks in the original track.

e) Zoom in on one of the strong beats, and select from the start of that strong beat in the first track, to the start of the strong beat in the recoded track, like this (click image to expand):
beats.png
Note that the “Length of selection” in my example is 188 ms (your will probably be different).
This is our initial measurement for the amount of “round trip” latency.

Because we need to shift the newly recorded track to the left (earlier), we need to adjust the position by -188 ms (minus one hundred and eighty eight).

f) “Edit > Preferences > Devices” → Set “Track shift after record” to the negative of the measurement. (In my case, I set it to “-188”). Press OK to close the Prefs window.

g) Ctrl + Z to undo the recording.

h) Select the first track and set it to “Solo” (click the track “Solo” button).

i) Shift + R to record a new track, then stop after a few seconds.
j) Repeat step (i) so that you have several tracks one above the other like this:
tracks001.png
Note that it is normal for there to be a little variation from one track to the next, but with a reasonable sound card the variation should be small, perhaps varying by around +/- 1 ms.

  • If the average position of each click in the recorded tracks line up with the original track, you’re done.
  • If the average position is a millisecond later than the original, then you need to tweak the “Track shift after record” amount by another -1 ms (in my case that would be -189).
  • If the average position is a millisecond earlier than the original, then you need to tweak the “Track shift after record” by +1 ms (in my case that would be -187).

If there is more than a few ms variation in the recorded track positions, then something is wrong with your sound card.

something is wrong with your sound card.

That’s not mentioned in the instructions, but if your time matching wanders from one day to the next (or even hour by hour), then there may be something serious wrong with your machine.

If you do get wandering, it’s good to know a little about it. Say you set it all up, but the first real test wanders and is clearly different from your setup. Does a third test wander, too, or do tracks two and three match?

One other mistake some performers make is being too precise. I saw one performer changing the settings down the atomic level of his computer. That’s guaranteed to fail because we’re not using Audio Workstations here. We’re using home machines designed for Skype, Excel, and Angry Birds. They wander. Usually, they don’t wander enough to care.

Koz