Upgraded to 2.1.2 and cannot monitor or adjust input volume

I just upgraded to version 2.1.2 for Windows 10 and now I cannot monitor while recording, and the input volume slider does nothing and the music from my USB turntable is all distorted.

What did you upgrade from?


can’t remember but prolly 1 point something

Look at the Audacity Device Toolbar. Are you trying to play music to your sound system or back to the turntable? Sometimes Windows thinks any USB device will both record and play and it sets you up that way whether you want it or not.


This is when we wait for a Windows elf.


i think my inputs and outputs are correct, they are just like it was before in 1.something.
if i expand them, nothing else new shows up.
it records fine, and plays back fine, i just can’t seem to change the volume, or monitor when recording.

Did previous Audacity work on Windows 10?

You could post the contents of Help > Audio Device Info… top right of Audacity then we can see what you have. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

You can try changing the input volume in Windows Sound. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the turntable, then choose “Properties”. Then click the “Levels” tab and adjust the input slider.

To monitor audibly in Audacity , Transport > Software Playthrough must be ticked (checked). The playback device in Device Toolbar must be set to the speakers or headphones you are using.

If Software Playthrough does not work, then when you are in the recording properties of the USB turntable in Windows Sound (as above), move from the “Levels” tab to the “Listen” tab where you can enable “Listen to this device”. Again you will have to set the playback device to the speakers or headphones you are using.


Thank you Gale.
I am definitely getting monitoring with Software Playback. Woo hoo!
And I do think going into Windows Sound helped with the volume. Its kinda a pain compared to my last version where the slider for the mic worked fine, but if that’s what I gotta do, at least it works…
Also, thanks for the quick responses.

I posted too soon. The level does not appear to change by going to Windows Sound. I must have put on a quieter record the first time. I am back to pinning the meters and distortion. I have the input for my ‘Microphone Array’ at 10 out of 100, and it has not lowered in volume. However, when I am in the Sound Control Panel and change the slider, the APPLY button is not available, just the OK button.
I am curious why the playback slider in Audacity works fine like it used to, but the mic slider has no effect, whereas it used to function fine in 1X.

You are choosing the USB Audio CODEC for the turntable as Audacity Recording Device, aren’t you?

If you do that, is the Audacity recording volume slider then greyed out on maximum? If not, then moving the Audacity recording volume slider “should” move the recording volume slider for the turntable in Windows in tandem (move one slider, and the other slider moves exactly the same).

If the Windows slider makes no difference to the recording level, then that is a Windows problem, not an Audacity problem. If so, that might have happened with the upgrade to Windows 10. Unless the turntable was made after release of Windows 10, it may not fully support Windows 10.

What make and model number of turntable is it? Some turntables have a gain knob underneath the turntable. See if yours does.


This very same turntable and W10 computer setup worked just fine in 1X. The only reason I upgraded (besides the fact that your website highly encouraged it and no longer supports 1X) was that I would like to save my recordings as MP3’s or AAC mp4 instead of just WAV, and those pull down menus never worked in 1X. I read that the new version had options for mp3 and 4. Well, that backfired on me, b/c I still can’t figure out how to do either of those MP formats, and now my record volume is messed up. There may be a third party download I need to do for other formats?

Anyway, my Recording Device is listed as Microphone Array (USB Audio), the same as it used to be and worked fine. The volume slider is not greyed out ( I am assuming you mean the slider next to the mic symbol that used to control the input volume). Also, the new version seems to have more latency than the old version, when I could turn up the playback volume on the record player and listen to both at the same time. The turntable is a Crosley Radio CR6019A built in 2015 and has always seemed to be Windows 10 compatible. The only volume it has is playback volume, which has never influenced the USB output.

At this point I am sorry I deleted the old Audacity, I might have better luck going back to it and just convert my WAV files with another program.


To export MP3, you have to add LAME http://manual.audacityteam.org/man/faq_installation_and_plug_ins.html#lame if you do not already have a compatible LAME version.

To export MP4 you have to add FFmpeg http://manual.audacityteam.org/man/faq_installation_and_plug_ins.html#ffdown.

To export, use File > Export Audio… and choose the format you require.

Please move the recording volume slider in Audacity 2.1.2 while the turntable is the selected recording device, and see if it moves the recording slider for the turntable in Windows Sound. If it does, and moving that Windows slider for the turntable yourself does not affect the achieved recording level, then that is not likely to be an Audacity problem. Audacity does no manipulation of the level of the recording it receives.

Would it be true to say that in 1.x on Windows 10, you never adjusted the input volume anywhere - it was always at a reasonable level?

Are you saying it’s taking longer for the Audacity software playthrough to reach your computer speakers or headphones? If so, Audacity can’t adjust that latency value at the moment. That latency is set by the PortAudio audio interface we use for playback and recording, and in any case the prime determinant of the delay is the computer and how busy it is.

Perhaps as an experiment you would like to try our latest alpha build http://gaclrecords.org.uk/win-nightly/index.php?dir=&file=audacity-win-r58b8387-2.1.3-alpha-23-aug-16.zip and see if that can move the Windows slider for the turntable. It is not an installer. Just exit 2.1.2, right-click the ZIP, choose “Extract All” then extract the files to some folder on your computer.

We’ll take it from there.

Are you sure this Crosley model has no way to adjust the level of audio it sends to the computer?


OK i downloaded the mp3 and m4a files and saved a test file to the formats and it saved them. they were both playable on itunes, so that is fixed. thanks.

i did look at the control panel at the same time as moving the audacity slider, and they DO move together. so you think this is a windows issue? however, i am POSITIVE it worked before in 1X, i recorded many many records with different volumes, and that slider worked. so what could have happened between 1x and 2x?

i also tried the 2.1.3 alpha, but it did the same thing

the latency is no big deal, i just turn down the volume on the record player

there are no set screws or anything on the crosley, and i looked in the manual. don’t think there are any ways to control usb volume.

attached are screen shots of what you asked, didn’t know how else to do it

Audacity 1.jpg
Audacity 2.jpg
Audacity 3.jpg
Audacity 4.jpg

It is not very intuitive but you can click OK in the Audio Device Info to save a file, which you could then attach.

You have a lot of USB audio devices. Were you using all those when you had 1.x? What is SB for iTunes?

Are all these USB devices connected directly to separate USB ports on the computer, or connected to a USB computer hub which is connected to a USB port? If you are using a USB computer hub, this may cause USB devices to work improperly and will increase latency.

If you are still convinced 1.x would allow the Windows slider to control the turntable level, then you can find all 1.x versions here: https://sourceforge.net/projects/audacity/files/. The “audacity” folder contains 1.0.x and 1.2.x versions of Audacity, and the “audacity-beta” folder contains 1.1.x and 1.3.x versions.

Do not click any ads on that site or there is the potential you could harm your computer.


SB for itunes is SoundBlaster which is a small USB dongle that broadcasts music wirelessly, think probably bluetooth. But it also has a 1/8" jack for audio out of the computer.

So I went and chose 1.2.4 and it worked just like it used to, can change volume on the fly. Being that you don’t seem to believe me, attached is a screen shot of a song starting at 5, down to 0, then up to 10. So the only difference is that I went from 2x back to 1x, everything else in computer and turntable exactly the same… :open_mouth:

I do have a 10 way USB hub extender, and it is full. but i don’t see how that can affect audacity 2x and not 1x. as i said before, i noticed the latency, but it is the absolute LEAST of my issues. all i really want to do is control volume and output to mp3 or m4

thanks again
Audacity 1.2.4 Volume Change.png

I did not say I did not believe, but that it did not make any obvious sense to me, given moving the Windows recording slider yourself had no effect with 2.x.x, and given Audacity does not manipulate recording level other than through Windows.

Audacity 1.2.x is somehat “lighter” in resource use than 2.x.x. The only explanation I can think of at the moment is indeed the fully loaded USB hub. If you connected 2.x.x to an empty USB port I think there could be a chance it would control the recording volume. But really I would be massively concerned at the risk of recording dropouts using a fully loaded 10-way USB hub. Is it connected to a USB 3.0 port?

We could try other experiements to do with 16-bit/32-bit or the audio host you are choosing in 2.x.x (MME, Windows DirectSound or Windows WASAPI) but of course you don’t have to experiment for us if you don’t want to.

Be aware that 1.2.x could crash when you press Stop, and has no automatic crash recovery. It’s a risk you’ll take if you use that version.


i don’t mind being a guinea pig
would like to get it working
i have tried MME, Windows DirectSound and Windows WASAPI options with the same results

Can you control the recording level if you connect to an empty USB port?


sorry, i got real busy with several projects
i reloaded 2.12 again, and connected it straight into usb on back and front of computer, neither let me control volume…

Thanks for testing. I don’t have any other ideas, except possibly disconnecting every other USB device from the computer except the Crosley.

You could try following http://artproaudio.com/support/faqs#windows7 to use Speech Recognition settings to make the USB input less hot but I don’t know anyone who said that works.

And of course you could try other recording applications than Audacity and see if they let the Windows recording slider adjust volume. You should not use a recording application whose input slider does not move the Windows recording slider in tandem. All that would do is make any input distortion quieter, not stop it happening.


I use Magic Jack as a VOIP, and its slider moves in tandem with the Windows recording slider, and works fine.
If I disconnect all USB devices, that will include my mouse and keyboard, so I wouldn’t be able to control what I am doing on Audacity.