Unrecoverable startup error in 2.4.2 and earlier

On my Mac Pro running Mojave, I tried to move the temporary storage directory from my small boot disk to an external 2 TB USB drive.
When I do the necessary restart to save the settings, Audacity will not restart with an unrecoverable error! I must delete the app and reinstall. I tried this several times.

On my iMac running Catalina I cannot reproduce this. Is the “SessionData” folder created on the external HD?

– Bill

Yes, and in fact, audacity created the folder.

It was formatted as ExFAT though. I am reformatting it now into MacOS Journaled. That fixed it!
But if exFAT disks are not allowed, Audacity should tell you so.

Curiously enough I’ve been testing saving to exFAT USB on Mac with 3.0.0 for a large part of today.

This working mostly fine - albeit extremely slow.

So following your post I tried setting my Temporary files directory to my exFAT USB.

With both 2.4.2 and 3.0.0 latest alpha I get

Audacity Startup Failure
An unrecoverable error has occurred during startup

As folk seem keen for us to support exFat with Audacity on Win and Mac I shall log this as a bug tomorrow.

Thanks for the report, much appreciated :slight_smile: :sunglasses:


On w10 with 2.4.2 and latest 3.0.0 alpha having the Temporary files directory set on an exFAT formatted USB stick works fine.

So this is just a Mac issue.


I can confirm that exFAT does not work for Audacity’s Temp folder.

My speculation is that it may be a permissions issue, as exFAT does not support file permissions.
Probably not a good idea to use exFAT for a hard drive anyway - the format was developed by Microsoft for flash drives.

Once again Jarome thank you so much for alerting us to this issue, very much appreciated :slight_smile: :sunglasses:

I have logged this as a P1 (release blocking) bug: http://bugzilla.audacityteam.org/show_bug.cgi?id=2626

I’m glad you quickly found your workaround and thanks for reporting back with that - a question for you:
Q: is your USB drive fast enough for live projects on Audacity ?

I do a lot of QA testing with USB sticks and drives and I always find them painfully slow when used with live test projects?


It is a solid state USB drive, so very fast.

Thanks for the update info.

Which make and model is it please?


2TB Samsung T7

Close but no cigar.
It’s because FAT / exFAT do not support Unix socket files, which are used by Audacity on macOS and Linux for single instance checking.

So, Audacity needs to somehow check on the file system of the temp directory before accepting a change. At the very least, put a notice in the user GUI that FAT and ExFAT are not allowed.

People are working on it.

That is what is likely to be happening.

Plus there will be stuff about it in the Manual (oh and the 3.0.0 Release Notes).